نمایش نتایج: از شماره 1 تا 14 از مجموع 14
سپاس ها 9سپاس
  • 3 توسط shahani
  • 2 توسط mehrzadmo
  • 1 توسط shahani
  • 2 توسط mthm
  • 1 توسط shahani

موضوع: چطور در یک روتر میکروتیک میزان استفاده appهای مختلف از اینترنت رو بسنجیم

  
  1. #1
    نام حقيقي: mary

    عضو عادی
    تاریخ عضویت
    Feb 2012
    محل سکونت
    شیراز
    نوشته
    353
    سپاسگزاری شده
    46
    سپاسگزاری کرده
    188

    چطور در یک روتر میکروتیک میزان استفاده appهای مختلف از اینترنت رو بسنجیم

    سلام دوستان
    چطور میتونیم در یک شبکه که از میکروتیک به عنوان روتر استفاده میکنه میزان پهنای باند مصرف شده برای اینستاگرام، واتساپ، وب‌گردی و ... رو متوجه بشیم؟
    با تشکر



    موضوعات مشابه:

  2. #2
    نام حقيقي: ali

    عضو عادی
    تاریخ عضویت
    Jun 2010
    محل سکونت
    mashhad
    نوشته
    348
    سپاسگزاری شده
    264
    سپاسگزاری کرده
    33
    نرم افزار ها در لایه هفت قرار دارند و روتر روی لایه دو و سه داره کار میکنه
    انجام این کار ساده نیست و در مجموع ممکنه نتایج بدست اومده نیز دقیق نباشن
    بهترین کار اینه که بصورت نرم افزاری مصرف هر یک از برنامه ها را در سیستم عامل های مصرف کنندگان و کاربرها بررسی کنید .

    اما به هرحال راه هایی که میشه از داخل روتر پیشنهاد داد یکی اینکه سرور های مقصد برنامه های مورد نظر را بطور دقیق پیدا کرده و در روتر وارد کنید .
    برای هر یک از برنامه ها رولی بنویسید که داده های اون برنامه را مارک کند و در مجموع مقدار داده های مارک شده را در بخش وضعیت اون رول میتونید مشاهده کنید تا زمانی که روتر شما خاموش نشده باشه . (میتونید با اسکریپت اطلاعات را برای جلوگیری از حذف در محلی ذخیره کنید )



    به عنوان مثال در تصویر بالا بسته های داده با آدرس های آی پی به مقصد سرورهای تلگرام مارک میشوند تا در روتر از داخل کانال امن فیلترشکن عبور داده شوند و کاربران برای استفاده از این برنامه بصورت تک به تک نیاز به استفاده از فیلترشکن نداشته باشند و برنامه تلگرام بطور ساده و معمولی در اتصال با وای فای روتر در دسترس کابران باشد .
    در اینجا مشاهده میکنید که مقدار داده ای که در مدت زمان آخرین روشن بودن روتر برای این برنامه انتقال داده شده است ، قابل روئیت است.


    روش دیگر مارک گذاری برنامه ها در لایه هفت است ، سیستم عامل روتر میکروتیک امکانی را برای شناسایی داده های برنامه در لایه هفت فراهم کرده که البته کامل و دقیق نیست ، از طرف دیگر فشار زیادی را به پردازنده وارد میکنه .
    میتونید مارک گذاری داده های برنامه ها را با بکارگیری این قسمت انجام دهید و سپس دیتا جابجا شده را در محلی ذخیره کنید،
    این روش بسیار دشوار است و نیاز به تخصص بیشتری داره ، نیاز هست که برای تک نک برنامه ها کد شناسایی لایه هفت آنها را وارد روتر کنید.
    بعضی از آنها روی اینترنت وجود دارند.

    - - - ادامه - - -

    در ضمن به این نکته توجه داشته باشید
    شما به هر روشی اقدام به پیاده سازی این مسئله در روتر بکنید ، درصورتی که کاربرشما از فیلترشکن استفاده کند ...
    روش شما با شکست مواجه خواهد شد و روتر قادر به شناسایی داده های برنامه های مختلف و تفکیک سازی نخواهد بود .


    mthm، mthm و mthm سپاسگزاری کرده‌اند.

  3. #3
    نام حقيقي: sima963

    تازه وارد
    تاریخ عضویت
    Oct 2018
    محل سکونت
    تهران
    نوشته
    2
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    0
    سلام ممنون از مطلب خوبتون


    http://yazdpich.com/product/%d9%be%db%8c%da%86-%d8%a7%d9%85-%d8%af%db%8c-%d8%a7%d9%81/

  4. #4
    نام حقيقي: mary

    عضو عادی
    تاریخ عضویت
    Feb 2012
    محل سکونت
    شیراز
    نوشته
    353
    سپاسگزاری شده
    46
    سپاسگزاری کرده
    188
    ممنونم از پاسختون
    نقل قول نوشته اصلی توسط shahani نمایش پست ها
    نرم افزار ها در لایه هفت قرار دارند و روتر روی لایه دو و سه داره کار میکنه
    انجام این کار ساده نیست و در مجموع ممکنه نتایج بدست اومده نیز دقیق نباشن
    بهترین کار اینه که بصورت نرم افزاری مصرف هر یک از برنامه ها را در سیستم عامل های مصرف کنندگان و کاربرها بررسی کنید .

    اما به هرحال راه هایی که میشه از داخل روتر پیشنهاد داد یکی اینکه سرور های مقصد برنامه های مورد نظر را بطور دقیق پیدا کرده و در روتر وارد کنید .
    برای هر یک از برنامه ها رولی بنویسید که داده های اون برنامه را مارک کند و در مجموع مقدار داده های مارک شده را در بخش وضعیت اون رول میتونید مشاهده کنید تا زمانی که روتر شما خاموش نشده باشه . (میتونید با اسکریپت اطلاعات را برای جلوگیری از حذف در محلی ذخیره کنید )



    به عنوان مثال در تصویر بالا بسته های داده با آدرس های آی پی به مقصد سرورهای تلگرام مارک میشوند تا در روتر از داخل کانال امن فیلترشکن عبور داده شوند و کاربران برای استفاده از این برنامه بصورت تک به تک نیاز به استفاده از فیلترشکن نداشته باشند و برنامه تلگرام بطور ساده و معمولی در اتصال با وای فای روتر در دسترس کابران باشد .
    در اینجا مشاهده میکنید که مقدار داده ای که در مدت زمان آخرین روشن بودن روتر برای این برنامه انتقال داده شده است ، قابل روئیت است.


    روش دیگر مارک گذاری برنامه ها در لایه هفت است ، سیستم عامل روتر میکروتیک امکانی را برای شناسایی داده های برنامه در لایه هفت فراهم کرده که البته کامل و دقیق نیست ، از طرف دیگر فشار زیادی را به پردازنده وارد میکنه .
    میتونید مارک گذاری داده های برنامه ها را با بکارگیری این قسمت انجام دهید و سپس دیتا جابجا شده را در محلی ذخیره کنید،
    این روش بسیار دشوار است و نیاز به تخصص بیشتری داره ، نیاز هست که برای تک نک برنامه ها کد شناسایی لایه هفت آنها را وارد روتر کنید.
    بعضی از آنها روی اینترنت وجود دارند.

    - - - ادامه - - -

    در ضمن به این نکته توجه داشته باشید
    شما به هر روشی اقدام به پیاده سازی این مسئله در روتر بکنید ، درصورتی که کاربرشما از فیلترشکن استفاده کند ...
    روش شما با شکست مواجه خواهد شد و روتر قادر به شناسایی داده های برنامه های مختلف و تفکیک سازی نخواهد بود .




  5. #5
    نام حقيقي: mary

    عضو عادی
    تاریخ عضویت
    Feb 2012
    محل سکونت
    شیراز
    نوشته
    353
    سپاسگزاری شده
    46
    سپاسگزاری کرده
    188
    با teraffic-flow چطور؟
    کسی از دوستان در این زمینه تجربه داره؟



  6. #6
    نام حقيقي: مهرزاد مقدس

    عضو ویژه/سرپرست بخش‌های Mikrotik و Wireless
    تاریخ عضویت
    Sep 2006
    محل سکونت
    فارس
    نوشته
    4,295
    سپاسگزاری شده
    4539
    سپاسگزاری کرده
    2272
    نوشته های وبلاگ
    6
    netflow دقیقا کارش اینه . یه نرم افزار انالایزر مثل manage engine netflow analyzer روی یه سیستم نصب کنید و با میکروتیک ترافیک رو به سمتش بفرستید .


    mthm و sorenaseir سپاسگزاری کرده‌اند.
    MikroTik Certified Trainer & Consultant
    Mikrotik Official Distributor

  7. #7
    نام حقيقي: mary

    عضو عادی
    تاریخ عضویت
    Feb 2012
    محل سکونت
    شیراز
    نوشته
    353
    سپاسگزاری شده
    46
    سپاسگزاری کرده
    188
    ممنونم
    و یه سوال دیگه : بازهم باید IP سرور اون app ها را بدونم؟
    با تشکر



  8. #8
    نام حقيقي: mary

    عضو عادی
    تاریخ عضویت
    Feb 2012
    محل سکونت
    شیراز
    نوشته
    353
    سپاسگزاری شده
    46
    سپاسگزاری کرده
    188
    این کد چطوره؟ ادعا داره که ترافیک مربوط به واتساپ رو پیدا میکنه
    Whatsapp Finder Script RouterOS v6.33rc33 #
    # This here is the Version for New Terminal #
    # add to Scheduler and run with Time Interval 00:01:00 #
    {
    # STEP 1 set your prefered List Name here or leave it as it is #
    :global lst "Whatsapp";
    # Use DNS Entrys and add dst Address to the Firewall Address-list #
    :foreach i in=[/ip dns cache all find where (name~"whatsapp" || name~"whatscom") && (type="A") ] do={
    :local tmpAddress [/ip dns cache get $i address];
    delay delay-time=10ms
    # prevent script from using all cpu time #
    :if ( [/ip firewall address-list find where address=$tmpAddress] = "") do={
    :local cacheName [/ip dns cache get $i name] ;
    :log info ("added entry: $cacheName $tmpAddress");
    /ip firewall address-list add address=$tmpAddress list="$lst" comment=$cacheName;
    }
    }

    }




  9. #9
    نام حقيقي: ali

    عضو عادی
    تاریخ عضویت
    Jun 2010
    محل سکونت
    mashhad
    نوشته
    348
    سپاسگزاری شده
    264
    سپاسگزاری کرده
    33
    تمام کاری که این اسکریپت میکنه اینه که در صورت فعال بودن DNS سرور در روتر
    از روی درخواست های DNS که کاربر جهت دریافت آی پی سرور واتس آپ ارسال میکند، یک لیست آدرس از آی پی های این برنامه می سازد .
    که می توانید در ایده ای جهت اندازه گیری ترافیک از آن استفاده کنید .

    ایراد هایی که این اسکریپت دارد :
    - اگر آی پی سرورهایی از واتس آپ(به عنوان نمونه) تغییر کند ، لیست بدرستی بروز رسانی نمی شود و آدرس های قدیمی تر که ممکن است در حال حاضر مربوط به سرورها و سرویس های دیگرد در دنیا باشد - همچنان جزو برنامه واتس آب قلمداد میشود و ترافیک عبوری به اشتباه برای استفاده از این برنامه درنظر گرفته می شود.

    - اگر برنامه واتس آپ اتصال های مستقیمی برای ارتباط و تبادل دیتا با سرورهای خود برقرار کنند که قبل از آن، اقدام به دریافت آدرس آنها از طریق DNS نکرده باشد ، (برنامه نویسان از ابتدا آی پی مقصد را در کدهای برنامه ثبت کرده باشند) که به هیچ عنوان چنین مسئله ای ، کاری غیر معمول و دور از ذهن نیست ،
    بخش درخواست آی پی به وسیله DNS بطور کلی انجام نمی پذیرد و درنتیجه این اسکریپت هیچگونه عملکردی نخواهد داشت .

    - اگر کاربر از پراکسی استفاده کند ، داده های DNS نیز از طریق درگاه های دیگر و تانل رمزگذاری شده ، عبور خواهد کرد و در نتیجه روتر امکان خواندن اطلاعات DNS را نداشته و این اسکریپت کار نخواهد کرد .


    بطور کلی روش دقیق تر این است که برنامه مورد نظر برای کنترل را مدت زیادی با یک دستگاه تحت کنترل روتر مورد استفاده قرار داد و با استفاده از بخش کانکشن فایروال ، ارتباطات دستگاه مورد نظر را بدقت بررسی کرد و تک به تک آدرس های آی پی مقصد سرور به عنوان مثال واتس آپ را بصورت دستی برداشته و در لیست آدرسی اضافه نمود . (به دلیل تعویض آدرس ها و تغییرات در آنها ، انجام این کار در دوره زمانی های مختلف و متوالی بطور همیشگی مورد نیاز خواهد بود)
    همینطور میتوان از اینترنت و افراد برای بدست آوردن آدرس آی پی سرورهای یک برنامه خاص کمک گرفت.


    mthm سپاسگزاری کرده است.

  10. #10
    نام حقيقي: mary

    عضو عادی
    تاریخ عضویت
    Feb 2012
    محل سکونت
    شیراز
    نوشته
    353
    سپاسگزاری شده
    46
    سپاسگزاری کرده
    188
    با سلا ممنونم از توضیحاتتون. درست میفرمایید. منم خودم دقت کردم اصلا خیلی وقتها که dns هم مشکل داره،در whatsapp پیامها رد و بدل میشه

    نقل قول نوشته اصلی توسط shahani نمایش پست ها
    تمام کاری که این اسکریپت میکنه اینه که در صورت فعال بودن DNS سرور در روتر
    از روی درخواست های DNS که کاربر جهت دریافت آی پی سرور واتس آپ ارسال میکند، یک لیست آدرس از آی پی های این برنامه می سازد .
    که می توانید در ایده ای جهت اندازه گیری ترافیک از آن استفاده کنید .



    shahani و sorenaseir سپاسگزاری کرده‌اند.

  11. #11
    نام حقيقي: mary

    عضو عادی
    تاریخ عضویت
    Feb 2012
    محل سکونت
    شیراز
    نوشته
    353
    سپاسگزاری شده
    46
    سپاسگزاری کرده
    188
    البته قاعدتا هر ترافیکی که کاربران از طریق فیلترشکن بزنند هم نمیتونیم بررسی کنیم. درسته؟



  12. #12
    نام حقيقي: ali

    عضو عادی
    تاریخ عضویت
    Jun 2010
    محل سکونت
    mashhad
    نوشته
    348
    سپاسگزاری شده
    264
    سپاسگزاری کرده
    33
    ترافیک مصرفی یک کاربر قابل برسی هست ، اما چون بسته های داده حقیقی در قالب یک بسته پوششی به سرور پروکسی ارسال میشه ، قابل تشخیص نیست که بسته برای چه کاری ارسال شده و محتوای اون چی هست .

    در مورد DNS درست می فرمایید ، من به عنوان برنامه نویس میتونم یک آدرس مرجع روی اینترنت طراحی کنم که نرم افزارم برای دریافت آدرس های مورد نیاز به اون آدرس مرجع مراجعه کنه و پس از آن ارتباطات خودش را برقرار کند ، به این صورت برنامه من دیگر از DNS استفاده نمیکند ، و یا بعضی ارتباطات از طریق DNS انجام بپذیرد و بعضی دیگر خیر .
    در هر صورت این اشتباهه اگه فکر کنیم با اتکا به چنین اسکریپتی (که آدرس های یک برنامه را از روی داده های DNS پیدا میکند) ، می توانیم تمام ترافیک رد و بدل شده را اندازه بگیریم.


    mthm سپاسگزاری کرده است.

  13. #13
    نام حقيقي: mary

    عضو عادی
    تاریخ عضویت
    Feb 2012
    محل سکونت
    شیراز
    نوشته
    353
    سپاسگزاری شده
    46
    سپاسگزاری کرده
    188
    باز هم ممنونم، از توضیحتون.
    میخوام از traffic flow استفاده کنم، اما address list نمیگیره و باید آدرسها رو یکی یکی در اون تعریف کنم.
    آدرسهای واتساپ رو از اینجا گرفتم
    https://myip.ms/view/ip_owners/90500/Whatsapp_Inc.html
    درسته؟
    با تشکر



  14. #14
    نام حقيقي: sorenaseir

    تازه وارد
    تاریخ عضویت
    Oct 2018
    محل سکونت
    tehran
    نوشته
    1
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    2
    تشکر فراوان از راهنمایی هایتان



کلمات کلیدی در جستجوها:

هیچ کلمه ای ثبت نشده است.

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •