نمایش نتایج: از شماره 1 تا 8 از مجموع 8
سپاس ها 1سپاس

موضوع: لود بالانس fail over بین 2 ipip تانل در میکروتیک

  
  1. #1
    نام حقيقي: سعید قاسمی

    تازه وارد
    تاریخ عضویت
    Sep 2014
    محل سکونت
    اهواز
    نوشته
    15
    سپاسگزاری شده
    3
    سپاسگزاری کرده
    4

    لود بالانس fail over بین 2 ipip تانل در میکروتیک

    سلام
    من 2 شبکه لن دارم که با ipip تانل به هم متصل هستن. بستر ارتباطیمون هم قبلا اینترنت بود و جدیدا سروییس ptp مخابرات گرفتم کیفیتش هم خوبه که یه ارتباط از نوع لایه 2 بهمون میده. حالا من میخوام یه ipip تانل روی بستر اینترنت داشته باشم و یه ipip تانل روی بستر دیتای مخابرات. که اگه دیتای ما مشکلی پیدا کرد و قطع شد به اون یکی تانل که بسترش اینترنت هست سویچ کنه جناب میکروتیک. هر 2 سمت هم اینترنت و هم دیتا وارد میکروتیک ها میشه. یه چیزی شبیه fail over. میشود آیا؟؟



    موضوعات مشابه:

  2. #2
    نام حقيقي: مهرزاد مقدس

    عضو ویژه/سرپرست بخش‌های Mikrotik و Wireless
    تاریخ عضویت
    Sep 2006
    محل سکونت
    فارس
    نوشته
    4,383
    سپاسگزاری شده
    4620
    سپاسگزاری کرده
    2290
    نوشته های وبلاگ
    6
    یه مقدار اسکریپت نویسی داره ولی ممکنه .


    MikroTik Certified Trainer & Consultant
    Mikrotik Official Distributor

  3. #3
    نام حقيقي: سعید قاسمی

    تازه وارد
    تاریخ عضویت
    Sep 2014
    محل سکونت
    اهواز
    نوشته
    15
    سپاسگزاری شده
    3
    سپاسگزاری کرده
    4
    نقل قول نوشته اصلی توسط mehrzadmo نمایش پست ها
    یه مقدار اسکریپت نویسی داره ولی ممکنه .

    اگر واستون مقدوره بزارید واسم اسکریپت هاشو لطفا. مرسی



  4. #4

  5. #5
    نام حقيقي: احسان لاجوردی

    خواننده
    تاریخ عضویت
    Dec 2013
    محل سکونت
    تهران
    نوشته
    132
    سپاسگزاری شده
    99
    سپاسگزاری کرده
    26
    نقل قول نوشته اصلی توسط saeedbambo نمایش پست ها
    سلام
    من 2 شبکه لن دارم که با ipip تانل به هم متصل هستن. بستر ارتباطیمون هم قبلا اینترنت بود و جدیدا سروییس ptp مخابرات گرفتم کیفیتش هم خوبه که یه ارتباط از نوع لایه 2 بهمون میده. حالا من میخوام یه ipip تانل روی بستر اینترنت داشته باشم و یه ipip تانل روی بستر دیتای مخابرات. که اگه دیتای ما مشکلی پیدا کرد و قطع شد به اون یکی تانل که بسترش اینترنت هست سویچ کنه جناب میکروتیک. هر 2 سمت هم اینترنت و هم دیتا وارد میکروتیک ها میشه. یه چیزی شبیه fail over. میشود آیا؟؟
    با میکروتیک اینکارو کردم ولی لود بالانسینگش خیلی ضعیفه . برای اینکار بهتره از تجهیزات مخصوص همین کار استفاده کنید. قابلیت speedfusion تو تجهیزات peplink دقیقا برای همین کار هستش.



  6. #6
    نام حقيقي: مهرزاد مقدس

    عضو ویژه/سرپرست بخش‌های Mikrotik و Wireless
    تاریخ عضویت
    Sep 2006
    محل سکونت
    فارس
    نوشته
    4,383
    سپاسگزاری شده
    4620
    سپاسگزاری کرده
    2290
    نوشته های وبلاگ
    6
    یه لینک فیل اور دقیقا کجاش مربوط به لود بالانس هست و چجوری میکروتیک توی این کار ضعیفه ؟!


    MikroTik Certified Trainer & Consultant
    Mikrotik Official Distributor

  7. #7
    نام حقيقي: سعید قاسمی

    تازه وارد
    تاریخ عضویت
    Sep 2014
    محل سکونت
    اهواز
    نوشته
    15
    سپاسگزاری شده
    3
    سپاسگزاری کرده
    4
    نقل قول نوشته اصلی توسط HLajevardi نمایش پست ها
    با میکروتیک اینکارو کردم ولی لود بالانسینگش خیلی ضعیفه . برای اینکار بهتره از تجهیزات مخصوص همین کار استفاده کنید. قابلیت speedfusion تو تجهیزات peplink دقیقا برای همین کار هستش.
    از همه دوستانی که زحمت کشیدن پاسخ دادن ممنونم خیلی خیلی لطف کردین.
    اتفاقا یه peplink bpl30 جدیدا خریداری کردم ولی هنوز به دستم نرسیده و واسه تجمیع خطوط اینترنت میخواستم استفاده کنم ازش ولی این vpn bondin رو تست میکنم ببینم به شکل هستش اگه شد یکی دیگه میگیرم.

    بازم متشکرم از همگی



  8. #8
    نام حقيقي: نینجا (سرباز متخصص)

    عضو عادی شناسه تصویری mizogomo
    تاریخ عضویت
    Oct 2010
    محل سکونت
    هسته لینوکس
    نوشته
    467
    سپاسگزاری شده
    240
    سپاسگزاری کرده
    33
    با سلام خدمت دوست عزیز
    همونطور که جناب مهرزاد فرمودن کارشدنی هست

    فیل آور بر اساس توازن پاکت های icmp کار میکنه پس داستان یکم آسون میشه ولی موردی که هست ببینید گتوی شما به سمت کدام dns ها مسیردهی میشن که میتونه 8.8.8.8 یا هر dns سرور دیگه باشه که این اصول بر اساس میزان time oute سرویس دهنده دامنت کار میکنه

    شما میای تعریف میکنی که بعد از 10 تا time out فیل بشه به لینک شماره دوم

    تو اینترنت سرچ کنی پیدا میکنی من اسکریپت آمادش رو واست میزارم البته چون تونل ip داری داستان کمی فرق میکنه ولی مشکل داشتی بگو

    # ------------------- header -------------------
    # Script by Tomas Kirnak, version 1.0.7
    # If you use this script, or edit and
    # re-use it, please keep the header intact.
    #
    # For more information and details about
    # this script please visit the wiki page at
    # Failover Scripting - MikroTik Wiki
    # ------------------- header -------------------



    # ------------- start editing here -------------
    # Edit the variables below to suit your needs

    # Please fill the WAN interface names
    :local InterfaceISP1 ether1
    :local InterfaceISP2 ether2

    # Please fill the gateway IPs (or interface names in case of PPP)
    :local GatewayISP1 1.1.1.1
    :local GatewayISP2 2.2.2.2

    # Please fill the ping check host - currently: resolver1.opendns.com
    :local PingTarget 208.67.222.222

    # Please fill how many ping failures are allowed before fail-over happends
    :local FailTreshold 3

    # Define the distance increase of a route when it fails
    :local DistanceIncrease 2

    # Editing the script after this point may break it
    # -------------- stop editing here --------------



    # Declare the global variables
    :global PingFailCountISP1
    :global PingFailCountISP2

    # This inicializes the PingFailCount variables, in case this is the 1st time the script has ran
    :if ([:typeof $PingFailCountISP1] = "nothing") do={:set PingFailCountISP1 0}
    :if ([:typeof $PingFailCountISP2] = "nothing") do={:set PingFailCountISP2 0}

    # This variable will be used to keep results of individual ping attempts
    :local PingResult



    # Check ISP1
    :set PingResult [ping $PingTarget count=1 interface=$InterfaceISP1]
    ut $PingResult

    :if ($PingResult = 0) do={
    :if ($PingFailCountISP1 < ($FailTreshold+2)) do={
    :set PingFailCountISP1 ($PingFailCountISP1 + 1)

    :if ($PingFailCountISP1 = $FailTreshold) do={
    :log warning "ISP1 has a problem en route to $PingTarget - increasing distance of routes."
    :foreach i in=[/ip route find gateway=$GatewayISP1 && static] do=\
    {/ip route set $i distance=([/ip route get $i distance] + $DistanceIncrease)}
    :log warning "Route distance increase finished."
    }
    }
    }
    :if ($PingResult = 1) do={
    :if ($PingFailCountISP1 > 0) do={
    :set PingFailCountISP1 ($PingFailCountISP1 - 1)

    :if ($PingFailCountISP1 = ($FailTreshold -1)) do={
    :log warning "ISP1 can reach $PingTarget again - bringing back original distance of routes."
    :foreach i in=[/ip route find gateway=$GatewayISP1 && static] do=\
    {/ip route set $i distance=([/ip route get $i distance] - $DistanceIncrease)}
    :log warning "Route distance decrease finished."
    }
    }
    }



    # Check ISP2
    :set PingResult [ping $PingTarget count=1 interface=$InterfaceISP2]
    ut $PingResult

    :if ($PingResult = 0) do={
    :if ($PingFailCountISP2 < ($FailTreshold+2)) do={
    :set PingFailCountISP2 ($PingFailCountISP2 + 1)

    :if ($PingFailCountISP2 = $FailTreshold) do={
    :log warning "ISP2 has a problem en route to $PingTarget - increasing distance of routes."
    :foreach i in=[/ip route find gateway=$GatewayISP2 && static] do=\
    {/ip route set $i distance=([/ip route get $i distance] + $DistanceIncrease)}
    :log warning "Route distance increase finished."
    }
    }
    }
    :if ($PingResult = 1) do={
    :if ($PingFailCountISP2 > 0) do={
    :set PingFailCountISP2 ($PingFailCountISP2 - 1)

    :if ($PingFailCountISP2 = ($FailTreshold -1)) do={
    :log warning "ISP2 can reach $PingTarget again - bringing back original distance of routes."
    :foreach i in=[/ip route find gateway=$GatewayISP2 && static] do=\
    {/ip route set $i distance=([/ip route get $i distance] - $DistanceIncrease)}
    :log warning "Route distance decrease finished."
    }
    }
    }



کلمات کلیدی در جستجوها:

هیچ کلمه ای ثبت نشده است.

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •