نمایش نتایج: از شماره 1 تا 14 از مجموع 14
سپاس ها 5سپاس
  • 1 توسط mrsalesi
  • 1 توسط minoor
  • 2 توسط elderado
  • 1 توسط ksi_xi_nt

موضوع: چگونگی ری دایرکت کلیه کاربران متصل به مودم من ؟

  
  1. #1
    نام حقيقي: amin

    تازه وارد
    تاریخ عضویت
    Sep 2013
    محل سکونت
    کره خاکی
    نوشته
    15
    سپاسگزاری شده
    4
    سپاسگزاری کرده
    10

    چگونگی ری دایرکت کلیه کاربران متصل به مودم من ؟

    با سلام خدمت تمامی بزرگواران
    میخواهم تدبری بچینم
    که تمامی کاربران متصل به وای فای من پس از باز کردن مرورگر گوشی همراه خود به ای پی مورد نظر من تغییر مسیر داده

    در ضمن چون این کار محتملا از عهده مودم معمولی خارج است یک عدد روتر hap litte هم تهیه کرده ایم
    حال گوی چون کنم ؟
    تشکر و سپاس
    (فراموش شد بگم ای پی مورد نظر ای پی یک رایانه همراه در شبکه محلی هست که در آن سایتی بصورت local برقرار است)



    موضوعات مشابه:
    ویرایش توسط minoor : 2016-02-25 در ساعت 08:23 AM

  2. #2
    نام حقيقي: Mask

    عضو عادی شناسه تصویری Mask
    تاریخ عضویت
    Jun 2014
    محل سکونت
    ایران-فعلا اصفهان
    نوشته
    532
    سپاسگزاری شده
    240
    سپاسگزاری کرده
    97
    در بهترین حالت این کار بوسیله میکروتیک قابل انجامه.


    pm_hamze@yahoo.com

  3. #3
    نام حقيقي: amin

    تازه وارد
    تاریخ عضویت
    Sep 2013
    محل سکونت
    کره خاکی
    نوشته
    15
    سپاسگزاری شده
    4
    سپاسگزاری کرده
    10
    تشکر

    با تنظیماتش آشنایی دارید ؟
    ممکنه توضیحات بیشتر و ریزتری راجع به تنظیمات بدید



  4. #4
    نام حقيقي: amin

    تازه وارد
    تاریخ عضویت
    Sep 2013
    محل سکونت
    کره خاکی
    نوشته
    15
    سپاسگزاری شده
    4
    سپاسگزاری کرده
    10
    نقل قول نوشته اصلی توسط Mask نمایش پست ها
    در بهترین حالت این کار بوسیله میکروتیک قابل انجامه.
    دوستان میکروتیک کار
    کسی نیست لطف کنه راهنمایی کنه
    بعد اتصال کاربران به hap litte و باز کردن مرورگر گوشی چطور بلافاصله به سایت یا ip خاصی هدایت بشند ؟؟!
    ممنون



  5. #5
    نام حقيقي: محمد

    تازه وارد
    تاریخ عضویت
    Nov 2013
    محل سکونت
    ایران
    نوشته
    2
    سپاسگزاری شده
    1
    سپاسگزاری کرده
    3
    سلام

    من هم همین سوال را دارم.

    کمی تحقیق کردم ولی عملی نشد

    1 - استفاده از مودم وایر لس+isa server + dhcp server + iis :

    مودم خوذش آی پی نمیده و میفرسته به dhcp که روی سرور نصب هست
    isa server همه خروجی ها را ریداریکت میکنه روی سایتی که روی iis درست کریم

    مشکل با https مسکل داره و ریدایرکت نمی کنه


    روش دوم :

    میکروتیک را روی ماشین مجازی بیاریم بالا

    به مشکل برخوردم

    چون کار با میکروتیک را بلد نبودم و winbox هم هر کاری کردم کانکت نشد

    دوستان لطفا کمک کنید


    minoor سپاسگزاری کرده است.

  6. #6
    نام حقيقي: amin

    تازه وارد
    تاریخ عضویت
    Sep 2013
    محل سکونت
    کره خاکی
    نوشته
    15
    سپاسگزاری شده
    4
    سپاسگزاری کرده
    10
    دوست عزیز نتیجه گرفتید

    برای من http رو هم ریدایرکت نمیکنه پایین کروم که نگاه میکنه مینویسه . . . . . resolve host
    نمی دنم مشکل از dns یا فایرواله
    شاید هم از تنظیمات پیشفرض میکروتیک که برای اینترنت دار کردن سیستمم استفاده کرده quick set = ap هست.
    چون یه سری رول فایروال اتومات اضاف میکنه.
    من رول زیر رو در نت تنظیم کردم:

    /ip
    firewall
    nat
    add chain=dstnat
    src-address=192.168.1.0/24
    protocol=tcp
    dst-port=80,443
    action=dstnat
    to-address=192.168.1.10
    to-ports=80


    ویرایش توسط minoor : 2016-03-17 در ساعت 07:32 AM

  7. #7
    نام حقيقي: amin

    تازه وارد
    تاریخ عضویت
    Sep 2013
    محل سکونت
    کره خاکی
    نوشته
    15
    سپاسگزاری شده
    4
    سپاسگزاری کرده
    10
    نقل قول نوشته اصلی توسط mrsalesi نمایش پست ها
    سلام

    من هم همین سوال را دارم.

    کمی تحقیق کردم ولی عملی نشد

    1 - استفاده از مودم وایر لس+isa server + dhcp server + iis :

    مودم خوذش آی پی نمیده و میفرسته به dhcp که روی سرور نصب هست
    isa server همه خروجی ها را ریداریکت میکنه روی سایتی که روی iis درست کریم

    مشکل با https مسکل داره و ریدایرکت نمی کنه


    روش دوم :

    میکروتیک را روی ماشین مجازی بیاریم بالا

    به مشکل برخوردم

    چون کار با میکروتیک را بلد نبودم و winbox هم هر کاری کردم کانکت نشد

    دوستان لطفا کمک کنید
    برای بار اول باید با میکروتیک در یک شبکه قرار بگیری تا بتونی بهش متصل بشی:
    ماشین مجازی رو که نصب کردی همراش یک یا چند کارت شبکه هم نصب میشه با دستور ipconfig در cmd میتونی ببینید ای پی ها رو.(که البته قابل تغییر هم هستند)
    اگه هم میخوای کارت شبکه مجازی ماشین با کارت شبکه فیزیکی pc در یه رنج ای پی قرار بگیره کارت ماشین رو در حالت بریج bridge قرار بده.
    اطلاعات بیشتر در این زمینه اینجا هست
    =========================
    مرحله دوم باید میکروتیک رو که در ماشین مجازی نصب و بالا اوردی ای پی بدی از همون رنجی که کارت شبکه فیزیکیت قرار داره خیلی راحته با یک خط دستور:
    البته قبلش باید به خط فرمان میکروتیک در ماشین دسترسی پیدا کنی
    یوزر پیشفرض admin هست و پسورد هم نداره
    بعد ای پی رو به شکل زیر وارد میکنی :

    admin@MikroTik] > ip address add address=192.168.90.1/24 interface=ether1
    یکم از دستور رو که بنویسی بعد کلید tab رو بزن خودش دستورت رو کامل میکنه
    ================================================

    البته یه راه میانبر داره :
    اینکه به جایی که روی میکروتی ای پی ست کنی بصورت دستی ای پی کارت شبکه رو، مجازی یا فیزیکی (هر کدوم رو که استفاده میکنی) رو در بازه رنج ای پی پیش فرض میکروتیک قرار بده
    ای پی پیشفرظ میکروتیک ها 192.168.88.1 هست با سابنت ماسک 255.255.255.0
    ================================================
    حالا بعد این مراحل اگه وینباکس رو باز کنی باید بتونی بهش وصل بشی جای پسورد رو هم خالی بزار.(امیدوارم توضیحاتم درست باشه)


    البته این روش هم باید کاربردی و جالب باشه
    1 - استفاده از مودم وایر لس+isa server + dhcp server + iis :
    اگه امکانش هست کمی در موردش توضیح بدید مخصوصا در مورد ریدایرکت با سرور مجازی و ویندوز معمولی نمیشه اینکار رو کرد ؟


    ویرایش توسط minoor : 2016-03-17 در ساعت 08:22 AM
    mrsalesi سپاسگزاری کرده است.

  8. #8
    نام حقيقي: محمد

    تازه وارد
    تاریخ عضویت
    Nov 2013
    محل سکونت
    ایران
    نوشته
    2
    سپاسگزاری شده
    1
    سپاسگزاری کرده
    3
    نقل قول نوشته اصلی توسط minoor نمایش پست ها
    برای بار اول باید با میکروتیک در یک شبکه قرار بگیری تا بتونی بهش متصل بشی:
    ماشین مجازی رو که نصب کردی همراش یک یا چند کارت شبکه هم نصب میشه با دستور ipconfig در cmd میتونی ببینید ای پی ها رو.(که البته قابل تغییر هم هستند)
    اگه هم میخوای کارت شبکه مجازی ماشین با کارت شبکه فیزیکی pc در یه رنج ای پی قرار بگیره کارت ماشین رو در حالت بریج bridge قرار بده.
    اطلاعات بیشتر در این زمینه اینجا هست
    =========================
    مرحله دوم باید میکروتیک رو که در ماشین مجازی نصب و بالا اوردی ای پی بدی از همون رنجی که کارت شبکه فیزیکیت قرار داره خیلی راحته با یک خط دستور:
    البته قبلش باید به خط فرمان میکروتیک در ماشین دسترسی پیدا کنی
    یوزر پیشفرض admin هست و پسورد هم نداره
    بعد ای پی رو به شکل زیر وارد میکنی :

    admin@MikroTik] > ip address add address=192.168.90.1/24 interface=ether1
    یکم از دستور رو که بنویسی بعد کلید tab رو بزن خودش دستورت رو کامل میکنه
    ================================================

    البته یه راه میانبر داره :
    اینکه به جایی که روی میکروتی ای پی ست کنی بصورت دستی ای پی کارت شبکه رو، مجازی یا فیزیکی (هر کدوم رو که استفاده میکنی) رو در بازه رنج ای پی پیش فرض میکروتیک قرار بده
    ای پی پیشفرظ میکروتیک ها 192.168.88.1 هست با سابنت ماسک 255.255.255.0
    ================================================
    حالا بعد این مراحل اگه وینباکس رو باز کنی باید بتونی بهش وصل بشی جای پسورد رو هم خالی بزار.(امیدوارم توضیحاتم درست باشه)


    البته این روش هم باید کاربردی و جالب باشه
    1 - استفاده از مودم وایر لس+isa server + dhcp server + iis :
    اگه امکانش هست کمی در موردش توضیح بدید مخصوصا در مورد ریدایرکت با سرور مجازی و ویندوز معمولی نمیشه اینکار رو کرد ؟


    تشکر از مطالب شما البته وفت نکردم تست کنم ولی به محض اینکه تستش کردم نتیجه را می گذارم :

    اما راجع به مودم وایر لس+isa server + dhcp server + iis :

    مودم نباید IP از خودش بدهد و باید از یک کامپیوتر سرور بگیره (dhcp) ، isa server روی همون سروری هست که dhcp هست و همه ریکوئست ها را بلاک می کنه بجر DNS ها و DHCP ها ،

    درخواست های http را هم بلاک میکنه و ریدایرکت می کنه روی iis ( وبسایتی که روی iis قرار دادیم)


    مشکل در خواست های https هست که ریدایرکت نمی شوند!!!!!

    .لی نصفه نیمه کار می دهد



  9. #9
    نام حقيقي: amin

    تازه وارد
    تاریخ عضویت
    Sep 2013
    محل سکونت
    کره خاکی
    نوشته
    15
    سپاسگزاری شده
    4
    سپاسگزاری کرده
    10
    نقل قول نوشته اصلی توسط minoor نمایش پست ها
    دوست عزیز نتیجه گرفتید

    برای من http رو هم ریدایرکت نمیکنه پایین کروم که نگاه میکنه مینویسه . . . . . resolve host
    نمی دنم مشکل از dns یا فایرواله
    شاید هم از تنظیمات پیشفرض میکروتیک که برای اینترنت دار کردن سیستمم استفاده کرده quick set = ap هست.
    چون یه سری رول فایروال اتومات اضاف میکنه.
    من رول زیر رو در نت تنظیم کردم:

    /ip
    firewall
    nat
    add chain=dstnat
    src-address=192.168.1.0/24
    protocol=tcp
    dst-port=80,443
    action=dstnat
    to-address=192.168.1.10
    to-ports=80
    به جز https مشکل حل شد
    با تشکر از تمامی دوستان پرشین نت ورک
    هر چند در مدت طرح این سوال ما تازه کار ها رو یاری نکردند
    باز خدا خیر بده به آقای ماسک یک خط نوشت .

    این مطلب رو مینویسم شاید مشکل بنده خدای دیگه ای به دون سوال پرسیدن و انتظار کشیدن حل بشه.

    ===============================

    من از این روش برای ریدایرکت کردن استفاده می کردم

    /ip
    firewall
    nat
    add chain=dstnat
    src-address=192.168.1.0/24
    protocol=tcp
    dst-port=80,443
    action=dstnat
    to-address=192.168.1.10
    to-ports=80

    که به هیچ عنوان جواب نمی گرفتم

    تا اینکه بطور اتفاقی از قسمت ip , setting متوجه accept redirect شدم که تیک نداشت بعد زدن این تیک nat بالا جواب داد (مشکل کلا جای دیگه بود ما چند جور نت از ابداعی گرفته تا ریدایرکت به پروکسی و امثال ذالک رو امتحان کردیم)

    اما متاسفانه هنوز برای https ها مشکل پابرجاست.




    ویرایش توسط minoor : 2016-03-23 در ساعت 06:42 AM

  10. #10
    نام حقيقي: jalal

    عضو عادی
    تاریخ عضویت
    May 2011
    محل سکونت
    مهر
    نوشته
    82
    سپاسگزاری شده
    29
    سپاسگزاری کرده
    42
    خب برای اینکه مشکل پورت نداشته باشی میتونی کلا پورت رو از تنظیمات نت برداری
    شما پورت 443 رو داری به پورت 80 ریدایرکت میکنی
    کلا توی قسمت to port هیچی ننویس



  11. #11
    نام حقيقي: amin

    تازه وارد
    تاریخ عضویت
    Sep 2013
    محل سکونت
    کره خاکی
    نوشته
    15
    سپاسگزاری شده
    4
    سپاسگزاری کرده
    10
    نقل قول نوشته اصلی توسط elderado نمایش پست ها
    خب برای اینکه مشکل پورت نداشته باشی میتونی کلا پورت رو از تنظیمات نت برداری
    شما پورت 443 رو داری به پورت 80 ریدایرکت میکنی
    کلا توی قسمت to port هیچی ننویس

    کلا دو تا مشکل اساسی داره :

    پورت SSL روی پورت 80 جواب نمیده

    جدای این حالت من در حالتی که اینترنت داشتم امتحان کردم در حالت لوکال دوباره به مشکل می خورم چون هم از dns ها جواب نمی گیرم هم مقصد پاسخ درخواست منو نمی ده چون بعد اون عمل ریدایرکت انجام میشه.

    من مسئله رو در انجمن میکروتیک مطرح کردم (بصورت انگلیسی دست و پاشکسته) و پاسخ دادند مسئله روشنتر شد
    توضیحات بیشتر :

    ZeroByte
    firstly - the enable redirects is not what you're thinking - that's referring to whether the router should send ICMP redirect messages when applicable, but this has to do with routing and choice of default GW vs more specific gateway.... not what you're doing.

    The rules you've set should work just fine - except that your web server must now accept ANY web site name and then redirect to your own website.

    Consider this:

    1) I type http://www.example.com/examples/basic.html into my browser.
    2) My computer finds the IP address of the host Example Domain in DNS to be 192.0.2.101
    3) My computer sends request to open a TCP socket to 192.0.2.101 on port 80.
    4) The Mikrotik does dstnat and re-writes the destination IP address on the packet to be 192.168.88.250 and then forwards the packet to your web server
    5) The web server accepts the connection and TCP is established (nat happens on each packet in this process, so I won't mention it anymore)
    6) My computer will then ask the HTTP daemon on your server to please serve the file /examples/basic.html from host Example Domain

    This is where things go off the rails....

    If your server is configured to always "just be itself" regardless of the host name specified by clients, then that's fine - but it will then look for the file my browser requested - it will look in the HTML folder for a sub-folder called "examples" and in that folder, it wants a file called "basic.html" - chances are almost certain that you don't have this file on your server, so the server is going to say "Sorry, buddy - I don't have that file. Error code 404"

    OR - if your server DOES know what hostnames are, it will connect the session to the default website regardless of name, where the above problem happens.... OR - if the server will ONLY respond to requests for its specific host name - then who knows what error it's going to give, but it's going to fail in some way....

    So the solution is to tell your web server that it should use a custom 404 (file not found) error page - and you make a custom 404 page that has a redirect header instructing the browser to go instead to http://192.168.88.250/mywebsite.html (or if you have DNS inside your network, you could use http://your-website-name-here/)

    One more problem with your dstnat rule is that you specify tcp ports 80,443 to match, but specify to-ports=80
    This means that connection attempts to reach port 443 on the web will be redirected to your server on port 80.
    SSL won't work on port 80, so I suggest that you remove the to-ports=80 (leave that unspecified, and the port won't get modified
    )
    Of course now you have another problem - that being you need an SSL certificate for your server so that it can operate on port 443 as well, and unfortunately, this is going to give users a warning message "WARNING: the certificate doesn't match the site you requested" - but there's not really any easy way around this for SSL, but it's probably better to have this happen so that at least the users will know that the connection is doing something. If you just drop port 443 (or map it to port 80) then the connection is just going to sit there until the browser gives up, giving the illusion that they're having a problem with their connection.

    Realize that these days, many people's browsers' default pages are going to be SSL-enabled websites, so you'd rather give the SSL warning than just let the browser open up and not do anything. You could perhaps just reject port 443 (reject with tcp-reset) so that browsers will tell the user "connection refused" immediately, and then they'll try typing in something different - almost certainly without putting https:// at the beginning - and then you'll have them on your website.

    - - - ادامه - - -

    این طور که mrsalesi گفتند فکر کنم بهتر باشه از isa استفاده کنیم


    ویرایش توسط minoor : 2016-03-24 در ساعت 01:16 PM

  12. #12
    نام حقيقي: jalal

    عضو عادی
    تاریخ عضویت
    May 2011
    محل سکونت
    مهر
    نوشته
    82
    سپاسگزاری شده
    29
    سپاسگزاری کرده
    42
    دوست عزیز یه پیشنهاد
    شما دوتا رول برای nat بذار روی mikrotik
    برای دوتا پورت
    ip firewall nat add chain=dstnat src=address=192.168.1.0/24 dst-pot=80 action=dstnat to-address=192.168.1.2 to port=80
    و
    ip firewall nat add chain=dstnat src=address=192.168.1.0/24 dst-port=443 action=dstnat to-address=192.168.1.2 to port=443
    و یا یه رول بنویس ولی هیچی رو مشخص نکن
    ip firewall nat add chain=dstnat src-adres=192.168.1.0/24 action=dstnat to adress=192.168.1.2
    اینجوری تمام درخواستهای این شبکه به طرف اون ip ریدایرکت میشن.
    امیدوارم جواب بگیری


    ksi_xi_nt و minoor سپاسگزاری کرده‌اند.

  13. #13
    نام حقيقي: amin

    تازه وارد
    تاریخ عضویت
    Sep 2013
    محل سکونت
    کره خاکی
    نوشته
    15
    سپاسگزاری شده
    4
    سپاسگزاری کرده
    10
    نقل قول نوشته اصلی توسط elderado نمایش پست ها
    دوست عزیز یه پیشنهاد
    شما دوتا رول برای nat بذار روی mikrotik
    برای دوتا پورت
    ip firewall nat add chain=dstnat src=address=192.168.1.0/24 dst-pot=80 action=dstnat to-address=192.168.1.2 to port=80
    و
    ip firewall nat add chain=dstnat src=address=192.168.1.0/24 dst-port=443 action=dstnat to-address=192.168.1.2 to port=443
    و یا یه رول بنویس ولی هیچی رو مشخص نکن
    ip firewall nat add chain=dstnat src-adres=192.168.1.0/24 action=dstnat to adress=192.168.1.2
    اینجوری تمام درخواستهای این شبکه به طرف اون ip ریدایرکت میشن.
    امیدوارم جواب بگیری

    ممنون دوست عزیز
    من چندین روش و جواب شما رو امتحان کردم
    برای ssl که همون پروتکل رمزنگاری هست که روی پورت 443 کار میکه هیچ کدوم از این راه ها جوابگو نیست در هات اسپان هم دقت کنی صفحات که شامل این پروتکل میشن و با https شروع میشن ریدایرکت نمیشن.

    برای پورت 80 هم من با توجه به تنظیماتی که انجام داده بوده در حالتی که آنلاین و میکروتیک اینترنت دار بود جواب گرفتم اما در حالت لوکال که مورد نظر منه جواب نمیده یه بابایی هم خدا خیرش بده در فروم میکروتیک توضیحات کاملی رو دادند اگه شما و اساتید این انجمن راهی رو میدونید کمک کنید (من در زمینه میکروتیک زیاد تجربه ندارم)
    با این حساب فک کنم باید برم دنبال یادگیری ویندوز سرور و isa که لااقل روی پورت 80 در حالت افلاین و لوکال به خوبی جواب بگیرم .
    تشکر



  14. #14
    نام حقيقي: Immortal

    خواننده شناسه تصویری ksi_xi_nt
    تاریخ عضویت
    Dec 2004
    محل سکونت
    SYZ
    نوشته
    114
    سپاسگزاری شده
    52
    سپاسگزاری کرده
    35
    به اینجا سر بزنید:
    https problem on hotspot - MikroTik RouterOS


    minoor سپاسگزاری کرده است.

کلمات کلیدی در جستجوها:

http:forum.persiannetworks.comf77t73915.html

ریدایرکت مودم

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •