نمایش نتایج: از شماره 1 تا 5 از مجموع 5

موضوع: یک AS و چند کش سرور

  
  1. #1
    نام حقيقي: هاشم سکاکی

    عضو عادی شناسه تصویری milad22
    تاریخ عضویت
    May 2005
    محل سکونت
    iran
    نوشته
    2,050
    سپاسگزاری شده
    320
    سپاسگزاری کرده
    197

    Icon10 یک AS و چند کش سرور

    با توجه به استفاده از حجم بالای دیتا و استفاده از پهنای باند های مختلف نیاز به Cache Server های مختلف در یک ISP احساس می شه.

    برای Redirect کردن پکتها در روتر هم می توان از روشهای مختلفی استفاده کرد که می توان از WCCP(Web Cache Control Protocol) یا IP Policity استفاده کرد.
    با هر کدام از روشهای بالا می توان مسیر IP ها را به کش کنترل کرد.
    مثلا با WCCP:
    IP WCCP Web-Cache Redirect-list 1
    حتی می شه دو کش سرور با منابع متفاوت داشت که توسط Peer مسیر کاربران رو به کش سرور دیگر با منبع دیتای دیگر هدایت کنیم و حتی این هدایت بر اساس پهنای باند موجود صورت پذیرد.
    حالا یه سوال:
    می شه از تو روتر لیست های مختلف رو به دوتا کش سرور جدا از یک نوع فرستاد. مثلا دوتا CacheXpress با دو منبع اینترنتی یکسان یا جدا؟







  2. #2


    عضو غیر فعال شناسه تصویری NetMaster
    تاریخ عضویت
    Jun 2004
    نوشته
    376
    سپاسگزاری شده
    5
    سپاسگزاری کرده
    0
    Yes you can

    This is why you have access-list and redirect list options

    So that you can define which network list should be redirected to which cache server!

    Good Luck!




  3. #3
    نام حقيقي: هاشم سکاکی

    عضو عادی شناسه تصویری milad22
    تاریخ عضویت
    May 2005
    محل سکونت
    iran
    نوشته
    2,050
    سپاسگزاری شده
    320
    سپاسگزاری کرده
    197

    Icon12 ممنون دوست عزیز

    سلام NetMaster عزیز.

    خوشحالم از بازگشت شما. و آرزوی موفقیت براتون دارم.

    من کانفیگ روتر رو به شکل زیر تنظیم کردم:

    کد HTML:
     call rsvp-sync			 
    modem call-record terse					 
    ip subnet-zero			 
    ip wccp web-cache redirect-list 2								 
    ip cef	 
    ip name-server 192.9.9.3				 
    ip name-server 195.146.32.130							 
    ! 
    ! 
    ! 
    interface Serial1				 
    ip unnumbered FastEthernet0							
    ip access-group 115 in					 
    ip wccp web-cache redirect out							 
    ip nat outside			 
    encapsulation ppp				 
    no ip mroute-cache				 
    no fair-queue			 
    !
    ! 
    interface FastEthernet0					 
    ip address 192.168.0.1 255.255.255.0 secondary												
    ip address 80.191.240.129 255.255.255.224										 
    ip access-group 115 in					 
    ip access-group 115 out						
    ip nat inside			 
    no ip mroute-cache				 
    duplex full			
    speed auto		 
    ! 
    interface Group-Async0					 
    ip unnumbered FastEthernet0							
    ip nat inside			 
    encapsulation ppp				 
    ip tcp header-compression passive								 
    no ip mroute		 
    async mode interactive					 
    peer default ip address pool setup_pool										
    ppp authentication chap pap							
    group-range 1 120				 
    ! 
    ip local pool setup_pool 80.191.240.134 80.191.240.154													 
    ip local pool setup_pool 192.168.0.11 192.168.0.20													
    ip nat pool My-nat 80.191.240.155 80.191.240.158 prefix-length 24																 
    ip nat inside source list 1 pool My-nat overload												
    ip classless			
    ip route 0.0.0.0 0.0.0.0 Serial1								
    no ip http server				 
    ip pim bidir-enable				 
    ! 
    access-list 1 permit 192.168.0.0 0.0.0.255										 
    access-list 2 permit 80.191.240.0 0.0.0.255										 
    access-list 115 deny udp any any eq tftp										 
    access-list 115 deny tcp any any eq 135										 
    access-list 115 deny tcp any any eq 4444										 
    access-list 115 deny udp any any eq 135										 
    access-list 115 deny udp any any eq netbios-ns												
    access-list 115 deny udp any any eq netbios-dgm												 
    access-list 115 deny tcp any any eq 139										 
    access-list 115 deny udp any any eq netbios-ss												
    access-list 115 deny tcp any any eq 445										 
    access-list 115 deny tcp any any eq 593										 
    access-list 115 permit ip any any								 
    tacacs-server host 80.191.240.130
    no tacacs-server directed-request
    tacacs-server key data
    snmp-server community public RW 15
    !
    !
    با این روش لیست 2 رو به CacheXpress فرستادم.
    حالا با توجه به اینکه ISA نمیتونه WCCP رو پشتیبانی کنه می خوام با ip policy لیست 1 رو به آیزا بفرستم.
    route-map cache permit 2
    match ip address 2
    set ip next-hop 80.191.240.131

    ip policy route-map cache
    ip route-cache policy
    ip route-cache same-interface
    این امکان وجود داره؟
    البته اگه بشه تمام ترافیک رو روی ISA انداخت خیلی بهتره.
    بعد اونجا بشه ترافیک رو هدایت کرد به ماهواره یا مخابرات.
    ممنون می شم اگه در این مورد کسی از دوستان کمک کنه.


    ویرایش توسط milad22 : 2005-07-09 در ساعت 06:51 PM

  4. #4


    عضو غیر فعال شناسه تصویری NetMaster
    تاریخ عضویت
    Jun 2004
    نوشته
    376
    سپاسگزاری شده
    5
    سپاسگزاری کرده
    0
    Yes you can use the route-map command and should do it for you,

    Also you should put the group address of that access-group that belongs to the wccp group-list;

    Router(config)#ip wccp web-cache redirect-list 2 group-addres x.x.x.x

    Good Luck!




  5. #5
    نام حقيقي: هاشم سکاکی

    عضو عادی شناسه تصویری milad22
    تاریخ عضویت
    May 2005
    محل سکونت
    iran
    نوشته
    2,050
    سپاسگزاری شده
    320
    سپاسگزاری کرده
    197
    ممنون از توجهتون.
    ولی با این مطلب که ISA نمی تونه WCCP رو ساپورت کنه راه حلتون چیه؟
    در ضمن شب به خیر..



کلمات کلیدی در جستجوها:

Cisco WCCP کش سرور

چند کش

wccp کش سرور در حجم بالا

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •