نمایش نتایج: از شماره 1 تا 7 از مجموع 7
سپاس ها 5سپاس
  • 2 توسط xp_black
  • 2 توسط xp_black
  • 1 توسط EVERAL

موضوع: راهنمایی برای روت نوشتن

  
  1. #1
    نام حقيقي: مهدى

    عضو عادی شناسه تصویری Mahdi-t
    تاریخ عضویت
    Nov 2011
    محل سکونت
    Tehran
    نوشته
    219
    سپاسگزاری شده
    68
    سپاسگزاری کرده
    60

    راهنمایی برای روت نوشتن

    با فرض سناریوی زیر چطور باید روت استاتیک بنویسم ؟
    من اینجوری نوشتم جواب نداد (برای R1) :

    کد:
    ip route 192.168.1.0 255.255.255.0 192.168.0.0






    موضوعات مشابه:
    Never Give Up





  2. #2
    نام حقيقي: علی رضا

    خواننده شناسه تصویری als_1360
    تاریخ عضویت
    Jul 2003
    محل سکونت
    Tehran
    نوشته
    782
    سپاسگزاری شده
    154
    سپاسگزاری کرده
    22
    نقل قول نوشته اصلی توسط Mahdi-t نمایش پست ها
    با فرض سناریوی زیر چطور باید روت استاتیک بنویسم ؟
    من اینجوری نوشتم جواب نداد (برای R1) :

    کد:
    ip route 192.168.1.0 255.255.255.0 192.168.0.0


    فکر کنم به جای 192.168.0.0 باید آی پی اینترفیس سمت 192.168.1.0 رو بنویسی .



  3. #3
    نام حقيقي: mohsen

    عضو عادی شناسه تصویری xp_black
    تاریخ عضویت
    May 2012
    محل سکونت
    تهران
    نوشته
    229
    سپاسگزاری شده
    192
    سپاسگزاری کرده
    22
    در R1 بنویس:
    ip route 192.168.1.0 255.255.255.0 192.168.0.2
    در R2 بنویس:
    ip route 192.168.2.0 255.255.255.0 192.168.0.1

    - - - Updated - - -

    default gateway را در end pointها ip اینترفیس همون دست روتر را بده تا بتونه packet را به روتر بده


    mehrzadmo و Mahdi-t سپاسگزاری کرده‌اند.

  4. #4
    نام حقيقي: مهدى

    عضو عادی شناسه تصویری Mahdi-t
    تاریخ عضویت
    Nov 2011
    محل سکونت
    Tehran
    نوشته
    219
    سپاسگزاری شده
    68
    سپاسگزاری کرده
    60
    نقل قول نوشته اصلی توسط xp_black نمایش پست ها
    در R1 بنویس:
    ip route 192.168.1.0 255.255.255.0 192.168.0.2
    در R2 بنویس:
    ip route 192.168.2.0 255.255.255.0 192.168.0.1

    - - - Updated - - -

    default gateway را در end pointها ip اینترفیس همون دست روتر را بده تا بتونه packet را به روتر بده
    کار نکردش

    - - - Updated - - -

    r1 خودش r2 رو میبینه ولی end point سمتش نه


    Never Give Up

  5. #5
    نام حقيقي: mohsen

    عضو عادی شناسه تصویری xp_black
    تاریخ عضویت
    May 2012
    محل سکونت
    تهران
    نوشته
    229
    سپاسگزاری شده
    192
    سپاسگزاری کرده
    22
    برای end pointها هم باید بزنی دیگه مثل همون چیزی که گفتم
    مثلا در R1 باید اینم اضافه کنی:
    ip route 192.168.2.0 255.255.255.0 192.168.0.2
    در R2 هم اینو اضافه کن:
    ip route 192.168.1.0 255.255.255.0 192.168.0.1
    من فکر کردم فقط نحوه نوشتن route رو مشکل داری والا همون اول برات کامل می نوشتم
    دوباره تست کن

    - - - Updated - - -

    در static routing باید تک تک network های دیگه شبکه را در هر روتر خودت دستی وارد کنی .

    - - - Updated - - -

    پیشنهاد می کنم concept static routing را در ویرایش سوم کتاب ccna حتما مطالعه کنی
    خیلی کمکت میکنه


    mohamad-23 و Mahdi-t سپاسگزاری کرده‌اند.

  6. #6
    نام حقيقي: مهدى

    عضو عادی شناسه تصویری Mahdi-t
    تاریخ عضویت
    Nov 2011
    محل سکونت
    Tehran
    نوشته
    219
    سپاسگزاری شده
    68
    سپاسگزاری کرده
    60
    جواب اولتون رو میدونستم اما اینو که تک تک شبکه ها رو باید وارد کرد نه
    فکر می کردم فقط واسه ارتباط 2 روتر بنویسی کافیه
    ممنون


    Never Give Up





  7. #7
    نام حقيقي: Rmin Rezaeimehr

    عضو عادی شناسه تصویری EVERAL
    تاریخ عضویت
    Jul 2009
    محل سکونت
    Tehran
    نوشته
    389
    سپاسگزاری شده
    396
    سپاسگزاری کرده
    511
    راهنمایی برای روت نوشتن
    In this tutorial we will connect two routers via static route with GNS3.
    Static route and Dynamic route
    Static route tells the device exactly where to send traffic, no matter what. Static route is often used when your network has only a few routers or there is only one route from a source to a destination. Dynamic routes, on the other hand, use a routing protocol to determine the best path and the routes can be changed depending on specific parameters (like bandwidth, delay, cost…). With dynamic routes, routers can communicate with each other to exchange routing information. In ROUTE 642-902 you will learn about dynamic routing protocols such as OSPF, EIGRP and BGP (RIP is also a dynamic routing protocol but it is not mentioned in ROUTE).

    The simple syntax of static route:
    ip route <destination><subnet mask><next hop IP address or outbound interface>

    Now we consider a real-world example of static routing. Suppose that your company has 2 branches located in New York and Chicago. As the administrator of the network, you are tasked to connect them so that employees in the two LANs can communicate with each other. After careful consideration you decided to connect them via static route.


    In GNS3, place 2 routers and connect them as the image below, I used IOS c2600-bin-mz.123-6f.bin to save some RAM (only require 64MB/router). We will use two loopback interfaces to simulate two Ethernet LANs.
    Configuring interfaces on R0

    R0(config)#interface s0/0
    R0(config-if)#ip address 12.12.12.1 255.255.255.0
    R0(config-if)#no shutdown
    R0(config-if)#interface lo0
    R0(config-if)#ip address 10.0.0.1 255.0.0.0
    R0(config-if)#exit
    Configuring interfaces on R1
    R0(config)#interface s0/0
    R0(config-if)#ip address 12.12.12.2 255.255.255.0
    R0(config-if)#no shutdown
    R0(config-if)#interface lo0
    R0(config-if)#ip address 172.16.0.1 255.255.0.0
    R0(config-if)#exit
    Now if we check the routing table of R0 & R1 by the command show ip route on both R0 and R1
    On R0:
    R0# show ip route

    The letter “C” means “connected” or “directly connected”. So there are 2 networks that are directly connected to R0: 10.0.0.0/8 and 12.12.12.0
    On R1
    R1# show ip route

    Configuring static route on R0
    R0(config)#ip route 172.16.0.0 255.255.0.0 12.12.12.2
    Configuring static route on R1
    R1(config)#ip route 10.0.0.0 255.0.0.0 12.12.12.1
    Notice that static route works one-way. It means we have to add static route to both R0 and R1 so that R0 and R1 can communicate.



    Now try to ping each far end network

    (Note: In fact, R0 can successfully ping R1 right after adding the static route to R0)
    Administrative distance of a static route.
    After adding two static routes in R0 & R1 routers, the routing tables of two routers contain these lines:
    S 10.0.0.0/8 [1/0] via 12.12.12.1 (on R1)
    S 172.16.0.0/16 [1/0] via 12.12.12.2 (on R0)
    The “S” letter tells us this is a static route. The networks 10.0.0.0/8 and 172.16.0.0/16 are the destinations of this static route and if the routers want to reach them they must send packets to 12.12.12.1 (on R1) and 12.12.12.2 (on R2). These parameters are straightforward and easy to understand. But what is [1/0]? Well, 1 is the administrative distance (AD) and 0 is the metric of that static route.
    The administrative distance is a measure of trustworthiness where lower numbers are considered to be more trustworthy than higher numbers. The route with the lowest administrative distance value is the preferred route that the router selects. Administrative distance is the value from 0 to 255.
    Directly connected routes have an administrative distance of 0. Static routes have an administrative distance
    of 1 so in the outputs above you will see the administrative distance of both static routes are 1.
    The router treats a static route pointing to an interface the same as a connected interface so the its AD is 0. If you configure a static route pointing to an exiting interface (for example: “ip route 172.16.0.0 255.255.0.0 s0/0” on R0) then the AD will not be shown.
    (For your information, EIGRP has an administrative distance of 90. IGRP has an administrative distance of 100. OSPF has an administrative distance of 110. And RIP has an administrative distance of 120)
    Configure Static Route – GNS3 Lab



    mehrzadmo سپاسگزاری کرده است.

کلمات کلیدی در جستجوها:

نوشتن روت در روتر

روت شبکه

نوشتن روت در روتر سیسکو

استاتیک روت سیسکو

روت تیبل

روت استاتیک

نوشتن روت برای روتر

نوشتن استاتیک روت

نوشتن روت استاتیک

داینامیک روت در سیسکو طریقه نوشتن ای پی روتنوشتن روت سیسکونحوه نوشتن روت استاتیکطریقه نوشتن روتنحوه نوشتن روتطریقه نوشتن ip static در روتر سیسکونمایش روت تیبل در روتر سیسکوطریقه نوشتن روت در سیسکونحوه نوشتن استاتیک روت در روترنحوه افزودن استاتیک روت در روتر سیسکونوشتن روتينگ در آيزا سروراستاتیک روتنوشتن روت در isaنوشتن روت ripتفاوت استاتیک روت و داینامیک روت

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •