نمایش نتایج: از شماره 1 تا 14 از مجموع 14
سپاس ها 11سپاس
  • 2 توسط hamid khan
  • 2 توسط Reza.D
  • 2 توسط Reza.D
  • 1 توسط hamid khan
  • 1 توسط Reza.D
  • 2 توسط Reza.D
  • 1 توسط Reza.D

موضوع: استفاده از Route-map بصورت حرفه ای تر

  
  1. #1
    نام حقيقي: حمید قنبریان

    خواننده
    تاریخ عضویت
    Oct 2009
    محل سکونت
    کرج
    نوشته
    501
    سپاسگزاری شده
    522
    سپاسگزاری کرده
    203

    Icon14 استفاده از Route-map بصورت حرفه ای تر

    با سلام خدمت سروران گرامی
    مدتی هست که جهت Load-balancing با دستور route-map درگیر هستم و هنوز نتوانسته ام نتیجه مطلوب را بدست آورم 2 لینک زیر خیلی خوب 2 سناریو مختلف را توضیح داده است (برای دوستانی که از کارکرد این دستور اطلاع ندارند) ولی من تلفیق ایندو را روی NAT بر روی 2 لینک نمیتوانم اجرا کنم :
    NIL - Small Site Multi-Homing
    NIL - Redundant Small Site Multi-Homing



    ip nat inside source route-map nat1 interface fa0/1 overload
    ip nat inside source route-map nat2 interface fa0/2 overload

    access-list 110 permit ip 192.168.10.0 0.0.0.255 any
    access-list 120 permit ip 192.168.20.0 0.0.0.255 any

    route-map nat1 permit 10
    match ip address 110
    set next-hop x.x.x.x
    route-map nat2 permit 10
    match ip address 110
    set next-hop y.y.y.y
    آخرش نفهمیدم آیا هنگامی که از Route-map استفاده میکنی باید باز هم از دستور Route استفاده کرد یا نه ؟
    مثلاً در مثال فوق لازم هست بنویسیم ،
    ip route 0.0.0.0 0.0.0.0 x.x.x.x
    ip route 0.0.0.0 0.0.0.0 y.y.y.y







    موضوعات مشابه:
    f14f21 و mohammadeb سپاسگزاری کرده‌اند.





  2. #2
    نام حقيقي: وحید

    عضو عادی
    تاریخ عضویت
    Jun 2012
    محل سکونت
    تهران
    نوشته
    109
    سپاسگزاری شده
    79
    سپاسگزاری کرده
    13
    به احتمال میدونید که route-map مثل نقش if تو برنامه نویسی میمونه و ربطی نداره به route . مطمئن باشید که route نیاز هست.
    حالا مشکل شما دقیقا کجای کاره؟



  3. #3
    نام حقيقي: حمید قنبریان

    خواننده
    تاریخ عضویت
    Oct 2009
    محل سکونت
    کرج
    نوشته
    501
    سپاسگزاری شده
    522
    سپاسگزاری کرده
    203
    آیا در Route-map بسته ها در لایه 3 شبکه Regenerate میشود و آدرس Destination بسته ها عوض میشود ؟



  4. #4
    نام حقيقي: رضا دانشمند (Dj Pashmak)

    عضو ویژه/سرپرست بخش Cisco شناسه تصویری Reza.D
    تاریخ عضویت
    Oct 2007
    محل سکونت
    .
    نوشته
    936
    سپاسگزاری شده
    871
    سپاسگزاری کرده
    866
    نقل قول نوشته اصلی توسط hamid khan نمایش پست ها
    آیا در Route-map بسته ها در لایه 3 شبکه Regenerate میشود و آدرس Destination بسته ها عوض میشود ؟
    Route Map مکانیزمی ست برای جدا کردن یک سری بسته ها و اختصاص دادن یک ویژگی خاص به اونها یا فیلتر کردن بسته ها. به عنوان مثال زمانیکه در منطق Route Map میگیم اگر بسته ها با Access list مثلا 10 مطابقت داشت next-hop اونها به فلان IP تغییر کنه صرفا نحوه تصمیم گیری برای بسته ها رو مورد تغییر قرار میدیم. اما آدرس مقصد بسته رو تغییر نمیدیم، ماصرفا مسیر رسیدن بسته ها به مقصد رو نسبت به اون چیزی که در جدول مسیریابی داریم بنا به شرایط تغییر میدیم.


    f14f21 و armaaan سپاسگزاری کرده‌اند.
    The great pleasure in life is doing what people say you cannot do

  5. #5
    نام حقيقي: حمید قنبریان

    خواننده
    تاریخ عضویت
    Oct 2009
    محل سکونت
    کرج
    نوشته
    501
    سپاسگزاری شده
    522
    سپاسگزاری کرده
    203
    نقل قول نوشته اصلی توسط Dj Pashmak نمایش پست ها
    Route Map ماصرفا مسیر رسیدن بسته ها به مقصد رو نسبت به اون چیزی که در جدول مسیریابی داریم بنا به شرایط تغییر میدیم.
    یعنی به گفته شما ، اگر ما از Route-map استفاده کنیم دیگرنیازی به جدول Route نیست در نتیجه به Static Route هم نیاز نیست بر خلاف گفته وست دیگرمان که فرمودند "مطمئن باشید که route نیاز هست"



  6. #6
    نام حقيقي: رضا دانشمند (Dj Pashmak)

    عضو ویژه/سرپرست بخش Cisco شناسه تصویری Reza.D
    تاریخ عضویت
    Oct 2007
    محل سکونت
    .
    نوشته
    936
    سپاسگزاری شده
    871
    سپاسگزاری کرده
    866
    نقل قول نوشته اصلی توسط hamid khan نمایش پست ها
    یعنی به گفته شما ، اگر ما از Route-map استفاده کنیم دیگرنیازی به جدول Route نیست در نتیجه به Static Route هم نیاز نیست بر خلاف گفته وست دیگرمان که فرمودند "مطمئن باشید که route نیاز هست"
    جناب قنبریان، شما در پست قبلی فرمودید:

    نقل قول نوشته اصلی توسط hamid khan نمایش پست ها
    آیا در Route-map بسته ها در لایه 3 شبکه Regenerate میشود و آدرس Destination بسته ها عوض میشود ؟
    صحبت من در رابطه این بود که آدرس مقصد بسته ها دچار تغییر نمیشه، مثلا اگر آدرس مقصد من 200.200.200.20 باشه با تنظیم Route Map من این آدرس رو تغییر نمیدم. اونچه تغییر میکنه next hop یا ایتنرفیس خروجی هست که من دارم بسته رو بهش میفرستم و همه این تصمیمات هم بر اساس همون جدول مسیریابی انجام میشه


    f14f21 و mohammadeb سپاسگزاری کرده‌اند.
    The great pleasure in life is doing what people say you cannot do





  7. #7
    نام حقيقي: حمید قنبریان

    خواننده
    تاریخ عضویت
    Oct 2009
    محل سکونت
    کرج
    نوشته
    501
    سپاسگزاری شده
    522
    سپاسگزاری کرده
    203
    با تشکر از توجه شما
    هنوز بنده جواب خود را نگرفتم : اگر در Route-map برای پکتهای گزینش شده next-hop وجود داشته باشد آیا لزومی دارد که برای آنها Static route نوشته شود ؟


    mohammadeb سپاسگزاری کرده است.

  8. #8
    نام حقيقي: رضا دانشمند (Dj Pashmak)

    عضو ویژه/سرپرست بخش Cisco شناسه تصویری Reza.D
    تاریخ عضویت
    Oct 2007
    محل سکونت
    .
    نوشته
    936
    سپاسگزاری شده
    871
    سپاسگزاری کرده
    866
    بله باید استاتیک روتها رو داشته باشید
    از route map فقط در NAT استفاده شده و کار NAT هم تغییر آدرس های شبکه داخلی به آدرس های valid بوده و ربطی به مسیریابی ندارند.
    بدون اون استاتیک روتها پکتی از شبکه خارج نمیشه که بخوایم NAT رو روش اعمال کنیم


    f14f21 سپاسگزاری کرده است.
    The great pleasure in life is doing what people say you cannot do

  9. #9
    نام حقيقي: حمید قنبریان

    خواننده
    تاریخ عضویت
    Oct 2009
    محل سکونت
    کرج
    نوشته
    501
    سپاسگزاری شده
    522
    سپاسگزاری کرده
    203
    بسیار خب حالا برگردیم به سناریو :
    route-map nat1 permit 10
    match ip address 110
    set next-hop x.x.x.x

    route-map nat2 permit 10
    match ip address 120
    set next-hop y.y.y.y

    ip route 0.0.0.0 0.0.0.0 x.x.x.x
    ip route 0.0.0.0 0.0.0.0 y.y.y.y

    در نمونه فوق که 2 عدد route مشابه به 2 مقصد داریم با Metric برابر فقط یکی را به عنوان اصلی اضافه کرده و route دوم مادامی که اولی هست نقشی ندارد پس چطور در route-map دوم شما بسته های گزینش شده را به مقصد دوم میفرستید ؟

    یا جور دیگر آیا در route-map هدف شما تغییر دادن مقصد بسته ها بدون در نظر گرفتن پیش فرض آنها نیست ؟



  10. #10
    نام حقيقي: رضا دانشمند (Dj Pashmak)

    عضو ویژه/سرپرست بخش Cisco شناسه تصویری Reza.D
    تاریخ عضویت
    Oct 2007
    محل سکونت
    .
    نوشته
    936
    سپاسگزاری شده
    871
    سپاسگزاری کرده
    866
    نقل قول نوشته اصلی توسط hamid khan نمایش پست ها
    بسیار خب حالا برگردیم به سناریو :
    route-map nat1 permit 10
    match ip address 110
    set next-hop x.x.x.x

    route-map nat2 permit 10
    match ip address 120
    set next-hop y.y.y.y

    ip route 0.0.0.0 0.0.0.0 x.x.x.x
    ip route 0.0.0.0 0.0.0.0 y.y.y.y

    در نمونه فوق که 2 عدد route مشابه به 2 مقصد داریم با Metric برابر فقط یکی را به عنوان اصلی اضافه کرده و route دوم مادامی که اولی هست نقشی ندارد پس چطور در route-map دوم شما بسته های گزینش شده را به مقصد دوم میفرستید ؟
    منظور شما از متریک برای route map چیست؟route map ها هریک جداگانه مورد بررسی قرار میگیرند و هر پکتی که با match clause آنها مطابقت داشته باشد دستور set نسبت به آن پکت اعمال میشود.

    در نمونه ای که مثال زدید دو route map داریم که هر کدام به یک دسته از IP address ها اعمال میشوند، اولی به آنها که با access list 110 مطابقت داشته باشند و دومی با access list 120. پس هر دو route map فعال هستند.
    اگر route map ها نبودند استاتیک روتها با متریک برابر باعث load balancing پکتهای خروجی از شبکه خواهند شد و با وجود route map ها هر استاتیک روت برای یک گروه از IP های شبکه داخلی مورد استفاده قرار خواهد گرفت.



    یا جور دیگر آیا در route-map هدف شما تغییر دادن مقصد بسته ها بدون در نظر گرفتن پیش فرض آنها نیست ؟
    هدف همینه و همون ابتدا عرض کردم این موضوع رو.

    برای set کردن next hop دو دستور قابل استفاده هستند:
    کد:
    Set ip next-hop ip-address
    ​Set ip default next-hop ip-address
    همینطور برای ست کردن اینترفیس خروجی داریم:
    کد:
    Set interface interface-type interface-num
    ​Set default interface interface-type interface-num
    تأثیر وجود یا عدم وجود کلمه default به این صورته که اگر کلمه default رو نداشته باشیم IOS ابتدا براساس منطق PBR عمل میکنه و سعی میکنه برابر دستور ست نوشته شده پکت رو forward کنه. در این حالت اگر next hop تعیین شده reachable نبود یا اینترفیس خروجی تعیین شده به هر دلیل down باشه سراغ destination based routing میره و پکت رو میفرسته.
    اگر کلمه default رو داشته باشیم برای پکتهایی که با match clause در PBR مطابقت داشته باشند ابتدا destination based routing با در نظر نگرفتن default route ها انجام خواهد شد، چنانچه به هر دلیل موفقیت آمیز نبود و یا روتی که با این شرایط مطابقت کنه وجود نداشت شرایط تعیین شده در PBR به پکتها اعمال خواهد شد.



    hamid khan و f14f21 سپاسگزاری کرده‌اند.
    The great pleasure in life is doing what people say you cannot do

  11. #11
    نام حقيقي: حمید قنبریان

    خواننده
    تاریخ عضویت
    Oct 2009
    محل سکونت
    کرج
    نوشته
    501
    سپاسگزاری شده
    522
    سپاسگزاری کرده
    203
    با کمال تشکر از وقتی که برای توضیح میگذارید :

    همه موارد فوق قبول
    ببین بزارین اینجوری مشکلم و بگم : برای هدایت بسته ها روتر اول سراغ route-map میره یا سراغ جدول route ؟

    (metric برای static route نه route-map)



  12. #12
    نام حقيقي: رضا دانشمند (Dj Pashmak)

    عضو ویژه/سرپرست بخش Cisco شناسه تصویری Reza.D
    تاریخ عضویت
    Oct 2007
    محل سکونت
    .
    نوشته
    936
    سپاسگزاری شده
    871
    سپاسگزاری کرده
    866
    درباره متریک من اشتباه کردم.عذر میخوام

    روتر سراغ جدول مسیریابی میره و آنچه در route map تعریف شده رو به پکتهایی که واجد شرایط باشند اعمال میکنه.


    The great pleasure in life is doing what people say you cannot do





  13. #13
    نام حقيقي: حمید قنبریان

    خواننده
    تاریخ عضویت
    Oct 2009
    محل سکونت
    کرج
    نوشته
    501
    سپاسگزاری شده
    522
    سپاسگزاری کرده
    203
    کلی مطلب در مورد Policy-Based Routing خوندم مفهوم این جمله را نفهمیدم :

    Enabling PBR disables switching of all packets arriving on this interface

    یا مورد دیگه انکه حتماً باید روی اینترفیس یا Global با دستور IP Policy Route-map آن را فعال کرد





    ویرایش توسط hamid khan : 2012-07-11 در ساعت 11:00 AM

  14. #14
    نام حقيقي: رضا دانشمند (Dj Pashmak)

    عضو ویژه/سرپرست بخش Cisco شناسه تصویری Reza.D
    تاریخ عضویت
    Oct 2007
    محل سکونت
    .
    نوشته
    936
    سپاسگزاری شده
    871
    سپاسگزاری کرده
    866
    از کتاب CCNP ROUTE فصل یازدهم استفاده کنید، اونجا خوب گفته مطلب رو.

    در مورد جمله اول مربوط میشه به fast switching اگر اشتباه نکنم که اینطور که من فهمیدم مفهوم اینه که سوئیچینگ بسته ها در حالتی که PBR داشته باشیم با سرعت کمتری انجام میشه.

    در مورد فعال کردن PBR مثل هر feature دیگه که فعال میشه باید PBR را در سطح اینترفیس با دستوری که فرمودید فعال کرد تا به بسته ها در زمان مسیریابی اعمال بشه



    f14f21 سپاسگزاری کرده است.
    The great pleasure in life is doing what people say you cannot do

کلمات کلیدی در جستجوها:

route map چیست

دستور route

pbr چیست

route map چیست؟

route-map چیست

اموزش route mapاستفاده از دستور routeroute map ciscoroute map در سیسکوRoute mapآموزش route-maproute map چیست ؟route map چيستroute map آموزش آموزش route map تغییر دادن routeاموزش en route chartip policy route-map دستورroute mapچیستآموزش دستور routeroute map match destination روترroute-map چیست؟دستور route-mapچیست route mapدستور route map

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •