نمایش نتایج: از شماره 1 تا 2 از مجموع 2
سپاس ها 2سپاس
  • 1 توسط patris1
  • 1 توسط patris1

موضوع: CCNA Certification: Cisco Router Commands

  
  1. #1
    نام حقيقي: 1234

    مدیر بازنشسته
    تاریخ عضویت
    Jul 2009
    محل سکونت
    5678
    نوشته
    5,634
    سپاسگزاری شده
    2513
    سپاسگزاری کرده
    272

    CCNA Certification: Cisco Router Commands

    کد:
    http://www.ciscokits.com/cisco-router-commands/
    CCNA Certification: Cisco Router Commands

    In preparation of your CCNA exam, we want to make sure we cover the various concepts that we could see on your Cisco CCNA exam. So to assist you, below we will discuss the CCNA concepts of Cisco Router Commands. As you progress through your CCNA exam studies, I am sure with repetition you will find this topic becomes easier. So even though it may be a difficult concept and confusing at first to learn all the Cisco commands, keep at it as no one said getting your Cisco certification would be easy!

    ROUTER COMMANDS



    TERMINAL CONTROLS:


    • Config# terminal editing - allows for enhanced editing commands
    • Config# terminal monitor - shows output on telnet session
    • Config# terminal ip netmask-format hexadecimal|bit-count|decimal - changes the format of subnet masks

    HOST NAME:


    • Config# hostname ROUTER_NAME

    BANNER:


    • Config# banner motd # TYPE MESSAGE HERE # - # can be substituted for any character, must start and finish the message

    DESCRIPTIONS:


    • Config# description THIS IS THE SOUTH ROUTER - can be entered at the Config-if level

    CLOCK:


    • Config# clock timezone Central -6
      # clock set hh:mm:ss dd month yyyy
      - Example: clock set 14:35:00 25 August 2003

    CHANGING THE REGISTER:


    • Config# config-register 0x2100 - ROM Monitor Mode
    • Config# config-register 0x2101 - ROM boot
    • Config# config-register 0x2102 - Boot from NVRAM

    BOOT SYSTEM:


    • Config# boot system tftp FILENAME SERVER_IP - Example: boot system tftp 2600_ios.bin 192.168.14.2
    • Config# boot system ROM
    • Config# boot system flash - Then - Config# reload

    CDP:


    • Config# cdp run - Turns CDP on
    • Config# cdp holdtime 180 - Sets the time that a device remains. Default is 180
    • Config# cdp timer 30 - Sets the update timer.The default is 60
    • Config# int Ethernet 0
    • Config-if# cdp enable - Enables cdp on the interface
    • Config-if# no cdp enable - Disables CDP on the interface
    • Config# no cdp run - Turns CDP off

    HOST TABLE:


    • Config# ip host ROUTER_NAME INT_Address - Example: ip host lab-a 192.168.5.1
      -or-
    • Config# ip host RTR_NAME INT_ADD1 INT_ADD2 INT_ADD3 - Example: ip host lab-a 192.168.5.1 205.23.4.2 199.2.3.2 - (for e0, s0, s1)

    DOMAIN NAME SERVICES:


    • Config# ip domain-lookup - Tell router to lookup domain names
    • Config# ip name-server 122.22.2.2 - Location of DNS server
    • Config# ip domain-name cisco.com - Domain to append to end of names

    CLEARING COUNTERS:


    • # clear interface Ethernet 0 - Clears counters on the specified interface
    • # clear counters - Clears all interface counters
    • # clear cdp counters - Clears CDP counters

    STATIC ROUTES:


    • Config# ip route Net_Add SN_Mask Next_Hop_Add - Example: ip route 192.168.15.0 255.255.255.0 205.5.5.2
    • Config# ip route 0.0.0.0 0.0.0.0 Next_Hop_Add - Default route
      -or-
    • Config# ip default-network Net_Add - Gateway LAN network

    IP ROUTING:


    • Config# ip routing - Enabled by default
    • Config# router rip
      -or-
    • Config# router igrp 100
    • Config# interface Ethernet 0
    • Config-if# ip address 122.2.3.2 255.255.255.0
    • Config-if# no shutdown

    IPX ROUTING:


    • Config# ipx routing
    • Config# interface Ethernet 0
    • Config# ipx maximum-paths 2 - Maximum equal metric paths used
    • Config-if# ipx network 222 encapsulation sap - Also Novell-Ether, SNAP, ARPA on Ethernet. Encapsulation HDLC on serial
    • Config-if# no shutdown

    ACCESS LISTS:


    IP STANDARD:


    • Config# access-list 10 permit 133.2.2.0 0.0.0.255 - allow all src ip’s on network 133.2.2.0
      -or-
    • Config# access-list 10 permit host 133.2.2.2 - specifies a specific host
      -or-
    • Config# access-list 10 permit any - allows any address
    • Config# int Ethernet 0
    • Config-if# ip access-group 10 in - also available: out

    IP EXTENDED:


    • Config# access-list 101 permit tcp 133.12.0.0 0.0.255.255 122.3.2.0 0.0.0.255 eq telnet
      -protocols: tcp, udp, icmp, ip (no sockets then), among others
      -source then destination address
      -eq, gt, lt for comparison
      -sockets can be numeric or name (23 or telnet, 21 or ftp, etc)
      -or-
    • Config# access-list 101 deny tcp any host 133.2.23.3 eq www
      -or-
    • Config# access-list 101 permit ip any any
    • Config# interface Ethernet 0
    • Config-if# ip access-group 101 out

    IPX STANDARD:


    • Config# access-list 801 permit 233 AA3 - source network/host then destination network/host
      -or-
    • Config# access-list 801 permit -1 -1 - “-1” is the same as “any” with network/host addresses
    • Config# interface Ethernet 0
    • Config-if# ipx access-group 801 out

    IPX EXTENDED:


    • Config# access-list 901 permit sap 4AA all 4BB all
      - Permit protocol src_add socket dest_add socket
      -“all” includes all sockets, or can use socket numbers
      -or-
    • Config# access-list 901 permit any any all any all
      -Permits any protocol with any address on any socket to go anywhere
    • Config# interface Ethernet 0
    • Config-if# ipx access-group 901 in

    IPX SAP FILTER:


    • Config# access-list 1000 permit 4aa 3 - “3” is the service type
      -or-
    • Config# access-list 1000 permit 4aa 0 - service type of “0” matches all services
    • Config# interface Ethernet 0
    • Config-if# ipx input-sap-filter 1000 - filter applied to incoming packets
      -or-
    • Config-if# ipx output-sap-filter 1000 - filter applied to outgoing packets

    NAMED ACCESS LISTS:


    • Config# ip access-list standard LISTNAME
      -can be ip or ipx, standard or extended
      -followed by the permit or deny list
    • Config# permit any
    • Config-if# ip access-group LISTNAME in -use the list name instead of a list number -allows for a larger amount of access-lists

    PPP SETUP:


    • Config-if# encapsulation ppp
    • Config-if# ppp authentication chap pap
      -order in which they will be used
      -only attempted with the authentification listed
      -if one fails, then connection is terminated
    • Config-if# exit
    • Config# username Lab-b password 123456
      -username is the router that will be connecting to this one
      -only specified routers can connect
      -or-
    • Config-if# ppp chap hostname ROUTER
    • Config-if# ppp chap password 123456
      -if this is set on all routers, then any of them can connect to any other
      -set same on all for easy configuration

    ISDN SETUP:


    • Config# isdn switch-type basic-5ess - determined by telecom
    • Config# interface serial 0
    • Config-if# isdn spid1 2705554564 - isdn “phonenumber” of line 1
    • Config-if# isdn spid2 2705554565 - isdn “phonenumber” of line 2
    • Config-if# encapsulation PPP - or HDLC, LAPD

    DDR - 4 Steps to setting up ISDN with DDR

    1. Configure switch type
      Config# isdn switch-type basic-5ess - can be done at interface config
    2. Configure static routes
      Config# ip route 123.4.35.0 255.255.255.0 192.3.5.5 - sends traffic destined for 123.4.35.0 to 192.3.5.5
      Config# ip route 192.3.5.5 255.255.255.255 bri0 - specifies how to get to network 192.3.5.5 (through bri0)
    3. Configure Interface
      Config-if# ip address 192.3.5.5 255.255.255.0
      Config-if# no shutdown
      Config-if# encapsulation ppp

      Config-if# dialer-group 1 - applies dialer-list to this interface
      Config-if# dialer map ip 192.3.5.6 name Lab-b 5551212
      connect to lab-b at 5551212 with ip 192.3.5.6 if there is interesting traffic can also use “dialer string 5551212” instead if there is only one router to connect to
    4. Specify interesting traffic
      Config# dialer-list 1 ip permit any
      -or-
      Config# dialer-list 1 ip list 101 - use the access-list 101 as the dialer list
    5. Other Options
      Config-if# hold-queue 75 - queue 75 packets before dialing
      Config-if# dialer load-threshold 125 either
      -load needed before second line is brought up
      -“125” is any number 1-255, where % load is x/255 (ie 125/255 is about 50%)
      -can check by in, out, or either
      Config-if# dialer idle-timeout 180
      -determines how long to stay idle before terminating the session
      -default is 120

    FRAME RELAY SETUP:


    • Config# interface serial 0
    • Config-if# encapsulation frame-relay - cisco by default, can change to ietf
    • Config-if# frame-relay lmi-type cisco - cisco by default, also ansi, q933a
    • Config-if# bandwidth 56
    • Config-if# interface serial 0.100 point-to-point - subinterface
    • Config-if# ip address 122.1.1.1 255.255.255.0
    • Config-if# frame-relay interface-dlci 100
      -maps the dlci to the interface
      -can add BROADCAST and/or IETF at the end
    • Config-if# interface serial 1.100 multipoint
    • Config-if# no inverse-arp - turns IARP off; good to do
    • Config-if# frame-relay map ip 122.1.1.2 48 ietf broadcast
      -maps an IP to a dlci (48 in this case)
      -required if IARP is turned off
      -ietf and broadcast are optional
    • Config-if# frame-relay map ip 122.1.1.3 54 broadcast

    SHOW COMMANDS


    • Show access-lists - all access lists on the router
    • Show cdp - cdp timer and holdtime frequency
    • Show cdp entry * - same as next
    • Show cdp neighbors detail - details of neighbor with ip add and ios version
    • Show cdp neighbors - id, local interface, holdtime, capability, platform portid
    • Show cdp interface - int’s running cdp and their encapsulation
    • Show cdp traffic - cdp packets sent and received
    • Show controllers serial 0 - DTE or DCE status
    • Show dialer - number of times dialer string has been reached, other stats
    • Show flash - files in flash
    • Show frame-relay lmi - lmi stats
    • Show frame-relay map - static and dynamic maps for PVC’s
    • Show frame-relay pvc - pvc’s and dlci’s
    • Show history - commands entered
    • Show hosts - contents of host table
    • Show int f0/26 - stats of f0/26
    • Show interface Ethernet 0 - show stats of Ethernet 0
    • Show ip - ip config of switch
    • Show ip access-lists - ip access-lists on switch
    • Show ip interface - ip config of interface
    • Show ip protocols - routing protocols and timers
    • Show ip route - Displays IP routing table
    • Show ipx access-lists - same, only ipx
    • Show ipx interfaces - RIP and SAP info being sent and received, IPX addresses
    • Show ipx route - ipx routes in the table
    • Show ipx servers - SAP table
    • Show ipx traffic - RIP and SAP info
    • Show isdn active - number with active status
    • Show isdn status - shows if SPIDs are valid, if connected
    • Show mac-address-table - contents of the dynamic table
    • Show protocols - routed protocols and net_addresses of interfaces
    • Show running-config - dram config file
    • Show sessions - connections via telnet to remote device
    • Show startup-config - nvram config file
    • Show terminal - shows history size
    • Show trunk a/b - trunk stat of port 26/27
    • Show version - ios info, uptime, address of switch
    • Show vlan - all configured vlan’s
    • Show vlan-membership - vlan assignments
    • Show vtp - vtp configs

    I hope you found this article to be of use and it helps you prepare for your Cisco CCNA certification. I am sure you will quickly find out that hands-on real world experience is the best way to cement the CCNA concepts in your head to help you pass your CCNA exam





    موضوعات مشابه:
    aryagohar سپاسگزاری کرده است.





  2. #2
    نام حقيقي: 1234

    مدیر بازنشسته
    تاریخ عضویت
    Jul 2009
    محل سکونت
    5678
    نوشته
    5,634
    سپاسگزاری شده
    2513
    سپاسگزاری کرده
    272

    CCNA Certification: Basic Two Router Lab

    2 Router Basic Configuration Lab
    * DCE




    Objective:
    In preparation of your CCNA exam, we want to make sure we cover the various concepts that we could see on your Cisco CCNA exam. So to assist you, below we provided one of our CCNA Labs, the Basic Two Router Lab. As you progress through your CCNA exam studies, I am sure you will find that hands on experience you receive from such as lab will go a long way in helping you acheive your Cisco certification!
    In this lab you will configure a simple network to allow two routers to route packets between to remote networks.
    Requirements:

    • Two Cisco routers with one Ethernet port and one serial port.
    • Cisco IOS 10.0 or higher
    • One PC for consoling into routers with terminal emulation software
    • One serial cable
    • One Cisco rollover cable

    Setup:
    Step 1: Physical Connections Connect the following interfaces:


    • Console: Connect your PC/terminal to the console port using a rollover cable and HyperTerminal (9600-8-N-1-no flow)
    • Ethernet: Connect Ethernet ports to a hub or a switch using a straight-through cable. Use a cross-over cable if going directly from the PC’s NIC to the Ethernet (AUI) port on the router using a transceiver.
    • Serial: If going directly between two routers, don’t forget to connect one port via the DTE cable and the other via the DCE cable.

    Step 2: Boot up the routers

    Just say “no” to use the setup mode (setup dialogue). The setup mode will only allow you to configure the router with the basic features and not with any advanced features.
    If asked if you would like to terminate the auto configuration; say “yes”.
    Let the routers finish booting.
    Step 3: Host Name and Passwords

    Begin your configuration with the hostname and passwords. This is to remind you of what router you are configuring and now's the time to start thinking about router security.
    RouterA
    router>en router#
    router#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    router(config)#hostname RouterA (sets the router's name)
    RouterA(config)#enable secret cisco (Sets the secret password
    for the router)
    RouterA(config)#line vty 0 4 (there are five concurrent
    connections for the telnet ports coming into a Cisco 2500
    router. We are setting the login password on all five of them)
    RouterA(config-line)#login (This enables the router to require a
    login password for a telnet session to the router)
    RouterA(config-line)#password cisco (this sets the login
    password for all 5 telnet sessions coming into the router as cisco)
    RouterA(config-line)#exit
    RouterA(config)#^Z (This is the key combination of control+z
    which takes you back to the privileged executive mode)
    RouterA#
    RouterB
    router>en
    router#
    router#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    router(config)#hostname RouterB (sets the router's name)
    RouterB(config)#enable secret cisco (Sets the secret password for the router)
    RouterB(config)#line vty 0 4 (there are five concurrent connections for the telnet ports coming into a Cisco 2500 router. We are setting the login password on all five of them)
    RouterB(config-line)#login (This enables the router to require a login password for a telnet session to the router)
    RouterB(config-line)#password cisco (this sets the login password for all 5 telnet sessions coming into the router as cisco)
    RouterB(config-line)#exit
    3 RouterB(config)#^Z (This is the key combination of control+z which takes you back to the privileged executive mode)
    FYI: Anytime you make a configuration change to a router and you come back to the privileged exec mode you need to save your changes to NVRAM. This ensures that if the router reboots, you won’t loose your changes which are in the running-config which is volatile RAM. The following command(s) saves your changes to the startup-config.
    RouterA#copy running-config startup-config
    Or

    RouterA# copy run start
    Or

    RouterA#wr me (short for write memory)
    Step 4: Adding IP Addresses

    Adding IP addresses, is a basic function of configuring routers. Below is an example of configuring both an Ethernet and serial interface. For serial interface with the DCE cable you will need to also add the clocking with the clockrate command. Get the IP addresses from the network diagram.
    RouterA
    RouterA#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    RouterA(config)#int e0
    RouterA(config-if)#ip address 172.16.12.1 255.255.255.0
    RouterA(config-if)# description LAN Network for RouterA
    RouterA(config-if)# no shutdown
    RouterA(config-if)#int s0
    RouterA(config-if)#ip address 172.16.10.1 255.255.255.0
    (RouterA will have the serial 0 with the DCE end of the serial cable. The other partner will have serial1 with the DTE end of the serial cable. Check the network diagram to confirm to see who has what interface)
    RouterA(config-if)#clockrate 250000 (DCE interface only which is the s0 on RouterA)
    RouterA(config-if)#no shutdown
    RouterA(config-if)#description Network connection to RouterB
    RouterB
    RouterB#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    RouterB(config)#int e0
    RouterB(config-if)#ip address 172.16.11.1 255.255.255.0
    RouterB(config-if)# description LAN Network for RouterB
    RouterB(config-if)# no shutdown
    RouterB(config-if)#int s1
    RouterB(config-if)#ip address 172.16.10.2 255.255.255.0
    RouterB(config-if)#no shutdown
    RouterB(config-if)#description Network connection to RouterA
    Once both routers are configured properly, you should be able to use the ping command and ping the interface e0 on each of the routers from the neighboring router.
    If you do a show ip route on both routers and do not see the directly connected interfaces in the routing table, they are either not configured or they never came up.
    Confirm that the IP addressing took and the interfaces came up by using the show ip int and looking at the interfaces' status and ip address configuration.
    RouterA# show ip route
    RouterA# show ip int
    Do this on both routers.
    Step 5a: Adding Dynamic Routing: RIP

    For this router to participate in a dynamic routing using a dynamic routing protocol like RIP or IGRP, you'll need to enable a routing protocol and advertise the directly connected networks that want advertised.. We only advertise the classful network address, not the subnet mask of the network.
    RouterA
    RouterA>en
    RouterA#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    RouterA(config)#router RIP
    RouterA(config-router)#network 172.16.12.0
    RouterB
    RouterB>en
    RouterB#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    RouterB(config)#router RIP
    RouterB(config-router)#network 172.16.11.0
    FYI: We need to advertise the network, not any particular host. An example of that would be enabling RIP on RouterB. We want the other router (RouterA) to know that any packet destined for the network 172.16.11.0 can be sent to RouterB which has a directly connected 5 entry in it’s routing table showing what interface to send the packet to; in this case its e0. If you route to 172.16.11.1, all your every going to route to, is the e0 on RouterB and nothing else.
    Test your configuration to ensure that it is configured properly by pinging from router to router. Check your routing table for entries that are preceded by a capital letter "R" to ensure that you are receiving routing updates using RIP. Ensure that your partner has finished configuring his router so that you can receive his updates. No updates, no ping.
    Do a show ip protocol to see what routing protocol is configured on the routers.
    Step 5b: Adding Dynamic Routing: IGRP IGRP

    uses an autonomous system (AS) number or process id. This number must be the same on all routers wanting to share IGRP routing updates or they don’t share. Turn RIP off before you turn on IGRP. For this lab we'll be using an AS number of 100.
    RouterA
    RouterA>en
    RouterA#config t
    RouterA(config)#no router rip
    RouterA(config)#router igrp 100
    RouterA(config-router)#network 172.16.12.0 (again, just the network portion of the IP for your Ethernet network, NO subnet mask)
    RouterB
    RouterB>en
    RouterB#config t
    Enter configuration commands, one per line. End with CNTL/Z. RouterB(config)#no router rip
    RouterB(config)#router igrp 100
    RouterB(config-router)#network 172.16.11.0 (again, your Ethernet network IP NO Subnet Address)
    Step 6: Adding Default Routes

    Good candidates for default routes are routers which are known as the boundary router. This is a router which is normally part of a stub network. Inside the stub network, the routers may be participating in a dynamic routing using a protocol like RIP, but only a static default route is needed to connect the stub network to the Internet.
    RouterA
    RouterA>en
    RouterA#config t
    RouterA(config)#ip route 0.0.0.0 0.0.0.0 172.16.10.2
    RouterB
    RouterB>en
    RouterB#config t
    RouterB(config)#ip route 0.0.0.0 0.0.0.0 172.16.10.1
    Step 7: Adding Static Routes

    A static route can be used for different reasons. One reason may be for a router to connect to another router in a lab. You'll need to turn off all routing protocols before you configure the router for static routing.
    RouterA
    RouterA>en
    RouterA#config t
    RouterA(config)#no router igrp 100
    RouterA(config)#ip route 172.16.11.0 255.255.255.0 172.16.10.2
    What we are saying here is: For RouterA to route to the network 172.16.11.0, go to the next hop interface which is the serial1 (172.16.10.2) attached to RouterB. Since RouterB knows about the directed connected Ethernet network of 172.16.11.0, it will have route for it in its routing table proceeded by the letter "C". (See next example)
    RouterB#sh ip route
    (Output omitted)
    172.16.0.0/24 is subnetted, 1 subnets
    C 172.16.0.0 is directly connected, Ethernet0
    RouterB#
    RouterB
    RouterB>en
    RouterB#
    RouterB#config t
    RouterB(config)#no router igrp 100
    RouterB(config)#ip route 172.16.12.0 255.255.255.0 172.16.10.1
    Step 8: Testing and Monitoring

    At this point it is a good idea to start testing your network using various commands. Perform the following on both routers.
    RouterA# show ip route
    RouterA# show ip interface brief (This command shows the IP and status of all interface)
    RouterA# show controller s0 (Shows whether or not the serial cable is DCE or DTE.)
    RouterA# ping ip-address
    RouterA# trace ip-address
    RouterA# debug ip rip (Remember to turn debug off when done, use undebug all, no debug all or un all)
    RouterA# terminal monitor (for using debug from a telnet
    session, otherwise debug output will go to the console. Caution: This will cause the debug output to go to all telnet sessions on the router.)
    Show commands
    RouterA# terminal no monitor(To turn off monitoring during a telnet session.)
    RouterA# show cdp neighbors
    RouterA# show ip protocols
    RouterA# #show version
    RouterA# #show flash
    RouterA# show ip route (shows the routing table)
    RouterA# show memory
    RouterA# show stacks
    RouterA# show buffers
    RouterA# show arp
    RouterA# show processes
    RouterA# show processes cpu
    RouterA# show tech-support
    Step 9: Finishing up

    Once you have your routers up and working you may wish to run some commands to make working on Cisco routers easier and to stop some of the default annoying behavior of Cisco routers.
    RouterA(config)# ip host RouterB 172.16.10.2 (This configures a host table entry for the name RouterB. So instead of having to remember the IP of RouterB to ping it, you can now ping it using its name, RouterB. It's the same as using a hosts file on a computer. If you just type in RouterB and hit enter, the router will assume you’re wanting to telnet into RouterB using port 23) RouterA(config)# no ip domain-lookup (When there is no DNS server and you miss spell a single word command, it will try to do a DNS lookup using a broadcast address of 255.255.255.255. To stop this lookup of a non-existent DNS server, we can turn off the DNS lookup capability using this command.)
    RouterA(config)# banner motd #!!!!Warning! Authorized Access Only!!!!# (This message will be seen by anyone trying to logon to your router. The # sign is known as a delimiting character and is used to identify the text portion of the MOTD. Notice that the actual message starts and ends with the delimiting character)
    RouterA(config)# no service-config (When you reboot a Cisco router, the default behavior is to try and find a configuration file on the network using a number of methods over a broadcast address of 255.255.255.255. To stop this annoying behavior, Use this command.)
    RouterA(config)#no logging console (Each time you leave one level of the router and return to the previous level or bring an interface up, you get a read out on the console screen. If you get busy typing and configuring the router this can be distracting and annoying. Use this command to stop the logging of messages to the console screen.)
    And don’t forget to…
    RouterA# show running-config
    RouterA# copy running-config startup-config
    Miscellaneous
    RouterA#? (the question mark can be used by itself or follow at the end of any partial command line to get the next part of the command syntax)
    To have the router CLI finish typing a command for you, just type out a partial command and hit the TAB key. An example would be typing out copy ru and hitting the TAB key. The router CLI with finish the command as copy running-configuration. Now if you add st to that and hit the tab key again, the CLI will add to your last command startup-configuration, making your entire command copy running-configuration startup-configuration. This works because there is only one command the begins with copy ru.
    Editing Commands
    Control-A: Moves to the beginning of the command line.
    Control-E: Moves to the end of the command line.
    Esc-B: Moves back one word.
    Control F: Moves forward one character.
    Control-B: Move back one character.
    Esc F: Moves forward one word.
    History Commands
    Control P or up arrow key - Recalls last (previous command.)
    Control N or down arrow key - Recalls most recent command
    Tab key: completes the entry.
    RouterA# show history
    RouterA# terminal history
    RouterA# terminal editing
    RouterA# no terminal editing
    FYI: This lab was designed to show you how to configure basic routing between two routers. If you would like to ping from one PC on one network (RouterA) to another PC on the other network (RouterB), you would need to configure the PC on each network with a host IP that belonged to the Ethernet network IP of each router. An example of that would be that the first available IP for a PC on the Ethernet network of RouterB would be 172.16.11.2. We know that the ".1" is already in use for the e0 interface on RouterB. The subnet mask for the PC would have to be the same as the rest of the network; 255.255.0.0 and the default gateway for the PC would be the e0 that connects the LAN to RouterB.
    So if a PC needs to find something that is not local or located on its LAN, the DFGW will take the request to the router by way of the Ethernet Interface that connects the LAN to the Router. An example of that would be, if you ping a PC located on the Ethernet network of RouterB from RouterA’s LAN, the return echo from the PC has to know how to get back to the network on RouterA from which it came. Since the Ethernet network path on RouterA is known to RouterB through a routing table entry, the DFGW on the PC will take the unknown request for the return trip of the packet from the PC and send it to RouterB which will know what to do with it. No default Gateway in the TCP/IP properties of the PC and the packet will just time out and the ping attempt will be unsuccessful. Chances are the ping did reach the PC but the return echo did not know how to find a way back.
    End of Lab

    Basic Router Configuration Lab NoAnswers



    Objective:
    In this lab you will configure a simple network to allow two routers to route packets between to remote networks.
    Requirements:

    • Two Cisco routers with one Ethernet port and one serial port.
    • Cisco IOS 10.0 or higher
    • One PC for consoling into routers with terminal emulation software
    • One serial cable
    • One Cisco rollover cable

    Setup:
    Step 1: Physical Connections

    Configure a console session to your router(s) from your PC.
    Step 2: Boot up the routers

    Do not use the setup mode (setup dialogue) or auto configuration to configure the router. Let the routers finish booting.
    Step 3: Host Name and Passwords

    Begin your configuration with the hostnames and passwords for both routers.
    Configure RouterA and RouterB with their correct hostnames. Configure all telnet sessions on both routers with the password of cisco Exit back to the privileged mode and save your current configuration
    Step 4: Adding IP Addresses

    Configure the interfaces on both routers with the IPs as per the network diagram. Set a description on all interface. Set the clockrate on the DCE end of the serial cable with a clockrate of 250000. Ensure the interfaces come up.
    Step 5a: Adding Dynamic Routing: RIP

    Configure both routers for dynamic routing using the routing protocol RIP. Advertise the appropriate networks on both routers.
    Check both routers to see if they are receiving RIP routing updates from each other. Ensure connectivity between the routers by using the ping command. Remove RIP before starting step 5b.
    Step 5b: Adding Dynamic Routing:

    IGRP Configure both routers to use the routing protocol IGRP. Configure both routers to use the same AS number. Advertise the appropriate networks on both routers.
    Check both routers to see if they are receiving IGRP routing updates from each other. Check to see what routing protocol the routers are using. Ensure connectivity between the routers by using the ping command. Remove IGRP before starting step 6.
    Step 6: Adding Default Routes

    Configure both routers with a default route to each other. Use the neighboring router as a smart gateway of last resort.
    Check to ensure that the routers have a default route.
    Ensure connectivity between the routers by using the ping command and pinging the interface e0 on each router.
    Step 7: Adding Static Routes

    Configure both routers with static routes to each routers remote network. Tell the routers how to find the path to each others Ethernet network.
    Check to ensure that the routers have a static route.
    Ensure connectivity between the routers by using the ping command and pinging the interface e0 on each router.
    Step 8: Optimize the router performance.

    Create a host table entry on each router to be able to ping the name of the router in lieu of the IP address.
    Configure both routers to turn off ip domain-lookup so they do not try and use a DNS server.
    Configure a MOTD on each router that warns of authorized access only.
    Configure both router not to look for a network configuration when they startup.
    Disable logging to the console screen on both routers.
    Step 9:

    Configure your PC(s) for connectivity on the network.
    Ping from the PC connected on RouterA's Ethernet 0 network to the PC on the Ethernet 0 of RouterB. If you only have one PC, ping the interface Ethernet 0 on the either router.
    End of Lab
    I hope you found this article to be of use and it helps you prepare for your Cisco CCNA certification. I am sure you will quickly find out that hands-on real world experience is the best way to cement the CCNA concepts in your head to help you pass your CCNA exam



    aryagohar سپاسگزاری کرده است.

کلمات کلیدی در جستجوها:

config router

access-list 10 permit 133.2.2.0 255.255.0.0 - allow all src ip’s on network 133.2.2.0pvcccnapassing packets between ethernet ports on a cisco routerinterface dialer persiannetworks.com

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •