صفحه 2 از 3 اولیناولین 1 2 3 آخرینآخرین
نمایش نتایج: از شماره 16 تا 30 از مجموع 34

موضوع: يك Ip واليد براي سه سرور

  
  1. #16
    نام حقيقي: علی پارسا

    عضو غیر فعال شناسه تصویری parsadevil
    تاریخ عضویت
    Nov 2008
    محل سکونت
    Dubai
    نوشته
    124
    سپاسگزاری شده
    36
    سپاسگزاری کرده
    1
    ip nat inside source static tcp 192.168.0.5 80 171.68.1.1 80 extendable

    یعنی اگر برای TCP پورت 80 یک packet از بیرون آمد... بفرست به 192.168.0.5 به پورت 80 اش
    در واقع این یک NAT پورت به پورت از یک آدرس Public به آدرس Private است اگر جاییش مشکل است بفرمایید.


    fafal سپاسگزاری کرده است.





  2. #17
    نام حقيقي: فرزاد

    عضو عادی
    تاریخ عضویت
    Jan 2009
    محل سکونت
    تهران
    نوشته
    46
    سپاسگزاری شده
    29
    سپاسگزاری کرده
    12
    ممون
    منظورم اينه چجوري nat رو تنظيم كنم تا بشه با اي پي وليد وب سروري كه اي پي اينوليد داره روي اينترنت browse بشه



  3. #18


    خواننده
    تاریخ عضویت
    Feb 2006
    نوشته
    142
    سپاسگزاری شده
    8
    سپاسگزاری کرده
    59
    خدمت اساتيد محترم بگم كه من در روتر را اينطوري تنظيم كردم
    ip nat inside source static tcp 172.16.1.5 8080 99.64.55.15 8080 extendable
    ip nat inside source static tcp 172.16.1.6 8081 99.64.55.15 8081 extendable
    ip nat inside source static tcp 172.16.1.7 8082 99.64.55.15 8082 extendable


    http://99.64.55.15:8080/paperless
    يا
    http://99.64.55.15:8081/mis
    و يا
    http://99.64.55.15:8082/webmali

    !
    interface Ethernet0
    ip address 172.16.1.9 255.255.255.0
    ip nat inside

    ولي امكان پذير نشد يعني هيچيك از page ها باز نمي شد.!
    آيا راه حل ديگه اي دارد؟
    اصلا دستورات را درست نوشتم؟




  4. #19
    نام حقيقي: علی پارسا

    عضو غیر فعال شناسه تصویری parsadevil
    تاریخ عضویت
    Nov 2008
    محل سکونت
    Dubai
    نوشته
    124
    سپاسگزاری شده
    36
    سپاسگزاری کرده
    1
    من Ip nat outside رو نمی بینیم رو interface سمت Internet تون
    از طرفی این paperless و mis و webmail از کجا پیدا شدن تو config ما نیسن باید تو IIS یا Apache تعریف شده باشند
    زمان تست کردن هم باید از بیرون و interface ی که nat outside روشه تست بگیربن نه از داخل



  5. #20


    خواننده
    تاریخ عضویت
    Feb 2006
    نوشته
    142
    سپاسگزاری شده
    8
    سپاسگزاری کرده
    59
    با سلام جناب آقاي پارسا

    خدمت شما عرض كنم در سئوال اول من عرض كردم يك عدد آي پي وليد روي يك روتر 1841 ست كردم و سه برنامه تحت وب دارم كه هر كدام را روي يك سرور جداگانه نصب هستند.
    1-آيا امكاني وجود دارد هر كدام از برنامه ها را با استفاده از يك آي اجرا كنم

    يعني
    2- آيا امكاني وجود دارد كه هر كدام از اين سرور ها جداگانه Remote كنم
    آنوقت شما استاد عزيز گفتيد
    به کمک Static NAT روی روتر این کار را میتوان انجام داد.

    ip nat inside source static tcp 192.168.0.5 80 171.68.1.1 80 extendable
    !
    interface Ethernet0
    ip address 192.168.0.254 255.255.255.0
    ip nat inside
    !
    interface serial0
    ip nat outside

    یعنی هر چه برای IP 171.68.1.1 روی پورت 80 از اینترنت آمد بفرست به 192.168.0.5

    من هم اينكار را كردم منتهي پورت سريال سيسكو 1841 فعال نشد
    و در آخر...






  6. #21
    نام حقيقي: علی پارسا

    عضو غیر فعال شناسه تصویری parsadevil
    تاریخ عضویت
    Nov 2008
    محل سکونت
    Dubai
    نوشته
    124
    سپاسگزاری شده
    36
    سپاسگزاری کرده
    1
    remotedesktop از پورت خودش استفاده میکنه Web هم از پورت خودش (80) فرقی نمیکنه برای NAT کدام پورت را به کدام IP و پورت بفرسته پس در تنظیم NAT میتوانید هر پورتی را از بیرون به هر سرور داخلی بفرستید تا اینجاش کار سیسکو.... برای URL های شما باید سرورتان نیز پذیرای آن باشد یعنی باید از داخل این URL با IP داخلی کار میکند که از خارج با IP ولید کار کند...
    قضیه ساده است اگر TCPIP را بدانی....ما پورت و IP را به پورت و IP دیگر داریم ترجمه میکنیم...

    من در مورد RDP شما جوابی ندادم چون در Windows باید داخل رجیستری تغییر بدی
    How to change the listening port for Remote Desktop

    من جوابهای ارسالی را یکبار مرور کردم شما دیگه باید بتونی این کار را انجام بدی... بیشتر تلاش کن ...







  7. #22


    خواننده
    تاریخ عضویت
    Feb 2006
    نوشته
    142
    سپاسگزاری شده
    8
    سپاسگزاری کرده
    59
    خوب بسيار ممنون
    البته من اينكارها را انجام دادم بطور كلي توضيح مي دهم شايد مفيد واقع شود و بيانگر موضوع اصلي باشد.
    1- خط adsl با يك آي پي واليد كه تنظيمان آن بصورت ذيل انجام دادم

    interface FastEthernet0/1
    no ip address
    ip nat outside
    no ip mroute-cache
    speed auto
    half-duplex
    pppoe enable
    pppoe-client dial-pool-number 1
    no cdp enable
    !
    interface Dialer1
    mtu 1492
    ip address negotiated
    ip access-group firewall in
    ip access-group firewall out
    ip nat outside
    encapsulation ppp
    ip tcp adjust-mss 1452
    no ip mroute-cache
    dialer pool 1
    dialer idle-timeout 0
    dialer persistent max-attempts 9999
    dialer-group 1
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username xxxxxxpassword 0 xxxxx
    !
    ip route 0.0.0.0 0.0.0.0 Dialer1
    !
    ip nat inside source static tcp 172.16.1.5 8080 99.64.55.15 8080 extendable
    تا اينجا نمي دونم درست است يا نه؟ ولي جواب گرفتم يعني ping DNS را دارم و اينترنت وصل شدم (در روتر) و مي دونم كه آي پي واليدم 99.64.55.15 است.
    حالا از بيرون مي خوام page باز كنم (اصلا فعلا از خير ريموت دسكتاب گذشتيم !!!)
    1-1 - اصلا اين آدرس درسته كه مي نويسم؟ (در شبكه داخلي كافيه فقط بنويسم http://172.16.1.5/paperless) تنظيمات paperless در IIs درسته و آنها را انجام دادم
    1-2- وقتي كابل adsl را به كارت شبكه دوم دستگاه سرور نصب مي كنم و كانكت مي شم آدرس سيستم درست كار ميكنه يعني:
    http://99.64.55.15/paperless بدون پورت 8080

    access-list ها از قبل همين بوده من نه اضافه كردم نه پاك ممكنه پورتي را بسته باشم؟
    access-list 23 permit 10.10.10.0 0.0.0.7
    access-list 130 permit icmp any any echo
    access-list 130 permit icmp any any echo-reply
    access-list 130 deny ip any any
    access-list 150 deny tcp any eq 1034 any
    access-list 150 deny tcp any eq 1080 any
    access-list 150 deny tcp any eq 1214 any
    access-list 150 deny tcp any eq 2535 any
    access-list 150 deny tcp any eq 1433 any
    access-list 150 deny tcp any eq 3127 any
    access-list 150 deny tcp any eq 2745 any
    access-list 150 deny tcp any eq 4444 any
    access-list 150 deny udp any eq 1434 any
    access-list 150 deny udp any range 135 netbios-ss any
    access-list 150 deny tcp any range 1036 1037 any
    access-list 150 deny tcp any any eq 81
    access-list 150 deny tcp any any eq 445
    access-list 150 deny tcp any any eq 1080
    access-list 150 deny tcp any any eq ident
    access-list 150 deny tcp any any eq 1214
    access-list 150 deny tcp any any eq 2745
    access-list 150 deny tcp any any eq 5101
    access-list 150 deny tcp any any eq 5554
    access-list 150 deny tcp any any eq 6129
    access-list 150 deny tcp any any eq 9996
    access-list 150 deny udp any any eq 1434
    access-list 150 deny tcp any any eq 11768
    access-list 150 deny tcp any any eq 15118
    access-list 150 deny tcp any any range 1022 1025
    access-list 150 deny tcp any any range 135 139
    access-list 150 deny udp any any range 135 netbios-ss
    access-list 150 permit ip any any
    اگر منظورم را درست گفتم و يا جايش را كم گفتم ببخشيد.
    ممنون




  8. #23
    نام حقيقي: علی پارسا

    عضو غیر فعال شناسه تصویری parsadevil
    تاریخ عضویت
    Nov 2008
    محل سکونت
    Dubai
    نوشته
    124
    سپاسگزاری شده
    36
    سپاسگزاری کرده
    1
    هر وقت شبکه داخی رو 8080 جواب داد از بیرون هم رو 8080 جواب میده...

    شما که داخلی وب سرور را روی پورت 80 (استاندارد) قراردادی چرا در NAT آنرا به پورت 8080 فرستادی!


    ip nat inside source static 172.16.1.5 80 99.64.55.15 8080 extendable

    این خط 8080 بیرون رو به 80 داخل شما میفرسته



  9. #24


    خواننده
    تاریخ عضویت
    Feb 2006
    نوشته
    142
    سپاسگزاری شده
    8
    سپاسگزاری کرده
    59
    با سلام خدمت آقاي پارسا
    خيلي اذيتت كردم ولي جواب نگرفتم من در iis پورت را 8080 قرار دادم ولي باز هم جواب نگرفتم
    شبكه داخلي هم روي پورت 8080 جواب داد
    يعني http://172.16.1.5:8080/paperless





  10. #25
    نام حقيقي: علی پارسا

    عضو غیر فعال شناسه تصویری parsadevil
    تاریخ عضویت
    Nov 2008
    محل سکونت
    Dubai
    نوشته
    124
    سپاسگزاری شده
    36
    سپاسگزاری کرده
    1
    هر بار که تغییری در NAT میدهی باید یک بار در خارج از Configuration دستور زیر:
    Clear ip nat translation * را بزنی (آخرش ستاره بزن Shift + 8)

    الان داری پورت 8080 را به 8080 داخلی وصل میکنی پس در تنظیم NAT نیز 8080 را به 8080 ترجمه کن



  11. #26


    خواننده
    تاریخ عضویت
    Feb 2006
    نوشته
    142
    سپاسگزاری شده
    8
    سپاسگزاری کرده
    59
    خوب من همين كار را كردم ولي نشد
    * Clear ip nat translation
    و بعد دستور زير را نوشتم
    ip nat inside source static tcp 172.16.1.5 8080 99.64.55.15 8080 extendable

    و بعد هيچ !!!



  12. #27
    نام حقيقي: علی پارسا

    عضو غیر فعال شناسه تصویری parsadevil
    تاریخ عضویت
    Nov 2008
    محل سکونت
    Dubai
    نوشته
    124
    سپاسگزاری شده
    36
    سپاسگزاری کرده
    1
    این الان رو روتر من کار میکنه:
    ip nat inside source static tcp 192.168.251.25 443 128.128.128.128 443 extendable no-alias

    اگر کار نمیکنه مشکل از جای دیگست

    show ip nat translation







  13. #28


    خواننده
    تاریخ عضویت
    Feb 2006
    نوشته
    142
    سپاسگزاری شده
    8
    سپاسگزاری کرده
    59
    آقاي پارسا با تشكر
    جواب نداد ! من از اينكه اين همه وقت را در اختيار من گذاشتيد تشكر مي كنم



  14. #29
    نام حقيقي: علی پارسا

    عضو غیر فعال شناسه تصویری parsadevil
    تاریخ عضویت
    Nov 2008
    محل سکونت
    Dubai
    نوشته
    124
    سپاسگزاری شده
    36
    سپاسگزاری کرده
    1
    جواب نداد نداریم باید جواب بده:

    در تنظیم قبلی تون اینو دیدم که اضافیه:

    interface FastEthernet0/1
    ip nat outside


    چون ADSL دارین فقط باید روی Dialer تنظیم ip nat outside را داشته باشین. در ضمن show ip nat translation را هم نفرستایدن
    کل تنظیم را ارسال کنید...



  15. #30


    خواننده
    تاریخ عضویت
    Feb 2006
    نوشته
    142
    سپاسگزاری شده
    8
    سپاسگزاری کرده
    59
    interface FastEthernet0/1
    no ip address
    no ip mroute-cache
    speed auto
    half-duplex
    pppoe enable
    pppoe-client dial-pool-number 1
    no cdp enable

    interface Dialer1
    mtu 1492
    ip address negotiated
    ip access-group firewall in
    ip access-group firewall out
    ip nat outside
    encapsulation ppp
    ip tcp adjust-mss 1452
    no ip mroute-cache
    dialer pool 1
    dialer idle-timeout 0
    dialer persistent max-attempts 9999
    dialer-group 1
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username xxxxxxx password xxxxx

    ip nat inside source static tcp 172.16.1.5 8080 99.64.55.15 8080 extendable

    router#show ip nat translations
    Pro Inside global Inside local Outside local Outside global
    tcp 99.64.55.15:8080 172.16.1.5:8080 217.219.275.115:1590 217.219.275.115:1590
    tcp 99.64.55.15:8080 172.16.1.5:8080
    tcp 99.64.55.15:8080 172.16.1.5:8080




صفحه 2 از 3 اولیناولین 1 2 3 آخرینآخرین

کلمات کلیدی در جستجوها:

http:172.16.1.6:8081

استفاده ip valid از پورت 80

پورت 1433 در میکروتیکدستور ip nat inside source staticراه اندازی ریموت دسکتاب از طریق ای پی ولید و روتر سیسکوآی پی ولید در میکروتیک ping نمی شودextendable در nat چه کار میکندping ندادن ip staticباز کردن پورت 1433 در میکروتکچگونگی nat کردن ip valid به invalid با روتر 1841پینگ ندادن ip staticنت کردن برای یک وب سرور در روتر 1841چگونگی فورارد کردن آی پی در روتر سیسکو تغییر ای پی valid بهinvalid

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •