نمایش نتایج: از شماره 1 تا 5 از مجموع 5
سپاس ها 3سپاس
  • 1 توسط mehrzadmo
  • 1 توسط shahani
  • 1 توسط shahani

موضوع: اتصال از طریق کلاینت l2tp به یک ادرس لیست خاص

  
  1. #1
    نام حقيقي: مهشید سام

    عضو عادی
    تاریخ عضویت
    Oct 2018
    محل سکونت
    مشهد
    نوشته
    34
    سپاسگزاری شده
    1
    سپاسگزاری کرده
    15

    اتصال از طریق کلاینت l2tp به یک ادرس لیست خاص

    سلام
    من میخوام یک ادرس لیست از سرور های تلگرام و یوتیوب تهیه کنم .. ادرس های تلگرام راحت پیدا میشن ولی یوتیوب رو چطور باید پیدا کنم ؟؟

    سوال اصلی این هست که چطور یک کلاینت l2tp بسازم که بتونم توی شبکه داخلی بدون محدودیت به ادرس لیستم متصل بشم ؟
    مانگل و روت و نت رو کانفیگ کردم ولی جواب نمیده .. ممکنه راهنمایی کنید چطو باید انجام بدم ؟!



    موضوعات مشابه:

  2. #2
    نام حقيقي: مهرزاد مقدس

    عضو ویژه/سرپرست بخش‌های Mikrotik و Wireless
    تاریخ عضویت
    Sep 2006
    محل سکونت
    فارس
    نوشته
    4,341
    سپاسگزاری شده
    4584
    سپاسگزاری کرده
    2278
    نوشته های وبلاگ
    6
    policy based routing رو برای روش انجام کار توی ویکی میکروتیک ببینید . برای ادرس ها چون روی کلود هستند و رنجشون زیاده باید جستجو کنید .


    hrs192 سپاسگزاری کرده است.
    MikroTik Certified Trainer & Consultant
    Mikrotik Official Distributor

  3. #3
    نام حقيقي: ali

    عضو عادی
    تاریخ عضویت
    Jun 2010
    محل سکونت
    mashhad
    نوشته
    486
    سپاسگزاری شده
    373
    سپاسگزاری کرده
    47
    همانطور که جناب مهرزاد استاد عزیز اشاره فرمودند، اصول کار در ویکی میکروتیک توضیح داده شده است
    همینطور در تاپیک های انجمن میتوانید اطلاعات بیشتر و کامل تری در این خصوص بدست بیاورید:
    تنظیمات اولیه :
    تغییر ای پی با وی پی ا-ن و مشکل باز نشدن بعضی از سایتها
    ش ی لت ر در میکروتیک نیاز به تعریف ای پی
    همینطور مطالب بسیار زیاد دیگه ای در این زمینه میتوانید در انجمن با اندکی جستجو پیدا کنید.
    ملاحظات اضافه :
    PING نشدن کاربران LAN بعد از اتصال VPN داخلی

    انجام Policy_Base_Routing به پردازنده شما ، مخصوصا در زمان استفاده دانلود و عبور ترافیک زیاد، بار پردازشی تحمیل می کند.
    بنابراین باید، توانایی های روتر خود را مد نظر قرار دهید، اگر پردازنده تک هسته ای دارید، به شما توصیه میکنم که تنها اصل مسئله را مورد نظر قرار دهید و بعد بصورت استاتیک، آی پی وب سایت ها را در آدرس لیست خود وارد نمایید، همین طور توجه داشته باشید که بدون تحمیل بار اضافه میتوانید در آدرس لیست خود بجای وارد کردن، آی پی وب سایت ها، آدرس کامل دامنه آنها را وارد نمایید که میکروتیک به طور دائم آدرس های آی پی سالم از آن وب سایت ها را در جدول DNS خود و آدرس لیست نگه دارید کند، مثلا میتوانید در آدرس لیست وارد نمایید : forum.persiannetworks.com (این قابلیت در نسخه های جدید روتر او اس اضافه شده است) .
    - این حالت بهترین روش برای بروزرسانی آی پی وب سایت ها و دامنه ها است، زیرا بعد از اتمام زمان TTL یک دامنه، میکروتیک مجددا آی پی را دریافت نموده و خود را بروز میکند.
    امکان استفاده از این روش برای یوتیوب و وب سایت هایی که دامنه های عجیب و پویا دارند، وجود ندارد، زیرا شما نمیتوانید از ابتدا نام هزاران دامنه پویا را در آدرس لیست وارد نمایید، و در آدرس لیست چون به صورت نظیر به نظیر عمل می شود، حتما نیاز وجود دارد که نام کامل دامنه برای بروزرسانی وارد شده باشد.

    در هر حال اگر روتر قدرتمندی دارید که پردازنده قوی دارد،(حداقل چهار هسته ای مثل RB4011) شما نیز میتوانید مثل من به روش پویا عمل کنید.
    یعنی اسکریپتی بنویسید که بطور دائم جدول DNS روتر را چک کند واگر در بخشی از نام دامنه، کلمه مورد نظر شما وجود داشته باشد، آن را بطور پویا و در مدت زمان مشخص شده شما ، به آدرس لیست اضافه نماید.
    در این حالت هر زمان که کاربران شما مشغول استفاده از آدرسی باشند که کلمه مورد نظر شما، بخشی از دامنه، باشد، توسط این اسکریپت، میتوانید مطمئن باشید که آن آدرس به آدرس لیست شما اضافه می شود.
    کد:
    :foreach i in=[/ip dns cache all find where (name~"youtube" ||  name~"wikia.com" || name~"twitter" || name~"facebook" || name~"fbcdn" || name~"fandom.com"  || name~"giphy" || name~"4chan" || name="t.co" || name~"googlevideo.com" ) && (type="A") && (static=no) ] do={
    :local tmpAddress [/ip dns cache get $i address];
    :local cacheName [/ip dns cache get $i name] ;
    :delay delay-time=20ms
    :if ( ( [:len $tmpAddress] != 0) && ( [:len $cacheName] != 0) && !($cacheName~"instagram") )  do={
    :if ( [/ip firewall address-list find where list="VPN" address=$tmpAddress] = "") do={
    :log info ("added entry To VPN: \"$cacheName\"  \"$tmpAddress\"");
    :do {
    /ip firewall address-list add address=$tmpAddress list="VPN" timeout="60d00:00:00" comment=$cacheName;
    } on-error={}
    }
    }
    }

    نکته اول در مورد این اسکریپت زمان اجرا آن در روتر است، میتوانید آن را هر 10 دقیقه یک بار اجرا نمایید
    باید در نظر داشته باشید که در این حالت ممکن است یک کاربر، اگر به آدرسی برای اولین بار فصد ارتباط داشته باشد، ممکن است، حداکثر تا ده دقیقه، ارتباط مورد نظر را بدست نیاورد، برعکس آن اگر برای حل این مشکل بخواهید هرچه سریعتر اسکریپت به طور متوالی انجام شود، بار پردازشی به همان نسبت بالا خواهد رفت، همینطور هرچه تعداد آدرس های موجود در این اسکریپت بالاتر باشد، طبیعتا زمان هر بار اجرا بالاتر خواهد رفت.
    من در روتر 36 هسته ای خود، این زمان را تنها 12 ثانیه تنظیم نموده ام و این اسکرپیت به خوبی و بدون مشکل کار میکند، البته من یک اسکریپت دیگر نیز دارم که معکوس عمل میکند و آدرس هایی که نیاز است، ارتباط آنها همیشه به صورت مستقیم و خارج از VPN برقرار شود را بصورت پویا از جدول DNS استخراج می کند.

    نکته دوم در مورد اسکریپت این هست که delay-time از هنگ کردن تریمنال روتر در زمان اجرای اسکریپت جلوگیری میکند و میتوانید برای روانتر کردن کار روتر، در صورت نیاز این زمان را بیشتر کنید، اما کمتر از 10 میلی ثانیه نکنید، زیرا اعمال نمیگردد و روتر آنرا 0 درنظر میگیرد.


    پیشنهاد های جایگزینی نیز، بجای استفاده از اسکریپت وجود دارد
    یک روش استفاده از هات اسپات است، میتوانید برای کاربران خود، دو سری اکانت، تدارک ببینید، درصورتی که آنها به اکانت های گروه اول متصل شوند، آدرس آی پی آنها بطور خودکار در گروه اول قرار گیرد که اینترنت آنها فیلتر شده است و اگر با اکانت گروه دوم متصل شوند، در رنج آی پی هایی قرار میگیرند که سورس آدرس آنها بطور کامل شامل قوانین روتینگ، نوشته شده شما می شود و تمام ترافیک آنها به داخل VPN هدایت خواهد شد.

    یا می توانید کل ترافیک پورت های 80 و 443 مربوط به وب سایت های کاربران خود را از داخل VPN عبور دهید، بجز موارد خاصی که در آدرس لیست، استثنا نموده اید، مانند آدرس بانک ها، بازی ها و غیره.

    مسئله ای که فکر میکنم، نیاز است مجدد به آن تاکید کنم، نیاز به مارک گذاری و عبور داده های DNS خود روتر از داخل تونل VPN است، زیرا این مورد در ویکی میکروتیک درنظر گرفته نشده است و بسیار دارای اهمیت است.
    اگر داده های DNS خروجی روتر شما در Chain Output مارک گذاری نشوند و بصورت مستقیم به سمت اینترنت روانه شوند، شامل فیلترینگ خواهند شد.

    بطور کلی بحث و گفتگو در مورد این مسئله بسیار گسترده است و از هر روش ابتکاری نیز میتوان استفاده نمود.


    ویرایش توسط shahani : 2019-11-12 در ساعت 06:37 PM
    hrs192 سپاسگزاری کرده است.

  4. #4
    نام حقيقي: ali

    عضو عادی
    تاریخ عضویت
    Jun 2010
    محل سکونت
    mashhad
    نوشته
    486
    سپاسگزاری شده
    373
    سپاسگزاری کرده
    47
    تغییر و اصلاح جزئی اسکریپت در مقداردهی متغییر .

    VPN
    کد:
    :local tmpAddress ;
    :local cacheName ;
    :foreach i in=[/ip dns cache all find where (name~"youtube" ||  name~"wikia.com" || name~"twitter" || name~"facebook" || name~"fbcdn" || name~"fandom.com"  || name~"giphy" || name~"4chan" || name="t.co" || name~"googlevideo.com" ) && (type="A") && (static=no) ] do={
    :set tmpAddress [/ip dns cache get $i address];
    :set cacheName [/ip dns cache get $i name];
    :delay delay-time=20ms
    :if ( ( [:len $tmpAddress] != 0) && ( [:len $cacheName] != 0) && !($cacheName~"instagram") )  do={
    :if ( [/ip firewall address-list find where list="VPN" address=$tmpAddress] = "") do={
    :log info ("added entry To VPN: \"$cacheName\"  \"$tmpAddress\"");
    :do {
    /ip firewall address-list add address=$tmpAddress list="VPN" timeout="60d00:00:00" comment=$cacheName;
    } on-error={}
    }
    }
    }
    Direct
    کد:
    :local tmpDirectAddress;
    :local cacheDirectName;
    :foreach xx in=[/ip dns cache all find where (name~"supercell" ||  name~"clashofclans" || name~"clashroyale" || name~"instagram.com" || name~"izbank.ir" || name~"rb24.ir" || name~"bankmellat.ir" || name~"shaparak.ir" || name~"shaparak.com" || name~"bmi.ir" || name~"cbi.ir" || name~"postbank.ir" || name~"tejaratbank.ir" || name~"edbi.ir" || name~"ttbank.ir" || name~"bankrefah.ir" || name~"banksepah.ir" || name~"refah-bank.ir" || name~"banksepah.ir" || name~"bim.ir" || name~"qmb.ir" || name~"ghbi.ir" || name~"bki.ir" || name~"bank-maskan.ir" || name~"enbank.ir" || name~"ansarbank.com" || name~"parsian-bank.ir" || name~"bpi.ir" || name~"ba24.ir" || name~"hibank24.ir" || name~"bank-day.ir" || name~"sinabank.ir" || name~"sb24.com" || name~"sbank.ir" || name~"shahr-bank.ir" || name~"city-bank.net" || name~"bsi.ir" || name~"rqb.ir" || name~"rqbank.ir" || name~"karafarinbank.ir" || name~"tourismbank.ir" || name~"tourism-bank.com" || name~"aparat.com" || name~"irancell" || name~"gsm.ir") && (type="A")] do={
    :set tmpDirectAddress [/ip dns cache get $xx address];
    :set cacheDirectName [/ip dns cache get $xx name] ; 
    :delay delay-time=20ms ;
    :if ( ( [:len $tmpDirectAddress] != 0) && ( [:len $cacheDirectName] != 0 ) ) do={
    :if ( [/ip firewall address-list find where list="All Direct" address=$tmpDirectAddress] = "" ) do={ 
    :log info ("added entry To All Direct: \"$cacheDirectName\"  \"$tmpDirectAddress\"");
    :do {
    /ip firewall address-list add address=$tmpDirectAddress list="All Direct" timeout="247d00:00:00" comment=$cacheDirectName;
    } on-error={}
    }
    }
    }



    ویرایش توسط shahani : 2019-11-12 در ساعت 07:43 PM
    hrs192 سپاسگزاری کرده است.

  5. #5
    نام حقيقي: مهشید سام

    عضو عادی
    تاریخ عضویت
    Oct 2018
    محل سکونت
    مشهد
    نوشته
    34
    سپاسگزاری شده
    1
    سپاسگزاری کرده
    15
    توضیحات عالی بود ممنون از راهنماییتون .. مسئله حل شد



کلمات کلیدی در جستجوها:

هیچ کلمه ای ثبت نشده است.

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •