نمایش نتایج: از شماره 1 تا 4 از مجموع 4

موضوع: dstnat کار نمی کند !!!

  
  1. #1
    نام حقيقي: محسن

    تازه وارد
    تاریخ عضویت
    Apr 2016
    محل سکونت
    تهران
    نوشته
    8
    سپاسگزاری شده
    2
    سپاسگزاری کرده
    0

    dstnat کار نمی کند !!!

    درود بر دوستان

    در یک شبکه WAN یه IP PBX بزرگ دارم که به بقیه کاربرهای شبکه سرویس میده. چطوری؟

    به این شکل که هر نمایندگی برای خودش شبکه LAN داره که با یه روتر میکروتیک به شبکه WAN متصل شده.
    توی شبکه LAN هر کدوم از نمایندگی ها یه IP PBX کوچیک هست که به PBX مرکزی متصل شده.

    حالا من برای دسترسی کاربرهای نمایندگی به تلفن های مخابرات چند تا رول نوشتم
    1- یک رول NAT با اکشن masquerade که اجازه تماس از داخل به بیرون رو میده.
    2- یه رول از نوع dstnat برای نمایندگی ها و مخابرات از بیرون به داخل

    اولین رول من کار می کنه ولی دومی کار نمیکنه
    یعنی torch می کنم و درخواست های سمت مخابرات و سایرین رو می بینم که روی 5060 UDP به مقصد IP سمت WAN میاد. اما و هزار اما رول dstnat کار نمیکنه !!!!

    چه کنم؟؟



    موضوعات مشابه:

  2. #2
    نام حقيقي: ali

    عضو عادی
    تاریخ عضویت
    Jun 2010
    محل سکونت
    mashhad
    نوشته
    361
    سپاسگزاری شده
    276
    سپاسگزاری کرده
    33
    برای اینکه رول Dstnat شما به درستی کار کنه دو مسئله مهم وجود داره اول این که آدرس آی پی عمومی و پابلیک شما که از روی اینترنت قابل شناسایی هست ، مستقیم در میکروتیک فعال باشه ، یعنی مثلا اگه مودم ADSL دارید بجای اینکه اون رو در حالت PPPoE قرار دهید ، درحالت Bridge قرار داده و با ست کردن یوزر و پسورد اتصال ؛ اولین اتصال را از isp در روتر خود برقرار کنید و ip static عمومی خودتون رو در اینترفیس متصل به مودم ها ست کنید.

    مسئله دوم انجام مسیریابی صحیح است تا داده هایی که با مقصد آی پی استاتیک شما از داخل شبکه شما ارسال می شوند را به سمت ISP خود و آی پی متقابل که در روتر ISP است و برای شما تنظیم شده هدایت کنید.

    برای اطلاعات بیشتر نحوه پورت فروارد در میکروتیک را بررسی دقیق تر کنید.
    https://mikrotik.tosinso.com/tips/31...D8%B1-mikrotik



  3. #3
    نام حقيقي: محسن

    تازه وارد
    تاریخ عضویت
    Apr 2016
    محل سکونت
    تهران
    نوشته
    8
    سپاسگزاری شده
    2
    سپاسگزاری کرده
    0
    ممنون از پاسختون

    این ها رول های nat من هستند؛


    VOIP ----->out side
    chain=srcnat action=src-nat to-addresses=xx.xxx.20.134 to-ports=5060 protocol=udp src-address=10.10.1.1 dst-address=xx.xxx.20.134
    out-interface=ether11-voip src-port=5060=""


    chain=dstnat action=dst-nat to-addresses=10.10.1.1 to-ports=5060-5061 protocol=udp src-address=xx.xxx.20.134 dst-address=xx.xxx.232.61
    dst-port=5060-5061=""


    chain=dstnat action=dst-nat to-addresses=10.10.1.1 to-ports=10000-20000 protocol=udp src-address=xx.xxx.20.134 dst-address=xx.xxx.232.61
    dst-port=10000-20000 -=""

    ضمنا SIP ALG رو هم غیر فعال کردم



  4. #4
    نام حقيقي: محسن

    تازه وارد
    تاریخ عضویت
    Apr 2016
    محل سکونت
    تهران
    نوشته
    8
    سپاسگزاری شده
    2
    سپاسگزاری کرده
    0
    اگر چه NAT انجام نمیشه. ولی احساس می کنم مشکل، تکنیک nat نیست.
    شاید اندازه پکت های مربوط به سیگنالینگ و شاید هم چیز دیگه..!



کلمات کلیدی در جستجوها:

هیچ کلمه ای ثبت نشده است.

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •