نمایش نتایج: از شماره 1 تا 6 از مجموع 6
سپاس ها 4سپاس
  • 2 توسط shahani
  • 1 توسط shahani
  • 1 توسط shahani

موضوع: بستن پورت Wan در میکروتیک با استفاده از Script در یک زمان مشخص.

  
  1. #1
    نام حقيقي: Behzad

    عضو عادی شناسه تصویری AH64-D
    تاریخ عضویت
    Oct 2016
    محل سکونت
    Garmsar
    نوشته
    32
    سپاسگزاری شده
    3
    سپاسگزاری کرده
    20

    بستن پورت Wan در میکروتیک با استفاده از Script در یک زمان مشخص.

    درود دوستان

    وقتتون بخیر.

    لطف می کنید به بنده کمک کنید

    ما ساعت 5 شرکتمون تعطیل میشه می خوام کار کنم با استفاده از Script در میکروتیک به صورت خودکار Port Wan که مربوط به ورودی Internet مون هستش قطع بشه و کسی Internet نداشته باشه.

    می خوام این کار هر روز راس ساعت 5 انجام بشه و Port Wan امون بسته بشه و فقط شبکه داخلی فعال باشه.

    ممنون میشم راهنمایی بفرمایید چگونه این Script بنویسم.



    موضوعات مشابه:

  2. #2
    نام حقيقي: ali

    عضو عادی
    تاریخ عضویت
    Jun 2010
    محل سکونت
    mashhad
    نوشته
    348
    سپاسگزاری شده
    264
    سپاسگزاری کرده
    33
    درود
    شما میتونید طبق روش های پایین اینترفیس مورد نظر خودتون رو پیدا کنید و اون ها رو در زمان های مختلف خاموش یا روشن نمایید.
    احتیاج به یه اسکریپت در میکروتیک

    کافی است با دستور زیر در داخل ترمینال شماره هر اینترفیس را نگاه کنید :

    کد:
    interface print



    سپس با دستور disable کردن و enable کردن آن اینترفیس را خاموش و روشن نمایید.
    کد:
    /interface disable 0
    کد:
    /interface enable 0
    در انتها نیز با زمان بندی اجرا شدن اسکریپت ها ، ارتباط روتر با مودم را در زمان های مشخص قطع و وصل نمایید.



    - - - ادامه - - -

    روش دیگری که میتوانم برای این کار پیشنهاد کنم ، قطع دسترسی کاربران داخل شبکه به اینترنت است.
    در این صورت خود روتر ، دسترسی به اینترنت را از دست نخواهد داد اما کاربران داخل شبکه امکان تبادل اطلاعات با اینترنت را نخواهند داشت.

    برای اینکار ابتدا شماره رول NAT که کاربران را به اینترنت متصل میکند از پنجره فایروال یا ترمینال بیابید مانند تصویر زیر :



    پس از آن با دستورات زیر اقدام به غیر فعال و فعال کردن این رول در دو اسکریپت جداگانه نمایید.
    کد:
    /ip firewall nat disable 21


    کد:
    /ip firewall nat enable 21
    در نهایت نیز طبق پست گذشته تنظیم نمایید این دو اسکریپت هر روز در زمان مشخص اجرا شوند.


    mehrzadmo و AH64-D سپاسگزاری کرده‌اند.

  3. #3
    نام حقيقي: Behzad

    عضو عادی شناسه تصویری AH64-D
    تاریخ عضویت
    Oct 2016
    محل سکونت
    Garmsar
    نوشته
    32
    سپاسگزاری شده
    3
    سپاسگزاری کرده
    20
    درود

    سپاسگذارم دوست گرامی، لطف کردین

    ببخشید لطف کنید بگید مثلا 5 عصر اینترنت قطع میشه ولی فردا 6 صبح اینترنت وصل بشه چطوری باید این فرمان بنویسم.



  4. #4
    نام حقيقي: ali

    عضو عادی
    تاریخ عضویت
    Jun 2010
    محل سکونت
    mashhad
    نوشته
    348
    سپاسگزاری شده
    264
    سپاسگزاری کرده
    33
    شما بصورت گرافیکی به کمک WinBox میتونید به System و سپس Scheduler بروید و پس از آن اقدام به ایجاد یک زمان بندی جدید کنید.





    یا بصورت فرمان در ترمینال میکروتیک آن را وارد نمایید:

    کد:
    /system scheduler add name="internet Off" start-date=oct/19/2018 start-time=17:00:00 interval="1d 00:00:00" on-event="net Off"


    در نمونه ای که زده شد ، در فردا 19 اکتبر برای اولین بار اسکریپت net Off (که حاوی دستور خاموش کردن اینترنت برای کاربران است) اجرا خواهد شد ؛ زمان اولین اجرا ساعت 5 بعد از ظهر یا 17 است و پس از اولین اجرا بطور دائم در مدت زمان های یک روزه این اسکریپت اجرا خواهد شد.

    توجه داشته باشید که برای روشن کردن مجدد در ساعت مشخص میبایست یک زمان بندی دیگر نیز اضافه نمایید
    به عنوان مثال مانند زمان بندی زیر :
    کد:
    /system scheduler add name="internet On" start-date=oct/19/2018 start-time=6:00:00 interval="1d 00:00:00" on-event="net On"

    نکته قابل توجه دیگر این است که باید دقت کنید تاریخ اولین شروع در گذشته نباشد ، در این صورت هرگز زمان بندی شما شروع به کار نخواهد کرد.

    - - - ادامه - - -

    ==========

    برای ساخت اسکریپت ها بصورت خط فرمان نیز میتوانید دستور های زیر را در ترمینال وارد کنید.

    با فرض اینکه اینترفیس شماره صفر (یا اولین پورت لن) روتر شما به مودم متصل شده باشد

    برای ساخت اسکریپت غیر فعال کردن ، دستور زیر را در ترمینال وارد کنید :
    کد:
    /system script add name="net Off" source="/interface disable 0"
    برای ساخت اسکریپت فعال کردن پورت متصل به مودم و اینترنت فرمان زیر را وارد نمایید :

    کد:
    /system script add name="net On" source="/interface enable 0"



    ویرایش توسط shahani : 2018-10-18 در ساعت 10:58 AM
    AH64-D سپاسگزاری کرده است.

  5. #5
    نام حقيقي: Behzad

    عضو عادی شناسه تصویری AH64-D
    تاریخ عضویت
    Oct 2016
    محل سکونت
    Garmsar
    نوشته
    32
    سپاسگزاری شده
    3
    سپاسگزاری کرده
    20
    درود

    سپاسگذارم دوست گرامی، لطف کردین پاسخ دادین.

    ببخشید یک سوال دیگه، در قسمت Interval اومدین 1d 00.00.00 گذاشتین این به این معنی هستش که هر روز این روند انجام بشه.



  6. #6
    نام حقيقي: ali

    عضو عادی
    تاریخ عضویت
    Jun 2010
    محل سکونت
    mashhad
    نوشته
    348
    سپاسگزاری شده
    264
    سپاسگزاری کرده
    33
    نقل قول نوشته اصلی توسط AH64-D نمایش پست ها
    درود

    سپاسگذارم دوست گرامی، لطف کردین پاسخ دادین.

    ببخشید یک سوال دیگه، در قسمت Interval اومدین 1d 00.00.00 گذاشتین این به این معنی هستش که هر روز این روند انجام بشه.
    بله ، بعد از هر اجرا ، شمارش معکوس Interval شرورع میشه و دقیقا سر زمان پایان یافتن این مدت زمانی ، مجددا اسکریپت اجرا خواهد شد.


    AH64-D سپاسگزاری کرده است.

کلمات کلیدی در جستجوها:

هیچ کلمه ای ثبت نشده است.

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •