نمایش نتایج: از شماره 1 تا 5 از مجموع 5
سپاس ها 2سپاس
  • 1 توسط mojtaba461
  • 1 توسط mojtaba461

موضوع: Import کردن User در Usermanager

  
  1. #1
    نام حقيقي: Blackie

    عضو عادی شناسه تصویری hexman
    تاریخ عضویت
    Jul 2012
    محل سکونت
    تهران
    نوشته
    2,308
    سپاسگزاری شده
    402
    سپاسگزاری کرده
    842

    Import کردن User در Usermanager

    سلام دوستان یک فایل اکسل دارم شامل دو ستون یکی user و دیگری password با حدود 200 رکورد..میخوام تو userman میکروتیک این یوزرها رو ایجاد کنم ایا راهی هست که بتونم یوزر و پسوردها رو از تو همین فایل اکسل به میکروتیک بدم تا بصورت خودکار ساخته بشن و مجبور نشم دویست یوزر رو بصورت دسنی بسازم؟

    ممنون



    موضوعات مشابه:





  2. #2
    نام حقيقي: مجتبی شمس نجاتی

    عضو عادی شناسه تصویری mojtaba461
    تاریخ عضویت
    Aug 2012
    محل سکونت
    لاهیجان
    نوشته
    2,346
    سپاسگزاری شده
    2240
    سپاسگزاری کرده
    702
    نوشته های وبلاگ
    11
    لینک زیر از صفحه میکروتیک شامل اسکریپتی هست که یوزر ها از فایل txt. میخونه و داخل ppp secret/ وارد می کنه.
    کد:
    http://wiki.mikrotik.com/wiki/Manual:Scripting-examples#Parse_file_to_add_ppp_secrets
    با کمی تغییر میشه از فایل csv. بخونه و بجای secret داخل usermanager بسازه:
    کد:
    :global content [/file get [/file find name=test.csv] contents] ;
    :global contentLen [ :len $content ] ;
    
    
    :global lineEnd 0;
    :global line "";
    :global lastEnd 0;
    
    
    
    
    :do {
           :set lineEnd [:find $content "\r\n" $lastEnd ] ;
           :set line [:pick $content $lastEnd $lineEnd] ;
           :set lastEnd ( $lineEnd + 2 ) ;
    
    
           :local tmpArray [:toarray $line] ;
        :if ( [:pick $tmpArray 0] != "" ) do={
        :put $tmpArray;
             /tool user-manager user add customer=admin name=[:pick $tmpArray 0] username=[:pick $tmpArray 0] password=[:pick $tmpArray 1];
    }
    } while ($lineEnd < $contentLen)



    ویرایش توسط mojtaba461 : 2014-12-16 در ساعت 03:21 PM
    hexman سپاسگزاری کرده است.
    mojtaba.shams [at] hotmail.com

  3. #3
    نام حقيقي: علیپور

    عضو عادی
    تاریخ عضویت
    Feb 2010
    محل سکونت
    تهران
    نوشته
    430
    سپاسگزاری شده
    16
    سپاسگزاری کرده
    54
    ساختار فایل csv و یا txt چگونه باید باشه ؟ لطفا در صورت امکان برای هر کدام فایلی با 2 یوزر بذارید.
    ضمنا این فایل txt یا csv رو در چه مسیری در میکروتیک باید کپی کنیم ؟


    ویرایش توسط javadkey : 2014-12-16 در ساعت 11:10 PM

  4. #4
    نام حقيقي: علیپور

    عضو عادی
    تاریخ عضویت
    Feb 2010
    محل سکونت
    تهران
    نوشته
    430
    سپاسگزاری شده
    16
    سپاسگزاری کرده
    54
    یه سوال دیگه اینکه این دستورات رو در کجا باید وارد کنیم؟



  5. #5
    نام حقيقي: مجتبی شمس نجاتی

    عضو عادی شناسه تصویری mojtaba461
    تاریخ عضویت
    Aug 2012
    محل سکونت
    لاهیجان
    نوشته
    2,346
    سپاسگزاری شده
    2240
    سپاسگزاری کرده
    702
    نوشته های وبلاگ
    11
    نقل قول نوشته اصلی توسط javadkey نمایش پست ها
    ساختار فایل csv و یا txt چگونه باید باشه ؟ لطفا در صورت امکان برای هر کدام فایلی با 2 یوزر بذارید.
    ضمنا این فایل txt یا csv رو در چه مسیری در میکروتیک باید کپی کنیم ؟
    فیلد ها با کاما (,) و ستون ها با new line از هم جدا میشن. مثل:
    کد:
    user1,123
    ali,654
    نقل قول نوشته اصلی توسط javadkey نمایش پست ها
    یه سوال دیگه اینکه این دستورات رو در کجا باید وارد کنیم؟
    مطالب مربوط به اسکریپت نویسی رو مطالعه بفرمایید:
    Persian Networks - مجتبی شمس نجاتی - وبلاگ های تخصصی


    hexman سپاسگزاری کرده است.
    mojtaba.shams [at] hotmail.com

کلمات کلیدی در جستجوها:

هیچ کلمه ای ثبت نشده است.

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •