نمایش نتایج: از شماره 1 تا 10 از مجموع 10
سپاس ها 7سپاس
  • 2 توسط mehrzadmo
  • 1 توسط al1p0ur
  • 2 توسط SADEGH65
  • 1 توسط fireboy007
  • 1 توسط mostafaa

موضوع: ندیدن و پینگ نشدن ip ولید از بیرون ، بعد از بالانس در میکروتیک

  
  1. #1
    نام حقيقي: kazi

    عضو عادی شناسه تصویری fireboy007
    تاریخ عضویت
    Jul 2011
    محل سکونت
    tehran
    نوشته
    169
    سپاسگزاری شده
    135
    سپاسگزاری کرده
    120

    ندیدن و پینگ نشدن ip ولید از بیرون ، بعد از بالانس در میکروتیک

    با سلام.من دو لینک اینترنت یکی 1مگ و دیگری 2 مگ دارم با دو رنج Ip ولید متفاوت روی هرکدوم از اونها.یکی 217.11.19.0 (2مگ) و یکی 217.11.24.0 (1مگ).داخل شبکه هم دو دسته شبکه،یکی شبکه داخلی با رنج IP از 10.0.0.0 و شبکه وایرلس از رنج 192.168.0.0.من با روش زیر شبکه داخلی رو از اینترنت 1 مگ و شبکه وایرلس رو از اینترنت 2 مگ route کردم.

    اول دوتا mangle تعریف کردم با chain : prerouting و action:mark routing و src.address برای یکی 10.0.0.0 و یکی 192.168.0.0 .که اسم mark routing برای 10.0.0.0 میشه Lan و برای 192.168.0.0 میشه wireless.بعدش تو بخش ip>Routes دو تا gateway تعریف کردم.برای Dst.address هر دو 0.0.0.0 برای gateway هاشون ، یکی gateway ای که برای رنج 217.11.19 داریم و یکی هم که gateway ای که برای رنج 217.11.24 داریم و routing mark رنج داخلی هم همونطور که تو mangle تعریف کردم Lan و رنج وایرلس هم Wireless . و در آخر هم که دو تا Nat با chain : srcnat و action : masqurade برای src.address هر دو رنج IP داخلی و وایرلس.

    الان همه چی درست کار میکنه و شبکه داخلی از اینترنت 1 مگ میره و شبکه وایرلس از اینترنت 2 مگ.تنها مشکلی که الان وجود داره اینه که ، من از بیرون ، از طریق اینترنت ، نمیتونم اون ip ولید هایی که روی 2تا از پورت ها که اون دو تا اینترنت بهشون وصل شدن رو ببینم یا پینگشون کنم.انواع رول ها و mangle ها رو هم که از خود ویکی میکروتیک پیدا میکردم رو امتحان کردم اما باز هم نشد.اینجا هم گشتم ، چنین مشکلی ندیدم کسی داشته باشه. کسی میتونه راهنمایی کنه که چجوری میشه این مشکل رو رفع کرد؟خیلی ممنون



    موضوعات مشابه:

  2. #2
    نام حقيقي: مهرزاد مقدس

    عضو ویژه/سرپرست بخش‌های Mikrotik و Wireless
    تاریخ عضویت
    Sep 2006
    محل سکونت
    فارس
    نوشته
    4,341
    سپاسگزاری شده
    4584
    سپاسگزاری کرده
    2278
    نوشته های وبلاگ
    6
    تريس كن ببين تا كجا مي آد ؟ اگر كلاينت هات مشكلي ندارند فكر نمي كنم ربطي به منگل داشته باشه .


    mjzaret و fireboy007 سپاسگزاری کرده‌اند.
    MikroTik Certified Trainer & Consultant
    Mikrotik Official Distributor

  3. #3
    نام حقيقي: kazi

    عضو عادی شناسه تصویری fireboy007
    تاریخ عضویت
    Jul 2011
    محل سکونت
    tehran
    نوشته
    169
    سپاسگزاری شده
    135
    سپاسگزاری کرده
    120
    تریس تا گام 9 میره و از 10 تا 30 رو request time out میزنه.البته یه چیز جالب وشایدم مسخره ای که هست ، اینه که یکی از همین آی پی ولید ها روی یکی از سرورها(ویندوز سرور 2003) ست شده.من اون آی پی رو نمیتونم پینگ کنم و تریس اون هم مثل تریس آی پی روی میکروتیک ، تا گام 9 بیشتر نمیره و بقیه رو time out میزنه ، اما میتونم به اون IP روی اون ویندوز remote desktop بزنم.واسه همین رو آی پی میکروتیکم هم فکر نکنم بشه خیلی به پینگ و تریس اش اعتماد کرد.کلاینتها هم مشکلی ندارن و راحت به اینترنت وصل میشن.اما چیزی که باعث میشه من به mangle ها مشکوک بشم ، اینه که ، تا قبل از اینکه لینک دوم اینترنت رو به میکروتیک وصل کنم و mangel ها رو تعریف کنم ، یعنی زمانی که فقط یه gateway داشتم و فقط به یه شبکه داخلی اینترنت میدادم ، مشکلی نبود و میتونستم ip ولیدی که رو میکروتیک ست شده بود رو از اینترنت ببینم.ضمن اینکه من دو ip ولید از دو رنج مختلف روی دوتا از پورتهای میکروتیک دارم و این مشکل با هر دو ip وجود داره.



  4. #4
    نام حقيقي: Ali

    عضو ویژه شناسه تصویری al1p0ur
    تاریخ عضویت
    Feb 2010
    محل سکونت
    Tehran
    نوشته
    2,089
    سپاسگزاری شده
    2413
    سپاسگزاری کرده
    730
    خب برادر شما شما اومدی پکت های شبکه های داخلی (LAN , Wireless) رو mark کردی و فقط همونا رو route کردی . پس بقیه ترافیک از جمله ipvalid ها به سمت بیرون route نمیشن .(اگر غیر از این هست تنظیمات route , mangle رو اینجا بذارید)

    یه راهش اینه که شما بیا پکت هایی که از بیرون به قصد ارتباط با Ipvalid ها میان رو mark کن , بعد اونارو هم به سمت بیرون Route کن .
    یا این که این ipvalid ها رو هم مثل شبکه داخلی mark و route کنی
    یا ...


    ویرایش توسط al1p0ur : 2012-02-24 در ساعت 01:49 PM
    fireboy007 سپاسگزاری کرده است.

  5. #5
    نام حقيقي: kazi

    عضو عادی شناسه تصویری fireboy007
    تاریخ عضویت
    Jul 2011
    محل سکونت
    tehran
    نوشته
    169
    سپاسگزاری شده
    135
    سپاسگزاری کرده
    120
    اتفاقا دقیقا خودم هم امروز به این نتیجه رسیده بودم.چون وقتی از بیرون اون ip ولید رو پینگ میکنم ، با اینکه request time out دارم ، اما وقتی رفتم تو میکروتیک داخل بخش ip>firewall و connections رو چک کردم ، دیدم که connection از src.address همین کامپیوتر خونه که دارم پینگ رو میزنم به dst.address همون ip ولید میکروتیک با پروتکل icmp ایجاد شده و فهمیدم که پس درخواست تا توی میکروتیک رسیده اما راه برگشتی براش وجود نداره.اما تا اونجایی که من عقلم جواب داد ، دو سه مدل mangle و route مختلف واسه این کار نوشتم و جواب نداد.که اومدم اینجا این نتایج رو با شما مطرح کنم که اینترنت خونه هم قطع شد تا الان که دوباره وصل شد و اومدم پیشنهاد شما رو دیدم ، که این مدل route که شما فرمودید رو ننوشته بودم.یعنی یک route مخصوص IP ولید.اما این هم جواب نداد.البته مطمئنا من اشتباه کردم یکجا رو.حالا چیزهای مختلفی رو که نوشتم میگم ، ببینید آیا جور دیگه ای باید مینوشتم؟
    یکبار یک mangle به این صورت نوشتم که مثلا ترافیک ورودی از بیرون رو مارک کنم تا بعدش اونها رو route کنم به بیرون : chain : input و src.address:0.0.0.0 و dst.address:217.11.19.x (ولید) و action : mark connection و new connection mark : remote بعدش تو قسمت ip>route دیدم نمیشه connection mark انتخاب کرد.فقط route mark ها رو میشه انتخاب کرد.پس تو mangle بالا ، chain رو کردم prerouting و action رو route mark.و بعدش تو Ip>route زدم dst.address: 0.0.0.0 و gateway : 217.11.19.y (گیت وی ای که مربوط به ip ولیدها میشه) و routing mark : remote اما جواب نداد.حتی تو mangle جای 0.0.0.0 برای src.address و در route جای dst.address ، آی پی سیستم خودم رو تو خونه که ولید نیست و از سایت whatismyip به دست آوردم، به صورت 188.158.0.0/16 زدم.ترافیک رو نشون میداد تو mangle اما باز هم مشکل حل نمیشد.که مطمئنا chain یا action مشکل داره.این حرف آخر شما رو هم که خوندم ، دیدم منطقی به نظر میرسه اون رو هم به این صورت انجام دادم:
    یه mangle جدید درست کردم که IP ولیدم رو mark کنه: chain: prerouting و src.address: 217.11.19.x و action: mark routing و new routing mark: remote بعدش تو route نوشتم : dst.address : 0.0.0.0 و gateway: 217.11.19.y و routing mark : remote دقیقا همون کاری که برای مارک کردن ترافیک شبکه های داخلی و وایرلس و بعد برای route کردنشون انجام دادم رو برای ip ولیدم انجام دادم.اما باز هم نشد.
    چیز دیگه ای به ذهنم نمیرسه.مطمئنم یه جای این chain ها و action ها داره میلنگه.حالا کجاشه نمیدونم


    ویرایش توسط fireboy007 : 2012-02-24 در ساعت 07:09 PM

  6. #6
    نام حقيقي: صادق نجاتی زاده

    مدیر بازنشسته شناسه تصویری SADEGH65
    تاریخ عضویت
    Nov 2003
    محل سکونت
    تهران
    نوشته
    2,264
    سپاسگزاری شده
    3413
    سپاسگزاری کرده
    3619
    نوشته های وبلاگ
    12
    ببینید باید در ابتدا یک رول در فایروال بخش منگل به صورت زیر بنویسید که در صورت وارد شدن پکت از اینترفیس مربوط به خط شماره 1 آن را برای خروج از این اینترفیس مارک کند و برای دومی هم به همین صورت تکرار کنید.
    کد:
    ip firewall mangle add chain=prerouting in-interface=ether1 connection-mark=no-mark action=mark-connection new-connection-mark=Line1 ip firewall mangle add chain=prerouting connection-mark=Line1 action=mark-routing routing-mark=Line1-Route



    mehrzadmo و fireboy007 سپاسگزاری کرده‌اند.

  7. #7
    نام حقيقي: kazi

    عضو عادی شناسه تصویری fireboy007
    تاریخ عضویت
    Jul 2011
    محل سکونت
    tehran
    نوشته
    169
    سپاسگزاری شده
    135
    سپاسگزاری کرده
    120
    با تشکر از راهنمایی های اساتید عزیز.وقتی یه راهی میگید ، من 500 مدل دیگه اش رو هم امتحان میکنم ، که یه وقت نگید این تنبله و میخواد هلو برو تو گلو باشه :d راهنمایی های شما دید رو به من میده و وقتی میبینم نمیشه ، کلی تجزیه و تحلیلش میکنم و روشون کلی کار میکنم که شرمنده شما نشم.اما باز هم با هیچکدوم نتیجه ای نگرفتم متاسفانه.این کاری که شما آقای نجاتی زاده فرمودید هم ، کاملا منطقی به نظر میرسه و گفتم صد در صد همین مشکل رو حل میکنه اما باز هم نشد.حتی من تو مارک کردن connection های ورودی ، chain رو به input تغییر دادم ، یا src.address و dst.address رو هم معرفی کردم.اما باز هم نشد.درضمن بعد از این دو خطی که شما گفتید ، ip>route رو به این صورت نوشتم : dst.address:0.0.0.0 و gateway:217.11.19.129 و routing mark:remote (همون line1-Route مثال شما).حتی Nat هم تعریف کردم : chain:srcnat و action:Masquerade ، یکبار برای connection ای که مارک کردیم ، یکبار برای routing mark.گفتم شاید ربطی داشته باشه ، که میدونم خیلی بی ربط بود این هم یه سری screenshot از mangle و route و Nat

    این همونی که شما اول گفتید:




    این هم وقتی chain:input کردم



    این هم با src.address , dst.address.که 217.11.19.132 همون ip ولیدی هست که میخوام بهش دسترسی داشته باشم و src.address هم که ip کنونی خونه اس.



    این هم nat که برای اون دوتا شبکه داخلی و وایرلس نوشته شده



    و در آخر route table که wireless to net شبکه وایرلس ، lan to net شبکه داخلی و Remote هم که برای همون connection , Routing mark هست

    و میبرتشون اینترنت


    ویرایش توسط fireboy007 : 2012-02-24 در ساعت 09:45 PM
    mehrzadmo سپاسگزاری کرده است.

  8. #8
    نام حقيقي: ایمان ادریسیان

    عضو عادی شناسه تصویری mostafaa
    تاریخ عضویت
    Feb 2007
    محل سکونت
    کیش
    نوشته
    353
    سپاسگزاری شده
    178
    سپاسگزاری کرده
    37
    سلام دوست من قبل از هر چیز به جای اینکه هی اسکرین شات بزاری یه خروجی از کانفیگت بگیر و اون رو اینجا بزار!!(Export) اما در مورد مشکلتون... همانطور که آقای نجاتی زاده گفتن شما باید به ازای هر اینترفیستون که Public IP روش داری یک رول منگل داشته باشی تا ترافیک ورودی از هر اینترفیس رو مارک کنی که موقع خروج از همون اینترفیس بفرستیش بره. مثلا اینجوری :
    کد:
    add chain=prerouting in-interface=ISP1 connection-mark=no-mark action=mark-connection \     new-connection-mark=ISP1_conn   add chain=prerouting in-interface=ISP2 connection-mark=no-mark action=mark-connection \      new-connection-mark=ISP2_conn
    برای خروج هم میتونی این رول ها رو بنویسی :
    کد:
    add chain=prerouting  in-interface=LAN connection-mark=no-mark action=mark-connection new-connection-mark=ISP1_conn   add chain=prerouting  in-interface=Wireless connection-mark=no-mark action=mark-connection new-connection-mark=ISP2_conn  add chain=prerouting connection-mark=ISP1_conn in-interface=LAN action=mark-routing \      new-routing-mark=to_ISP1  add chain=prerouting connection-mark=ISP2_conn in-interface=LAN action=mark-routing \     new-routing-mark=to_ISP2  add chain=output connection-mark=ISP1_conn action=mark-routing new-routing-mark=to_ISP1       add chain=output connection-mark=ISP2_conn action=mark-routing new-routing-mark=to_ISP2



    ویرایش توسط mostafaa : 2012-02-29 در ساعت 03:55 PM
    fireboy007 سپاسگزاری کرده است.

  9. #9
    نام حقيقي: kazi

    عضو عادی شناسه تصویری fireboy007
    تاریخ عضویت
    Jul 2011
    محل سکونت
    tehran
    نوشته
    169
    سپاسگزاری شده
    135
    سپاسگزاری کرده
    120
    آقا ایمان ممنون از راهنماییتون.بابت اون قضیه export به جای اسکرین شات ببخشید چون بلد نبودم.اما مشکل من :
    اول همه ی اینایی که شما گفتید رو زدم درست نشد.بعد تو ip>route من فقط این دوتا رو داشتم:
    کد:
    /ip route 
    add comment="Lan To Net" disabled=no dst-address=0.0.0.0/0 \     gateway=GW-Lan routing-mark=Lan 
    
    add comment="Wireless To Net" disabled=no dst-address=0.0.0.0/0 \     gateway=GW-Wireless routing-mark=Wireless

    بعد که این رو هم اضافه کردم به اون چیزی که شما گفته بودید درست شد.

    کد:
    add disabled=no dst-address=0.0.0.0/0 gateway=GW-Wireless
    یعنی یه route کلی نوشتم (بدون routing-mark)، که gateway اون ، همون gateway شبکه وایرلس هست.آیا این کار درست هست؟مشکل دیگه ای پیش نمیاد با این کار؟

    فقط یه سوال دیگه. این دو تا mangle آخری که برای output نوشتید لازمه؟چون من اون دو تا رو disable هم کردم ، باز هم کار میکرد.فکر کنم همون mark routing هایی که قبلش نوشتید هم کارش شبیه همینه.نه؟
    یعنی این :
    کد:
    add chain=prerouting connection-mark=ISP1_conn in-interface=LAN action=mark-routing \      new-routing-mark=to_ISP1  add chain=prerouting connection-mark=ISP2_conn in-interface=LAN action=mark-routing \     new-routing-mark=to_ISP2

    با این فرق داره؟
    کد:
    add chain=output connection-mark=ISP1_conn action=mark-routing new-routing-mark=to_ISP1       add chain=output connection-mark=ISP2_conn action=mark-routing new-routing-mark=to_ISP2
    فکر میکنم جفتش یه کار میکنه.نه؟؟؟؟



  10. #10
    نام حقيقي: عرفان عابدی

    عضو عادی شناسه تصویری 3rfan
    تاریخ عضویت
    Sep 2010
    محل سکونت
    Tehran
    نوشته
    25
    سپاسگزاری شده
    9
    سپاسگزاری کرده
    5
    دوست عزیز من یه سوال دارم
    شرمنده وقت نکردم کل کانفیگ هایی که نوشتی رو بخونم
    اما آیا شما rout بدون منگل واسه IP ها داری ؟ یا فقط روتات با منگل هستن ؟
    اگر نداری یکی ادد کن که بتونه به ورودی ها جواب بده
    اگر اینجوری باشه شما هیچ روتی واسه غیر از منگل های خودت نساختی ، پس دلیلی نداره هیچ منگلی بتونه اون پکت ها رو مارک کنه که دوباره واسش روت بنویسی

    دوستان اگر در این مورد صحبت شده و من چیز تکراری گفتم شرمنده
    هدف من فقط این بود که تجربه خودمو که همچین مشکلی داشتم گفته باشم



کلمات کلیدی در جستجوها:

پینگ کردن آی پی ولید در میکروتیک

ip ولید

ip ولید در میکروتیک

گرفتن پینگ تریس

مشکل پینگ نشدن میکروتیک

پینگ نشدن دو آی پی هم رنج در میکروتیک

nat table in mikrotik

در دسترس کردن ای پی داخلی میکروتیک در اینترنت

ipولید

تریس Ip

علت پینگ نشدن ip

انواع پینگ آی پی

علت پینگ نشدن آی پی؟

دسترسی به آی پی ولید میکروتیک

باز کردن ریموت در میکروتیک

علت پینگ نشدن آی پی ولید

علت ندیدن دو کامپیوتر از طریق شبکه

جدول منگل در میکروتیک

پینگ نشدن آی پی در شبکه

پینگ نشدن ای پی میکروتیک از خارج

دلیل پینگ نکردن یک آی پی ولید

پینگ نشدن آی پی ولید در سرور

request time out در آیپی ولید

پینگ نشدن شبکه داخلی میکروتیک

علت پینگ کردن

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •