نمایش نتایج: از شماره 1 تا 13 از مجموع 13

موضوع: چگون بار اضافه روتر مديريت كنيم؟

  
  1. #1


    عضو غیر فعال
    تاریخ عضویت
    Jun 2004
    نوشته
    47
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    0

    Icon14 چگون بار اضافه روتر را مديريت كنيم؟

    سلام
    من يك روتر با مشخصات و تنظيمات زير دارم كه در پايين ترين حالت بيش از 30 درصد پروسس داره
    ممنون مي شم كه من رو راهنمايي كنيد

    Cisco Internetwork Operating System Software
    IOS (tm) 2500 Software (C2500-I-L), Version 12.0(9), RELEASE SOFTWARE (fc1)
    Copyright (c) 1986-2000 by cisco Systems, Inc.
    Compiled Mon 24-Jan-00 21:19 by bettyl
    Image text-base: 0x0302F300, data-base: 0x00001000
    ROM: System Bootstrap, Version 4.14(9.1), SOFTWARE
    router uptime is 16 hours, 20 minutes
    System restarted by reload
    System image file is "flash:c2500-i-l.120-9.bin"
    cisco 2511 (68030) processor (revision K) with 14336K/2048K bytes of memory.
    Processor board ID 01435525, with hardware revision 00000000
    Bridging software.
    X.25 software, Version 3.0.0.
    1 Ethernet/IEEE 802.3 interface(s)
    2 Serial network interface(s)
    16 terminal line(s)
    32K bytes of non-volatile configuration memory.
    16384K bytes of processor board System flash (Read ONLY)
    Configuration register is 0x2102


    hostname 2511


    !

    aaa new-model

    a
    aa authentication login default local

    aaa authentication ppp nttac radius local

    aaa authorization network nttac radius

    aaa accounting update newinfo

    aaa accounting exec nttac start-stop radius

    aaa accounting network default none

    aaa accounting network nttac start-stop radius

    enable secret 5 ???/


    !

    username user1 privilege 15 password 0 ????

    username user password 0 ????

    ip subnet-zero

    ip rcmd rsh-enable

    ip rcmd remote-host SYSTEM 192.168.1.10 SYSTEM enable

    ip name-server 4.2.2.4

    ip name-server 192.9.9.3

    ip name-server 195.146.32.2

    ip name-server 195.146.32.66


    !
    !
    !
    interface Ethernet0

    ip address 192.168.1.1 255.255.255.0

    ip access-group wall in

    ip access-group wall out

    no ip directed-broadcast

    ip nat inside


    !

    interface Serial0

    no ip address

    no ip directed-broadcast

    shutdown


    !

    interface Serial1

    ip address x.x.x.x x.x.x.x (ip valid - subnet)

    ip access-group wall in

    ip access-group wall out

    no ip directed-broadcast

    ip nat outside

    interface Group-Async1

    ip unnumbered Ethernet0

    ip access-group wall in

    no ip directed-broadcast

    encapsulation ppp

    no ip mroute-cache

    async mode interactive

    peer default ip address pool pool1

    ppp authentication pap nttac

    ppp authorization nttac

    ppp accounting nttac

    group-range 1 16


    !

    ip local pool pool1 x.x.x.x x.x.x.x (ip valid)

    ip nat inside source list 1 interface Serial1 overload

    ip classless

    ip route 0.0.0.0 0.0.0.0 Serial1

    ip access-list extended wall

    deny tcp any any eq 445

    deny tcp any any eq 135

    deny tcp any any eq 139

    deny tcp any any eq 593

    deny tcp any any eq 4444

    deny udp any any eq 1434

    deny udp any any eq 135

    deny udp any any eq netbios-ns

    deny udp any any eq netbios-dgm

    deny udp any any eq netbios-ss

    deny tcp any any eq 136

    deny tcp any any eq 137

    deny tcp any any eq 138

    deny udp any any range 995 999

    deny tcp any any eq 1434

    deny udp any any eq ntp

    deny icmp any any echo

    deny icmp any any echo-reply

    permit ip any any

    access-list 1 permit 192.168.1.0 0.0.0.255

    snmp-server community ???? RW 15

    radius-server configure-nas

    radius-server host 192.168.1.10 auth-port 1645 acct-port 1646

    radius-server timeout 7

    radius-server deadtime 10

    !


    line con 0

    transport input none

    line 1 16
    autoselect during-login

    autoselect ppp

    modem answer-timeout 10

    modem Dialin

    modem autoconfigure discovery

    terminal-type vt100

    transport input all

    escape-character BREAK

    autohangup

    speed 115200

    flowcontrol hardware

    line aux 0
    line vty 0 4


    m.dehghan





    موضوعات مشابه:
    ویرایش توسط nowpa : 2005-01-22 در ساعت 01:32 AM





  2. #2
    نام حقيقي: Reza ARYAGOHAR

    مدیر بازنشسته شناسه تصویری aryagohar
    تاریخ عضویت
    Jul 2003
    محل سکونت
    Sydney ,Australia
    نوشته
    3,056
    سپاسگزاری شده
    942
    سپاسگزاری کرده
    215
    بطور طبيعي با ايجاد NAT بار افزايش پيدا مي كنه. ولي نحوه تعريف Access-group هاي شما در 2 تا از اينترفيس ها به يك صورت مزيد بر علت شده.

    اگه access-group ها رو كمتر كني و دقيقا به صورتي كه درست هست اعمال كني پروسس روترت بين 10 تا 15 درصد كمتر ميشه



  3. #3


    عضو غیر فعال
    تاریخ عضویت
    Jun 2004
    نوشته
    47
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    0
    نقل قول نوشته اصلی توسط aryagohar
    بطور طبيعي با ايجاد NAT بار افزايش پيدا مي كنه. ولي نحوه تعريف Access-group هاي شما در 2 تا از اينترفيس ها به يك صورت مزيد بر علت شده.







    اگه access-group ها رو كمتر كني و دقيقا به صورتي كه درست هست اعمال كني پروسس روترت بين 10 تا 15 درصد كمتر ميشه
    با سلام







    تنظيمات زير انجام دادم تغيير فاحشي رخ نداد



    hostname 2511



    !


    aaa new-model

    a
    aa authentication login default local

    aaa authentication ppp nttac radius local

    aaa authorization network nttac radius

    aaa accounting update newinfo

    aaa accounting exec nttac start-stop radius

    aaa accounting network default none

    aaa accounting network nttac start-stop radius

    enable secret 5 ???/



    !


    username user1 privilege 15 password 0 ????

    username user password 0 ????

    ip subnet-zero

    ip rcmd rsh-enable

    ip rcmd remote-host SYSTEM 192.168.1.10 SYSTEM enable

    ip name-server 4.2.2.4

    ip name-server 192.9.9.3

    ip name-server 195.146.32.2

    ip name-server 195.146.32.66



    !
    !
    !
    interface Ethernet0

    ip address 192.168.1.1 255.255.255.0

    no ip directed-broadcast

    ip nat inside



    !


    interface Serial0

    no ip address

    no ip directed-broadcast

    shutdown



    !


    interface Serial1

    ip address x.x.x.x x.x.x.x (ip valid - subnet)

    ip access-group wall in

    no ip directed-broadcast

    ip nat outside

    interface Group-Async1

    ip unnumbered Ethernet0

    no ip directed-broadcast

    encapsulation ppp

    no ip mroute-cache

    async mode interactive

    peer default ip address pool pool1

    ppp authentication pap nttac

    ppp authorization nttac

    ppp accounting nttac

    group-range 1 16



    !


    ip local pool pool1 x.x.x.x x.x.x.x (ip valid)

    ip nat inside source list 1 interface Serial1 overload

    ip classless

    ip route 0.0.0.0 0.0.0.0 Serial1

    ip access-list extended wall

    deny tcp any any eq 445

    deny tcp any any eq 135

    deny tcp any any eq 139

    deny tcp any any eq 593

    deny tcp any any eq 4444

    deny udp any any eq 1434

    deny udp any any eq 135

    deny udp any any eq netbios-ns

    deny udp any any eq netbios-dgm

    deny udp any any eq netbios-ss

    deny tcp any any eq 136

    deny tcp any any eq 137

    deny tcp any any eq 138

    deny udp any any range 995 999

    deny tcp any any eq 1434

    deny udp any any eq ntp

    deny icmp any any echo

    deny icmp any any echo-reply

    permit ip any any

    access-list 1 permit 192.168.1.0 0.0.0.255

    snmp-server community ???? RW 15

    radius-server configure-nas

    radius-server host 192.168.1.10 auth-port 1645 acct-port 1646

    radius-server timeout 7

    radius-server deadtime 10


    !



    line con 0

    transport input none

    line 1 16
    autoselect during-login

    autoselect ppp

    modem answer-timeout 10

    modem Dialin

    modem autoconfigure discovery

    terminal-type vt100

    transport input all

    escape-character BREAK

    autohangup

    speed 115200

    flowcontrol hardware

    line aux 0
    line vty 0 4

    نتيجه اين شد



    CPU utilization for five seconds: 45%/29%; one minute: 31%; five minutes: 31%

    PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process
    1 36528 52099 701 0.00% 0.01% 0.00% 0 Load Meter
    2 2356 191 12335 0.40% 1.60% 0.60% 18 Virtual Exec
    3 1155428 68486 16871 0.00% 0.40% 0.39% 0 Check heaps
    4 2368 835 2835 0.00% 0.00% 0.00% 0 Pool Manager
    5 4 2 2000 0.00% 0.00% 0.00% 0 Timers
    6 21360 1091 19578 0.00% 0.00% 0.00% 0 Serial Backgroun

    7 26644 6499 4099 0.00% 0.00% 0.00% 0 ARP Input
    8 392 718 545 0.00% 0.00% 0.00% 0 DDR Timers 9 20 2 10000 0.00% 0.00% 0.00% 0 Entity MIB API
    10 0 1 0 0.00% 0.00% 0.00% 0 SERIAL A'detect 11 8927572 2126370 4198 15.67% 2.33% 0.97% 0 IP Input
    12 90040 36060 2496 0.00% 0.02% 0.00% 0 CDP Protocol
    13 47916 33322 1437 0.00% 0.00% 0.00% 0 Asy FS Helper
    14 4240 3587 1182 0.00% 0.00% 0.00% 0 PPP IP Add Route
    15 0 1 0 0.00% 0.00% 0.00% 0 X.25 Encaps Mana 16 92 138 666 0.00% 0.00% 0.00% 0 TCP Timer
    17 44 8 5500 0.00% 0.00% 0.00% 0 TCP Protocols
    18 0 1 0 0.00% 0.00% 0.00% 0 Probe Input
    19 0 1 0 0.00% 0.00% 0.00% 0 RARP Input
    20 10532 1627 6473 0.00% 0.00% 0.00% 0 BOOTP Server
    21 224068 11388 19675 0.00% 0.03% 0.04% 0 IP ackground
    22 30368 4354 6974 0.00% 0.00% 0.00% 0 IP Cache Ager
    23 4 1 4000 0.00% 0.00% 0.00% 0 PAD InCall
    24 0 2 0 0.00% 0.00% 0.00% 0 X.25 Background
    25 0 1 0 0.00% 0.00% 0.00% 0 Socket Timers
    26 4 1 4000 0.00% 0.00% 0.00% 0 ISDN Timer
    27 34336 5297 6482 0.00% 0.01% 0.00% 0 PPP auth
    28 0 1 0 0.00% 0.00% 0.00% 0 CallMIB Backgrou

    29 0 1 0 0.00% 0.00% 0.00% 0 ISDNMIB Backgrou 30 0 1 0 0.00% 0.00% 0.00% 0 SNMP ConfCo
    31 8 2 4000 0.00% 0.00% 0.00% 0 Critical Bkgnd
    32 432596 63787 6781 0.00% 0.06% 0.07% 0 Net Background
    33 3404 10578 321 0.00% 0.00% 0.00% 0 Logger
    34 87840 260022 337 0.00% 0.00% 0.00% 0 TTY Background
    35 42540 260083 163 0.00% 0.00% 0.00% 0 Per-Second Jobs
    36 14300 26093 548 0.00% 0.00% 0.00% 0 Net Input
    37 412232 52100 7912 0.16% 0.12% 0.10% 0 Compute load avg
    38 542272 4343 124861 0.00% 0.16% 0.16% 0 Per-minute Jobs
    39 4844 18431 262 0.00% 0.00% 0.00% 0 IP NAT Ager
    40 7632 2134 3576 0.00% 0.00% 0.00% 0 AAA Accounting
    41 4 2 2000 0.00% 0.00% 0.00% 0 CCP manager
    42 39760 12853 3093 0.00% 0.00% 0.00% 0 PPP manager
    43 24060 260341 92 0.00% 0.00% 0.00% 0 Multilink PPP
    44 4 2 2000 0.00% 0.00% 0.00% 0 Multilink PPP
    45 4 2 2000 0.00% 0.00% 0.00% 0 Multilink event
    46 0 1 0 0.00% 0.00% 0.00% 0 SNMP Timers
    47 632 29 21793 0.00% 0.00% 0.00% 0 IP SNMP
    48 0 1 0 0.00% 0.00% 0.00% 0 SNMP Traps
    49 11844 6356 1863 0.00% 0.00% 0.00% 0 RADIUS

    به نظر شما براي 4 يوزر فعال پروسس بالا نيست ؟


    m.dehghan



    ویرایش توسط nowpa : 2005-01-24 در ساعت 10:10 AM

  4. #4


    عضو غیر فعال شناسه تصویری NetMaster
    تاریخ عضویت
    Jun 2004
    نوشته
    376
    سپاسگزاری شده
    5
    سپاسگزاری کرده
    0
    You need to try the natting on another box.

    This router is old, and thus always have its CPU high, it is effected mostly by traffic size, access-list and other services.
    we tested 2503 with only routing a 128Kbps, the CPU was over 12%

    I am sure if you use a linux box only for nat or windows, you will have the cpu usage lowered, though it is not so dangerous if you have the CPU usage below 70%, that is acceptable by Cisco.

    Good Luck



  5. #5


    عضو غیر فعال
    تاریخ عضویت
    Feb 2005
    نوشته
    8
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    0
    خسته نباشی .تنظیمات درسته ولی دوستمون راست میگه اکسس لیستات زیاد بودن ولی این هم میتونه دلیل اصلیش نت باشه که بار روترتو زیاد کرده در ضمن از کش هم که خبری نیست یا من ندیدم؟؟!!! روترتون احتمالا مشکل رم هم

    داشته باشه البته اینجور مواقع باید از نزدیک مشکلو حل کرد موفق باشی!!!

    ضیا سجادی




  6. #6
    نام حقيقي: Reza ARYAGOHAR

    مدیر بازنشسته شناسه تصویری aryagohar
    تاریخ عضویت
    Jul 2003
    محل سکونت
    Sydney ,Australia
    نوشته
    3,056
    سپاسگزاری شده
    942
    سپاسگزاری کرده
    215
    نقل قول نوشته اصلی توسط zia-sh
    خسته نباشی .تنظیمات درسته ولی دوستمون راست میگه اکسس لیستات زیاد بودن ولی این هم میتونه دلیل اصلیش نت باشه که بار روترتو زیاد کرده در ضمن از کش هم که خبری نیست یا من ندیدم؟؟!!! روترتون احتمالا مشکل رم هم

    داشته باشه البته اینجور مواقع باید از نزدیک مشکلو حل کرد موفق باشی!!!

    ضیا سجادی
    به جمع ما خوش اومدي آقاي سجادي. انشالله بتونيم از دانش تون بهره كافي و وافي رو بريم.

    موفق و مويد باشيد.







  7. #7


    عضو غیر فعال
    تاریخ عضویت
    Feb 2005
    نوشته
    8
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    0
    سلام آریا گوهر جان ! 2-3 سال پیش وقتی تازه یه چیزایی در مورد روتر ها و کش سرور یاد گرفته بودم فک می کردم که خیلی زیاد بلدم!! ولی حالا بعد از این همه مطالعه و جستجو می بینم که هیچی بلد نیستم الان اومدم اینجا که بتونیم با هم کلی به اطلاعاتمون اضافه کنیم
    موفق وموید باشید
    ضیا سجادی




  8. #8


    عضو غیر فعال شناسه تصویری sdsl
    تاریخ عضویت
    Jan 2003
    محل سکونت
    Iran-Tehran
    نوشته
    630
    سپاسگزاری شده
    22
    سپاسگزاری کرده
    0
    چند تا نكته..

    1- اين پيكر بندي اضافات زياد داره.

    2- اگر IOS مربوطه و نسخه بالتر به اين روتر رو داريد و روتر قابليت Upgrade داره حتما اين كار رو بكنيد.

    3- از دستور ip cef در Config Mode استفاده كنيد. البته تست كنيد اگر قبول كرد CPU روتر رو تا 30 درصد مياره پايين.

    براي تنظيمات هم حتما براتون پاكسازي شده اون رو همين جا مي نويسم.

    موفق باشيد



  9. #9


    عضو غیر فعال
    تاریخ عضویت
    Jun 2004
    نوشته
    47
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    0
    نقل قول نوشته اصلی توسط sdsl
    چند تا نكته..

    1- اين پيكر بندي اضافات زياد داره.

    2- اگر IOS مربوطه و نسخه بالتر به اين روتر رو داريد و روتر قابليت Upgrade داره حتما اين كار رو بكنيد.

    3- از دستور ip cef در Config Mode استفاده كنيد. البته تست كنيد اگر قبول كرد CPU روتر رو تا 30 درصد مياره پايين.

    براي تنظيمات هم حتما براتون پاكسازي شده اون رو همين جا مي نويسم.

    موفق باشيد
    با سلام و تشكر از همه دوستان
    من نمي دونم اضافات اين پيكربندي كجاست؟
    در ضمن دستور فوق رو در روتر تست زدم جواب نداد

    m.dehghan



  10. #10


    عضو غیر فعال
    تاریخ عضویت
    Dec 2004
    محل سکونت
    marivan
    نوشته
    46
    سپاسگزاری شده
    1
    سپاسگزاری کرده
    0

    چه جوري ميشه cpu usage رو مشاهده كرد؟

    salam
    misheh be man begid cpu usage ro chejoor mishe did?



  11. #11
    نام حقيقي: محمد راستی

    مدیر عمومی شناسه تصویری M-r-r
    تاریخ عضویت
    Feb 2004
    محل سکونت
    تهران
    نوشته
    9,380
    سپاسگزاری شده
    4247
    سپاسگزاری کرده
    2673
    اگعه روي ويندوز هاي ايكس پي يا دوهزار به بعد دكمه هاي Ctrl+Alt+delete رو بزني در ويندوز ايكس پي و در ويندوز دوهزار بعد از اون كليد ها و انتخاب تسك منيجر ميتوني درصد استفاده از سي پي يو رو ببيني .


    There's no place like 127.0.0.1
    m.rasti [@] outlook.com

  12. #12
    نام حقيقي: محمد حکیمی

    Administrator شناسه تصویری Hakimi
    تاریخ عضویت
    Dec 2002
    محل سکونت
    تهران
    نوشته
    6,540
    سپاسگزاری شده
    6756
    سپاسگزاری کرده
    1029
    نوشته های وبلاگ
    4
    البته منظور ميديا CPU Usage بر روی Cisco بود.
    نرم افزار Solarwinds یک Tools برای این کار دارد.


    محمد حکیمی
    hakimi [a t] gmail.com





  13. #13


    عضو غیر فعال
    تاریخ عضویت
    Feb 2004
    نوشته
    60
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    0

    توضيحات در رابطه با دستور IP CEF

    نقل قول نوشته اصلی توسط sdsl
    چند تا نكته..

    1- اين پيكر بندي اضافات زياد داره.

    2- اگر IOS مربوطه و نسخه بالتر به اين روتر رو داريد و روتر قابليت Upgrade داره حتما اين كار رو بكنيد.

    3- از دستور ip cef در Config Mode استفاده كنيد. البته تست كنيد اگر قبول كرد CPU روتر رو تا 30 درصد مياره پايين.

    براي تنظيمات هم حتما براتون پاكسازي شده اون رو همين جا مي نويسم.

    موفق باشيد



    اگه ميشه لطف مي کنيد بگين اين دستور دقيقا چيکار مي کنه؟ البته من فکر مي کنم اين دستور موقعي استفاده مي شه که شما از اينترفيس هاي زيادي استفاده دمي کنيد تا عمل لود بالانسينگ انجام بشه...

    با تشکر...



کلمات کلیدی در جستجوها:

NTTAC اضافات

چگون بار

ppp pottocol ccp not configured nttac

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •