نمایش نتایج: از شماره 1 تا 6 از مجموع 6

موضوع: TACACS+ OR Radius

  
  1. #1
    نام حقيقي: محمد حکیمی

    Administrator شناسه تصویری Hakimi
    تاریخ عضویت
    Dec 2002
    محل سکونت
    تهران
    نوشته
    6,547
    سپاسگزاری شده
    6795
    سپاسگزاری کرده
    1034
    نوشته های وبلاگ
    4

    TACACS+ OR Radius

    پرسش:
    من امروز access-server مون رو Upgrade کردم به IOS 13.1، ولي يه مشكل كوچک داره. Accounting Packet رو برای سرور نمي فرسته. ولي بقيه اش كار مي كنه. چي فكر مي كني.
    تنظيمات قبلي با IOS 12.2-8 T داشت كار مي كرد. ديدم دوستان از 13.1 دارن حرف ميزنن. update كردم. حالا همونها كار را مي كنه يعني اعتبار سنجي Authentication و Authorization رو روي خطوط dialup انجام ميده Log هم مي كنه ولي accounting رو start نمي كنه . فقط روي Async ها . از روي TTY و Network مشكل نداره هم Log مي كنه هم روي Console نمايش مي ده . راستي نرم افزار NTTac Plus هستش. اگه تا حالا به اين مشكل برخوردي به من بگو. حدس مي زنم اين ورژن با Tacacs مشكل داشته باشه. چون من با اين پروتكل كار مي كنم.

    پاسخ:
    ببين طبق تجربه هايي كه ما (من و كوروش) بدست آورديم اكثرا ما با پروتكل Tacacs+ به مشکل بر میخوردیم یعنی حتی وقتی که با 12.2 کار میکردیم، اما وقتی Switch کردیم رو Radius کاملا اون مشکلاتمون بر طرف شد. حالا تو هم همین کار رو بکن که مطمئن شی از Tacacs ه این مشکلت. اگر حل نشد باید بریم پارامترهای دیگرو چک کنیم

    پرسش:
    اگه شما لطف كنيد من و كمك كنيد روي Radius سوييچ كنم ممنون مي شم.
    نظرتون چيه
    AAA Authentication login default local group Radius
    aaa authentication ppp login default local group radius
    aaa accounting nested
    aaa accounting update newinfo
    aaa accounting exec default start-stop group radius
    aaa accounting network default start-stop group radius

    interface group-async

    ppp Authenticaton pap chap

    radius-server host A.B.C.D auth port=1645 acct port=1646 timeout 30 key XXX
    radius-server retarnsmit 5

    پاسخ:
    ببين دستوراتت تقريبا درسته اما با اينكار تو Authentication خود Router رو هم سپردی به دست Radius سرورت که از نظر من کار درستی نیست.
    من این Command ها رو بهت پیشنهاد میکنم:
    aaa authentication login no-rad line
    aaa authentication ppp default group radius local
    aaa authorization network default group radius
    aaa accounting update newinfo
    aaa accounting network default start-stop group radius
    aaa session-id common

    ------
    line con 0
    login authentication no-rad
    ------
    line vty 0 4
    login authentication no-rad


    Radius سرورت رو هم که درست معرفی کردی بهر حال این پیشنهاد منه، موفق باشی
    در ضمن یادم رفت بگم که معمولا radius-server retransmit 3 قرار میدن که مقدار Default هستش، حالا شما 5 هم قرار دادی موردی نداره اما اگر دلیل خاصی نداره همون 3 بذاری فکر کنم بهتر باشه

    پرسش:
    نمي دونم چي شده ولي هنوزم يوزري accounting شروع نمي شه . فقط authentication چك ميشه و بس
    اينم تنظيمات من ببخشيد كه مجبورم فقط IP Address رو حذف كنم.

    hostname Router
    !
    boot startup-test power-on
    enable secret 5 $1$gKuP$o1jYou.rmrrrj0KkyKjAs1
    !
    username 123 password 7 03550958
    username modir privilege 15 password 7 035D0A58535B701C19594A
    username system privilege 15 password 7 154B5A5F517E7A747F6366
    !
    !
    resource-pool disable
    spe default-firmware spe-firmware-1
    aaa new-model
    !
    !
    aaa authentication login no-rad line
    aaa authentication ppp default group radius local
    aaa authorization network default group radius
    aaa accounting nested
    aaa accounting update newinfo
    aaa accounting network dafault start-stop group tacacs+
    aaa session-id common
    ip subnet-zero
    ip rcmd rsh-enable
    ip rcmd remote-host system 192.168.1.2 system enable
    ip cef
    ip name-server 195.146.32.1
    ip name-server 195.146.32.65
    !
    !
    !
    !
    !
    !
    !
    !
    !
    no voice hpi capture buffer
    no voice hpi capture destination
    !
    !
    !
    fax interface-type fax-mail
    !
    !
    !
    controller E1 2/0
    framing NO-CRC4
    line-termination 75-ohm
    ds0-group 1 timeslots 1-15,17-31 type r2-digital
    cas-custom 1
    !
    controller E1 2/1
    framing NO-CRC4
    ds0-group 1 timeslots 1-15,17-31 type r2-digital
    cas-custom 1
    !
    !
    interface FastEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/0
    ip address 217.219.xx.xx 255.255.255.128
    ip nat outside
    !
    interface Serial0/1
    no ip address
    shutdown
    clockrate 2000000
    !
    interface Group-Async1
    ip unnumbered FastEthernet0/0
    ip nat inside
    encapsulation ppp
    ip tcp header-compression
    no ip mroute-cache
    async mode interactive
    peer default ip address pool dial
    no keepalive
    ppp authentication pap chap
    group-range 1/00 1/59
    !
    ip local pool dial 192.168.1.101 192.168.1.160
    ip nat inside source list 7 interface Serial0/0 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0/0
    no ip http server
    !
    !
    access-list 7 permit 192.168.1.0 0.0.0.255
    !
    snmp-server community public RW 15
    snmp-server enable traps tty
    !
    radius-server host 192.168.1.2 auth-port 1645 acct-port 1646
    radius-server key 7 0209174F0A08
    radius-server authorization permit missing Service-Type
    !
    voice-port 2/0:1
    compand-type a-law
    !
    voice-port 2/1:1
    compand-type a-law
    !
    !
    dial-peer cor custom
    !
    !
    !
    !
    !
    line con 0
    login authentication no-rad
    line aux 0
    line vty 0 4
    password 7 04490A0F01
    login authentication no-rad
    line 1/00 1/59
    no flush-at-activation
    no modem callout
    modem Dialin
    modem autoconfigure discovery
    autocommand ppp
    transport input all
    autoselect during-login
    autoselect ppp
    !
    scheduler allocate 10000 400
    !
    end

    پاسخ:
    آقا اين دستور رو بردار ببين درست ميشه يا نه؟
    aaa accounting nested

    پرسش:
    مرسي مشكلم حل شد. ولي فكر كنم شانسي حل شد. نمي دونم كجا رو دستكاري كردم
    چون حالا مي خوام يه دونه ديگه رو ست كنم رو Radius همون مشكل رو دارم
    راستي امشب يعني فردا يه 8-9 ساعتي اينترنت بي اينترنت Downtime كلي هستش
    دوستان اين Radius اينجوريه
    هرچي Group مي سازي بايد يه جوري بچسپونيش به ppp خود nttac و الا مثل اينكه با اونا نمي خواد سر سازگاري داشته باشه. Tacacs در اين مورد يه خورده با گذشت تر بود تا Radius. شما هم اين مشكل رو داشتين
    من حالا log رو براتون ميفرستم. راستي ميشه بگين آيا با Radius هم مشكلي مثل موندن كاربر ها روي سرور Nttac بوجود مياد يا نه. قبلاَ ما روي access server كه nat مي كرديم با tacacs نصف بيشتر user ها رو سرور مي موندن و Disconnect نمي شدن .



    موضوعات مشابه:

  2. #2
    نام حقيقي: Reza ARYAGOHAR

    مدیر بازنشسته شناسه تصویری aryagohar
    تاریخ عضویت
    Jul 2003
    محل سکونت
    Sydney ,Australia
    نوشته
    3,056
    سپاسگزاری شده
    943
    سپاسگزاری کرده
    215
    كوروش جون اين رو از كجا كشيدي بيرون.
    دمت گرم . فكر كردم ديگه گم شده. آره خيلي بدرد مي خوره



  3. #3


    عضو غیر فعال
    تاریخ عضویت
    Feb 2005
    نوشته
    8
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    0
    سلام می شه بگید مشکلتون چطوری حل شد؟؟؟ منم چنین مشکلی دارم



  4. #4


    عضو غیر فعال
    تاریخ عضویت
    Jul 2006
    نوشته
    119
    سپاسگزاری شده
    2
    سپاسگزاری کرده
    0
    ببخشید من نمیتونم از کانفیگی که بالاتر آقای کوروش گفته بودند استفاده کنم
    بخش AAA و بخش Radius
    چطور میتونم مشکل رو حل کنم ؟



  5. #5


    عضو عادی شناسه تصویری vahsha1
    تاریخ عضویت
    Oct 2005
    نوشته
    916
    سپاسگزاری شده
    208
    سپاسگزاری کرده
    83

    با سلام

    نقل قول نوشته اصلی توسط ناصریان
    ببخشید من نمیتونم از کانفیگی که بالاتر آقای کوروش گفته بودند استفاده کنم
    بخش AAA و بخش Radius
    چطور میتونم مشکل رو حل کنم ؟
    aaa new-model رو بزنيد فکر کنم مشکل حل بشه.


    ویرایش توسط aryagohar : 2006-08-24 در ساعت 10:40 AM

  6. #6


    عضو غیر فعال
    تاریخ عضویت
    Jul 2006
    نوشته
    119
    سپاسگزاری شده
    2
    سپاسگزاری کرده
    0
    ممنونم عزیز . منتها بدون aaa new-model که امکان تعریف سرور (هاست) برای اکانتینگ و همچنین دستورات aaa نیست !
    من چک کردم این دستور اولین دستور aaa ها هست.



کلمات کلیدی در جستجوها:

چگونهtacacstانجام

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •