نمایش نتایج: از شماره 1 تا 13 از مجموع 13
سپاس ها 2سپاس
  • 1 توسط yasharf
  • 1 توسط greatcyrus

موضوع: مشکل در vlan

  
  1. #1
    نام حقيقي: cisco

    عضو عادی
    تاریخ عضویت
    Jul 2010
    محل سکونت
    TBZ
    نوشته
    81
    سپاسگزاری شده
    24
    سپاسگزاری کرده
    8

    مشکل در vlan

    با سلام سناریوییی به شکل زیر دارم . vlan های 10 و 20 همدیگرو میبینند اما 40 و 50 و 60 ( هر سه در یک رنج ) همدیگرو نمیبینند
    پورت سوئیج ها ترانک شده. آدرس gateway ها درسته .



    موضوعات مشابه:





  2. #2
    نام حقيقي: رضا دانشمند (Dj Pashmak)

    عضو ویژه/سرپرست بخش Cisco شناسه تصویری Reza.D
    تاریخ عضویت
    Oct 2007
    محل سکونت
    .
    نوشته
    941
    سپاسگزاری شده
    876
    سپاسگزاری کرده
    866
    VLAN های 10 و 20 چطور هم رو میبینند؟

    کانفیگ رو بزارین اینجا تا بررسی کنیم


    The great pleasure in life is doing what people say you cannot do

  3. #3
    نام حقيقي: علی شفائی

    عضو عادی شناسه تصویری alisc
    تاریخ عضویت
    Sep 2010
    محل سکونت
    شهریار
    نوشته
    1,871
    سپاسگزاری شده
    1702
    سپاسگزاری کرده
    2037
    نقل قول نوشته اصلی توسط yasharf نمایش پست ها
    با سلام سناریوییی به شکل زیر دارم . vlan های 10 و 20 همدیگرو میبینند اما 40 و 50 و 60 ( هر سه در یک رنج ) همدیگرو نمیبینند
    پورت سوئیج ها ترانک شده. آدرس gateway ها درسته .
    دوست عزیز ماهیت Vlan این هست که Broadcast Domain ها رو از هم جدا میکنه !
    اصلا هیچ کدوم از Vlan ها نباید همدیگرو ببینند !!! حتی Vlan هایی که در اون ها PC ها در یک رنج هستن !

    فقط در یک صورت میشه کاری کرد که Vlan ها به هم Ping داشته باشن ، یک روتر بزارید و روی اون Router On Stick یا همون Inter Vlan Routing ران کنید !




    VLAN چيست ؟
    Virtual Local Area Networks) VLAN) ، يکی از جديدترين و جالبترين تکنولوژی های شبکه است که اخيرا" مورد توجه بيشتری قرار گرفته است . رشد بدون وقفه شبکه های LAN و ضرورت کاهش هزينه ها برای تجهيزات گرانقيمت بدون از دست دادن کارآئی و امنيت ، اهميت و ضرورت توجه بيشتر به VLAN را مضاعف نموده است .

    وضعيت شبکه های فعلی
    تقريبا" در اکثر شبکه ها امروزی از يک (و يا چندين) سوئيچ که تمامی گره های شبکه به آن متصل می گردند ، استفاه می شود . سوئيچ ها روشی مطمئن و سريع به منظور مبادله اطلاعات بين گره ها در يک شبکه را فراهم می نمايند.با اين که سوئيچ ها برای انواع شبکه ها ، گزينه ای مناسب می باشند ، ولی همزمان با رشد شبکه و افزايش تعداد ايستگاهها و سرويس دهندگان ، شاهد بروز مسائل خاصی خواهيم بود . سوئيچ ها ، دستگاه های لايه دوم (مدل مرجع OSI ) می باشند که يک شبکه Flat را ايجاد می نمايند .

    همانگونه که در شکل فوق مشاهده می نمائيد ، به يک سوئيچ ، سه ايستگاه متصل شده است . ايستگاههای فوق قادر به ارتباط با يکديگر بوده و هر يک به عنوان عضوی از يک Broadcast domain مشابه می باشند. بدين ترتيب ، در صورتی که ايستگاهی يک پيام broadcast را ارسال نمايد ، ساير ايستگاههای متصل شده به سوئيچ نيز آن را دريافت خواهند داشت.
    در يک شبکه کوچک ، وجود پيام های Broadcast نمی تواند مشکل و يا مسئله قابل توجهی را ايجاد نمايد، ولی در صورت رشد شبکه ، وجود پيام های braodcast می تواند به يک مشکل اساسی و مهم تبديل گردد . در چنين مواردی و در اغلب مواقع ، سيلابی از اطلاعات بی ارزش بر روی شبکه در حال جابجائی بوده و عملا" از پهنای باند شبکه،استفاده مطلوب نخواهد شد. تمامی ايستگاههای متصل شده به يک سوئيچ ، پيام های Braodcast را دريافت می نمايند . چراکه تمامی آنان بخشی از يک Broadcast doamin مشابه می باشند .
    در صورت افزايش تعداد سوئيچ ها و ايستگاهها در يک شبکه ، مشکل اشاره شده ملموس تر خواهد بود .همواره احتمال وجود پيام های Braodcast در يک شبکه وجود خواهد داشت .
    يکی ديگر از مسائل مهم ، موضوع امنيت است . در شبکه هائی که با استفاده از سوئيچ ايجاد می گردند ، هر يک از کاربران شبکه قادر به مشاهده تمامی دستگاههای موجود در شبکه خواهند بود . در شبکه ای بزرگ که دارای سرويس دهندگان فايل ، بانک های اطلاعاتی و ساير اطلاعات حساس و حياتی است ، اين موضوع می تواند امکان مشاهده تمامی دستگاههای موجود در شبکه را برای هر شخص فراهم نمايد . بدين ترتيب منابع فوق در معرض تهديد و حملات بيشتری قرار خواهند گرفت . به منظور حفاظت اينچنين سيستم هائی می بايست محدوديت دستيابی را در سطح شبکه و با ايجاد سگمنت های متعدد و يا استقرار يک فايروال در جلوی هر يک از سيستم های حياتی ، انجام داد .

    معرفی VLAN
    تمامی مسائل اشاره شده در بخش قبل را و تعداد بيشتری را که به آنان اشاره نشده است را می توان با ايجاد يک VLAN به فراموشی سپرد . به منظور ايجاد VLAN ، به يک سوئيچ لايه دوم که اين تکنولوژی را حمايت نمايد ، نياز می باشد . تعدادی زيادی از افراديکه جديدا" با دنيای شبکه آشنا شده اند ، اغلب دارای برداشت مناسبی در اين خصوص نمی باشند و اينگونه استنباط نموده اند که صرفا" می بايست به منظور فعال نمودن VLAN ، يک نرم افزار اضافه را بر روی سرويس گيرندگان و يا سوئيچ نصب نمايند . ( برداشتی کاملا" اشتباه ! ) . با توجه به اين که در شبکه های VLAN ، ميليون ها محاسبات رياضی انجام می شود ، می بايست از سخت افزار خاصی که درون سوئيچ تعبيه شده است ، استفاده گردد (دقت در زمان تهيه يک سوئيچ)،در غير اينصورت امکان ايجاد يک VLAN با استفاده از سوئيچ تهيه شده ، وجود نخواهد داشت .
    هر VLAN که بر روی سوئيچ ايجاد می گردد ، به منزله يک شبکه مجزا می باشد . بدين ترتيب برای هر VLAN موجود يک broadcast domain جداگانه ايجاد می گردد . پيام های broadcast ، به صورت پيش فرض ، از روی تمامی پورت هائی از شبکه که عضوی از يک VLAN مشابه نمی باشند، فيلتر می گردند . ويژگی فوق ، يکی از مهمترين دلايل متداول شدن VALN در شبکه های بزرگ امروزی است ( تمايز بين سگمنت های شبکه ) . شکل زير يک نمونه شبکه با دو VLAN را نشان می دهد :

    در شکل فوق ، يک شبکه کوچک با شش ايستگاه را که به يک سوئيچ ( با قابليت حمايت از VLAN ) متصل شده اند ، مشاهده می نمائيم . با استفاده از پتانسيل VLAN سوئيچ ، دو VLAN ايجاد شده است که به هر يک سه ايستگاه متصل شده است (VLAN1 و VLAN2) . زمانی که ايستگاه شماره يک متعلق به VLAN1 ، يک پيام Braodcast را ارسال می نمايد ( نظير : FF:FF:FF:FF:FF:FF ) ، سوئيچ موجود آن را صرفا" برای ايستگاههای شماره دو وسه فوروارد می نمايد . در چنين مواردی ساير ايستگاههای متعلق به VLAN2 ، آگاهی لازم در خصوص پيام های broadcast ارسالی بر روی VLAN1 را پيدا نکرده و درگير اين موضوع نخواهند شد .
    در حقيقت ، سوئيچی که قادر به حمايت از VLAN می باشد ، امکان پياده سازی چندين شبکه مجزا را فراهم می نمايد ( مشابه داشتن دو سوئيچ جداگانه و اتصال سه ايستگاه به هر يک از آنان در مقابل استفاده از VLAN ) . بدين ترتيب شاهد کاهش چشمگير هزينه های برپاسازی يک شبکه خواهيم بود .
    فرض کنيد قصد داشته باشيم زير ساخت شبکه موجود در يک سازمان بزرگ را به دوازده شبکه جداگانه تقسيم نمائيم . بدين منظور می توان با تهيه دوازده سوئيچ و اتصال ايستگاههای مورد نظر به هر يک از آنان ، دوازده شبکه مجزا که امکان ارتباط بين آنان وجود ندارد را ايجاد نمائيم . يکی ديگر از روش های تامين خواسته فوق ، استفاده از VLAN است . بدين منظور می توان از يک و يا چندين سوئيچ که VLAN را حمايت می نمايند ، استفاده و دوازده VLAN را ايجاد نمود . بديهی است ، هزينه برپاسازی چنين شبکه هایی به مراتب کمتر از حالتی است که از دوازده سوئيچ جداگانه ، استفاده شده باشد .
    در زمان ايجاد VALN ، می بايست تمامی ايستگاهها را به سوئيچ متصل و در ادامه ، ايستگاههای مرتبط با هر VLAN را مشخص نمود. هر سوئيچ در صورت حمايت از VLAN ، قادر به پشتيبانی از تعداد مشخصی VLAN است . مثلا" يک سوئيچ ممکن است 64 و يا 266 VLAN را حمايت نمايد.



    منبع : آشنائی با VLAN




  4. #4
    نام حقيقي: cisco

    عضو عادی
    تاریخ عضویت
    Jul 2010
    محل سکونت
    TBZ
    نوشته
    81
    سپاسگزاری شده
    24
    سپاسگزاری کرده
    8
    جناب آقای شفایی متوجه منظور شما هستم. هر کردوم از این سوئیچ ها ماله یه ساختمون و هر کدوم از vlan ها واسه یه مدیریت هست. اینکه میفرمایید نمیشه دید درسته. اما وقتی هم رنج باشن و بین سوئیچ ها trunk کنیم میشه دید. بحث روتر یا سوئیچ لایه سه هم زمانی هست که بخواهیم همه رنج ها یا همه vlan ها همدیگرو ببینند و یا access list بنویسیم customize کنیم.
    اما سناریوی ما. ما اینو شبیه سازی کردیم . وقتی بجای vlan های 40 و 50 و 60 اسمشون 30 بود همه چی درست بود اما وقتی اسم vlan ها عوض شد دیگه ping نکردن.
    اما کانفیگ
    سوئیچ 1

    switchport access vlan 40
    !
    interface FastEthernet0/2
    switchport access vlan 20
    !
    interface FastEthernet0/3
    switchport mode trunk
    !
    interface FastEthernet0/4
    switchport access vlan 10

    no ip address
    shutdown
    !
    interface Vlan10
    ip address 10.0.0.1 255.0.0.0
    !
    interface Vlan20
    ip address 11.0.0.1 255.0.0.0
    !
    interface Vlan30
    no ip address
    !
    interface Vlan40
    ip address 12.0.0.3 255.0.0.0

    سوئیچ وسطی
    interface FastEthernet0/1
    switchport access vlan 20
    !
    interface FastEthernet0/2
    switchport access vlan 10
    !
    interface FastEthernet0/3
    switchport mode trunk
    !
    interface FastEthernet0/4
    switchport mode trunk
    !
    interface FastEthernet0/5
    switchport access vlan 50
    interface Vlan1
    no ip address
    shutdown
    !
    interface Vlan10
    ip address 10.0.0.1 255.0.0.0
    !
    interface Vlan20
    ip address 11.0.0.1 255.0.0.0
    !
    interface Vlan30
    no ip address
    !
    interface Vlan50
    ip address 12.0.0.2 255.0.0.0

    سوئیچ بالایی

    interface FastEthernet0/1
    switchport access vlan 20
    !
    interface FastEthernet0/2
    switchport access vlan 10
    !
    interface FastEthernet0/3
    switchport mode trunk
    !
    interface FastEthernet0/4
    switchport access vlan 60

    interface Vlan10
    ip address 10.0.0.1 255.0.0.0
    !
    interface Vlan20
    ip address 11.0.0.1 255.0.0.0
    !
    interface Vlan30
    no ip address
    !
    interface Vlan60
    ip address 12.0.0.1 255.0.0.0



  5. #5
    نام حقيقي: علی شفائی

    عضو عادی شناسه تصویری alisc
    تاریخ عضویت
    Sep 2010
    محل سکونت
    شهریار
    نوشته
    1,871
    سپاسگزاری شده
    1702
    سپاسگزاری کرده
    2037
    نقل قول نوشته اصلی توسط yasharf نمایش پست ها
    اینکه میفرمایید نمیشه دید درسته. اما وقتی هم رنج باشن و بین سوئیچ ها trunk کنیم میشه دید
    باز هم نمیشه دید
    در پکت تریسر تست کنید متوجه میشید !

    Vlan 10 و Vlan 20 حتی اگر کلاینت ها در یک رنج هم باشن ، به یکدیگر Ping ندارن !



  6. #6
    نام حقيقي: علیرضاباقری

    عضو عادی
    تاریخ عضویت
    Sep 2009
    محل سکونت
    تهران
    نوشته
    180
    سپاسگزاری شده
    82
    سپاسگزاری کرده
    59
    ببین دوست عزیز مشخصه وقتی شما اسم vlan ها رو شبیه به هم کنید با هم ارتباط دارند برای ارتباط vlanهای دیگه باید به گفته آقای شفائی عمل کنید







  7. #7
    نام حقيقي: cisco

    عضو عادی
    تاریخ عضویت
    Jul 2010
    محل سکونت
    TBZ
    نوشته
    81
    سپاسگزاری شده
    24
    سپاسگزاری کرده
    8
    پس نتیجه اینکه برای مشاهده vlan های هم رنج باید همدیگرو ببینند باید در همه موارد هم نام باشند



  8. #8
    نام حقيقي: علی شفائی

    عضو عادی شناسه تصویری alisc
    تاریخ عضویت
    Sep 2010
    محل سکونت
    شهریار
    نوشته
    1,871
    سپاسگزاری شده
    1702
    سپاسگزاری کرده
    2037
    نقل قول نوشته اصلی توسط yasharf نمایش پست ها
    پس نتیجه اینکه برای مشاهده vlan های هم رنج باید همدیگرو ببینند باید در همه موارد هم نام باشند
    فقط vlan های هم شماره میتونن همدیگرو ببینن !

    مثلا شما 20 تا سوئیچ هم که داشته باشین ، روی این 20 تا سوئیچ Vlan 100 رو بزنید ، همه سیستم هایی که عضو Vlan 100 هستن میتونن همدیگرو ببینن !

    یک پیشنهاد :
    همیشه هنگام ساختن Vlan ، روی سوئیچ ها VTP ران کنید که راحت باشید ! یک بار Vlan رو ایجاد کنید ، روی همه سوئیچ ها Vlan ها ایجاد میشن !



  9. #9
    نام حقيقي: Saeed

    عضو عادی شناسه تصویری greatcyrus
    تاریخ عضویت
    Jan 2010
    محل سکونت
    Tehran
    نوشته
    2,662
    سپاسگزاری شده
    930
    سپاسگزاری کرده
    1248
    نوشته های وبلاگ
    3
    نقل قول نوشته اصلی توسط yasharf نمایش پست ها
    اینکه میفرمایید نمیشه دید درسته. اما وقتی هم رنج باشن و بین سوئیچ ها trunk کنیم میشه دید.
    اون ترانک که گذاشتی بین 2تا سوییچ فقط باعث میشه ترافیک vlan های مختلف عبور کنه ازین سوییچ به اون سوییچ.

    بعد ترافیکی که مثلا تگ vlan10 تو سوییچ1 میره تو سوییچ2 میرسه به vlan10 اون سوییچ ...! و الا ماشالا ....

    پس نتیجه میگیریم ترافیک vlan10 به vlan20 و ... نخواهد رسید مگر اینکه یه لایه بیتی بالاتر و در لایه 3 روت کنی ....

    inter vlan routing



  10. #10
    نام حقيقي: cisco

    عضو عادی
    تاریخ عضویت
    Jul 2010
    محل سکونت
    TBZ
    نوشته
    81
    سپاسگزاری شده
    24
    سپاسگزاری کرده
    8
    تا جایی که من میدونم vtp برای اینه که سوئیچ ها از اطلاعات vlan های همدیگه باخبر بشند نه اینکه اگه تو یکی vlanای ساخته شد اتوماتیک تو اون یکی ها هم ساخته بشه . باز اگه اشتباه میکنم بفرمایید


    sasanmc سپاسگزاری کرده است.

  11. #11
    نام حقيقي: Saeed

    عضو عادی شناسه تصویری greatcyrus
    تاریخ عضویت
    Jan 2010
    محل سکونت
    Tehran
    نوشته
    2,662
    سپاسگزاری شده
    930
    سپاسگزاری کرده
    1248
    نوشته های وبلاگ
    3
    نقل قول نوشته اصلی توسط yasharf نمایش پست ها
    تا جایی که من میدونم vtp برای اینه که سوئیچ ها از اطلاعات vlan های همدیگه باخبر بشند نه اینکه اگه تو یکی vlanای ساخته شد اتوماتیک تو اون یکی ها هم ساخته بشه . باز اگه اشتباه میکنم بفرمایید
    میتونه اتومات ساخته بشه تو سوییچهای دیگه به شرطی که یه سوییچ بشه VTP Server و بقیه بشن VTP Client


    alisc سپاسگزاری کرده است.

  12. #12
    نام حقيقي: علی شفائی

    عضو عادی شناسه تصویری alisc
    تاریخ عضویت
    Sep 2010
    محل سکونت
    شهریار
    نوشته
    1,871
    سپاسگزاری شده
    1702
    سپاسگزاری کرده
    2037
    نقل قول نوشته اصلی توسط yasharf نمایش پست ها
    تا جایی که من میدونم vtp برای اینه که سوئیچ ها از اطلاعات vlan های همدیگه باخبر بشند نه اینکه اگه تو یکی vlanای ساخته شد اتوماتیک تو اون یکی ها هم ساخته بشه . باز اگه اشتباه میکنم بفرمایید
    اگر روی یک سوئیچ دستور vtp mode server و vtp domain ali رو بزنید .
    سپس برید داخل سوئیچ های دیگه هم بزنید vtp mode client و vtp domain ali بزنید .
    اینطوری اگر روی سوئیچی Vlan بسازید ، اون Vlan روی سوئیچ های دیگه هم ساخته میشه !







  13. #13
    نام حقيقي: sasan

    عضو عادی
    تاریخ عضویت
    Aug 2013
    محل سکونت
    tabriz
    نوشته
    24
    سپاسگزاری شده
    18
    سپاسگزاری کرده
    26
    دوست عزیز در vtp وقتی میگین از vlan های هم خبر داشته باشن یعنی بدونن دیگری چه vlan داره و اگر خودش انرا نداشت برای خودش از همان vlan ایجاد می کند که آنهم شرایطی دارد که در صورا تمایل می توانم کامل vtp را توضیح دهم .



کلمات کلیدی در جستجوها:

vtp پکت تریسر

چگونه vlan ها همدیگر را پینگ میکنند؟در پکت تریسر

چگونه دو vlan میتوانند همدیگر را ping کنند؟

کانفيگ سوئيچ trunk پکت تریسر

اموزش درست کردن ترانک در سوییچ در پاکت تریسر

vtp client در پکت تریسر

نحوه نشان دادن vlan در پکیت تریسر

آموزش ترانک بین 2 سوئیچ در پکت تریسر

تصویر ایجاد VLAN در سوئیچ سیسکو در پکت تریسر

ترانک در پکت تریسر

ارتباط بین vlanها در پکت تریسر

دستورات trunk در پکت تریسر

ساخت 2 vlan با قابلیت ارتباط با هم در پکت تریسر

چگونه management v-lan را عوض کنیم

کانفیگ دو سوییچ با یکدیگر

مراحل ایجاد اکسس لیست روی سویچ در پکت تریسر

دستورات valn ها همدیگرو ببینن

ارتباط بین vlan های غیر همنام با intervlan routing

اشتراک vlan ها ی همنام در 2 تا سوئیچ

مشکل در vlan

چگونه دو تا vlan غیر همنام یکدیگر را ping کنند

vlan بندی چگونه است؟

دستور vtp در vlan پکت تریسر

چطور میشه vlan های یه سوئیچ لایه سه رو به هم ارتباط داد

یک سناریو کوچک در inter vlan routing

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •