صفحه 1 از 2 1 2 آخرینآخرین
نمایش نتایج: از شماره 1 تا 15 از مجموع 17

موضوع: مشکل در VTP

  
  1. #1
    نام حقيقي: مصطفی

    عضو عادی شناسه تصویری Mostafa_IT
    تاریخ عضویت
    Jan 2013
    محل سکونت
    مشهد
    نوشته
    71
    سپاسگزاری شده
    42
    سپاسگزاری کرده
    41

    Icon9 مشکل در VTP

    سلام. دوستان من یه مشکلی خوردم توی شناسوندن Vlan هام به سوئیچ ها. الان من میخام این سوئیچ ها دقیقا بتونن بین Vlan هایی که من دارم ارتباط برقرار کنن چون اونطرف شبکه روتر ها هستن و باید ارتباط برقرار شه. اما ارتباط از اینجا مشکل داره. و هرچقدر VTP رو اجرا میکنم مشکل میخورم. حتما یه جای کارم میلنگه. لطفا بفرمایید چطوری VTP رو پیاده سازی کنم تا مشکلم حل شه

    با سپاس








  2. #2
    نام حقيقي: مهدی مرادی

    عضو عادی
    تاریخ عضویت
    Apr 2009
    محل سکونت
    تهران
    نوشته
    81
    سپاسگزاری شده
    46
    سپاسگزاری کرده
    12

    VTP سرور

    نقل قول نوشته اصلی توسط Mostafa_IT نمایش پست ها
    سلام. دوستان من یه مشکلی خوردم توی شناسوندن Vlan هام به سوئیچ ها. الان من میخام این سوئیچ ها دقیقا بتونن بین Vlan هایی که من دارم ارتباط برقرار کنن چون اونطرف شبکه روتر ها هستن و باید ارتباط برقرار شه. اما ارتباط از اینجا مشکل داره. و هرچقدر VTP رو اجرا میکنم مشکل میخورم. حتما یه جای کارم میلنگه. لطفا بفرمایید چطوری VTP رو پیاده سازی کنم تا مشکلم حل شه

    با سپاس
    سلام
    شما اگه میخوای این سناریو رو اجرا کنی باید اول vtpها رو کامل کانفیگ کنید بعد روی سوییچ اصلی که نقش vtp سرور رو داره اون پورتی رو که قراره وصل بشه به روتر رو ترانک تعریف کنید. بعد از اون داخل روتر باید ساب اینترفیس تعریف کنید. بعد تنظیمات روتر رو انجام بدید. بازم مشکلی بود بگید


    Mostafa_IT سپاسگزاری کرده است.
    Microsoft Certified Systems Engineer
    MCSE

  3. #3
    نام حقيقي: مصطفی

    عضو عادی شناسه تصویری Mostafa_IT
    تاریخ عضویت
    Jan 2013
    محل سکونت
    مشهد
    نوشته
    71
    سپاسگزاری شده
    42
    سپاسگزاری کرده
    41
    ارتباط بین سوئیچ ها Trunk گذاشتم. ارتباط بین سوئچی بالا تا سرور access و همینطور سوئیچ های پایین تا کامپیوتر ها هم access.
    روی یکی از سوئچی ها domain رو گذاشتم sony.com و روی بقیه هم خود به خود ست شد.
    این vtp status سوئیچ بالایی:
    Switch#show vtp status
    VTP Version : 2
    Configuration Revision
    : 1
    Maximum VLANs supported locally
    : 255
    Number of existing VLANs
    : 6
    VTP Operating Mode
    : Server
    VTP Domain Name
    : sony.com
    VTP Pruning Mode
    : Disabled
    VTP V2 Mode
    : Disabled
    VTP Traps Generation
    : Disabled
    MD5 digest
    : 0x1D 0x3B 0x38 0x4B 0xD6 0x34 0x4B 0x62
    Configuration last modified by 0.0.0.0 at 3
    -1-93 00:11:23
    Local updater ID is 0.0.0.0
    (no valid interface found)
    رانینگ کانفیگ سوئیچ بالایی:

    Switch#show running-config
    Building configuration...

    Current configuration : 1129 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password
    -encryption
    !
    hostname Switch
    !
    !
    spanning-tree mode pvst
    !
    interface
    FastEthernet0/1
    !
    interface
    FastEthernet0/2
    switchport mode trunk
    !
    interface
    FastEthernet0/3
    switchport mode trunk
    !
    interface
    FastEthernet0/4
    !
    interface
    FastEthernet0/5
    switchport access vlan 5
    switchport mode access
    !
    interface
    FastEthernet0/6
    !
    interface
    FastEthernet0/7
    !
    interface
    FastEthernet0/8
    !
    interface
    FastEthernet0/9
    !
    interface
    FastEthernet0/10
    !
    interface
    FastEthernet0/11
    !
    interface
    FastEthernet0/12
    !
    interface
    FastEthernet0/13
    !
    interface
    FastEthernet0/14
    !
    interface
    FastEthernet0/15
    !
    interface
    FastEthernet0/16
    !
    interface
    FastEthernet0/17
    !
    interface
    FastEthernet0/18
    !
    interface
    FastEthernet0/19
    !
    interface
    FastEthernet0/20
    !
    interface
    FastEthernet0/21
    !
    interface
    FastEthernet0/22
    !
    interface
    FastEthernet0/23
    !
    interface
    FastEthernet0/24
    !
    interface
    GigabitEthernet1/1
    !
    interface
    GigabitEthernet1/2
    !
    interface
    Vlan1
    no ip address
    shutdown
    !
    !
    line con 0
    !
    line vty 0 4
    login
    line vty 5 15
    login
    !
    !
    end
    رانینگ کانفیگ سوئیچ پایینی سمت چپ تصویر:

    S1(config)#do show running-config
    Building configuration...

    Current configuration : 1102 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password
    -encryption
    !
    hostname S1
    !
    !
    spanning-tree mode pvst
    !
    interface
    FastEthernet0/1
    switchport access vlan 3
    switchport mode access
    !
    interface
    FastEthernet0/2
    !
    interface
    FastEthernet0/3
    switchport mode trunk
    !
    interface
    FastEthernet0/4
    !
    interface
    FastEthernet0/5
    !
    interface
    FastEthernet0/6
    !
    interface
    FastEthernet0/7
    !
    interface
    FastEthernet0/8
    !
    interface
    FastEthernet0/9
    !
    interface
    FastEthernet0/10
    !
    interface
    FastEthernet0/11
    !
    interface
    FastEthernet0/12
    !
    interface
    FastEthernet0/13
    !
    interface
    FastEthernet0/14
    !
    interface
    FastEthernet0/15
    !
    interface
    FastEthernet0/16
    !
    interface
    FastEthernet0/17
    !
    interface
    FastEthernet0/18
    !
    interface
    FastEthernet0/19
    !
    interface
    FastEthernet0/20
    !
    interface
    FastEthernet0/21
    !
    interface
    FastEthernet0/22
    !
    interface
    FastEthernet0/23
    !
    interface
    FastEthernet0/24
    !
    interface
    GigabitEthernet1/1
    !
    interface
    GigabitEthernet1/2
    !
    interface
    Vlan1
    no ip address
    shutdown
    !
    !
    line con 0
    !
    line vty 0 4
    login
    line vty 5 15
    login
    !
    !
    end
    رانینگ کانفیگ سوئیچ پایینی سمت راست تصویر:

    Switch#show run
    Building configuration...

    Current configuration : 1106 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password
    -encryption
    !
    hostname Switch
    !
    !
    spanning-tree mode pvst
    !
    interface
    FastEthernet0/1
    switchport access vlan 2
    switchport mode access
    !
    interface
    FastEthernet0/2
    switchport mode trunk
    !
    interface
    FastEthernet0/3
    !
    interface
    FastEthernet0/4
    !
    interface
    FastEthernet0/5
    !
    interface
    FastEthernet0/6
    !
    interface
    FastEthernet0/7
    !
    interface
    FastEthernet0/8
    !
    interface
    FastEthernet0/9
    !
    interface
    FastEthernet0/10
    !
    interface
    FastEthernet0/11
    !
    interface
    FastEthernet0/12
    !
    interface
    FastEthernet0/13
    !
    interface
    FastEthernet0/14
    !
    interface
    FastEthernet0/15
    !
    interface
    FastEthernet0/16
    !
    interface
    FastEthernet0/17
    !
    interface
    FastEthernet0/18
    !
    interface
    FastEthernet0/19
    !
    interface
    FastEthernet0/20
    !
    interface
    FastEthernet0/21
    !
    interface
    FastEthernet0/22
    !
    interface
    FastEthernet0/23
    !
    interface
    FastEthernet0/24
    !
    interface
    GigabitEthernet1/1
    !
    interface
    GigabitEthernet1/2
    !
    interface
    Vlan1
    no ip address
    shutdown
    !
    !
    line con 0
    !
    line vty 0 4
    login
    line vty 5 15
    login
    !
    !
    end
    نکته دیگه اینکه بعد از ست کردن اعمال VTP خب طبیعتا دیگه DHCP به کامپیوتر ها IP نمیده. و اینکه پورت 0/1 سوئیچ پایین سمت چپ نارنجی شد!



  4. #4
    نام حقيقي: مهدی مرادی

    عضو عادی
    تاریخ عضویت
    Apr 2009
    محل سکونت
    تهران
    نوشته
    81
    سپاسگزاری شده
    46
    سپاسگزاری کرده
    12
    بیا این فیال مانفیگ و عکس اون هستش.
    vtp کانفیگ شده
    vlan 10,20,30 کانفیگ شده
    هر vlan جداگانه dhcp داره
    روتینگ هم کانفیگ شده
    VTP.rar
    بازم سوالی بود بپرس


    Mostafa_IT سپاسگزاری کرده است.
    Microsoft Certified Systems Engineer
    MCSE

  5. #5
    نام حقيقي: مصطفی

    عضو عادی شناسه تصویری Mostafa_IT
    تاریخ عضویت
    Jan 2013
    محل سکونت
    مشهد
    نوشته
    71
    سپاسگزاری شده
    42
    سپاسگزاری کرده
    41
    نقل قول نوشته اصلی توسط mehdi-e62 نمایش پست ها
    بیا این فیال مانفیگ و عکس اون هستش.
    vtp کانفیگ شده
    vlan 10,20,30 کانفیگ شده
    هر vlan جداگانه dhcp داره
    روتینگ هم کانفیگ شده
    VTP.rar
    بازم سوالی بود بپرس
    متاسفانه فایل packet tracer شما با ورژن من یکی نیست و جواب نمیده! من ورژن 5.3 استفاده میکنم. فایل شما 6 ئه؟



  6. #6
    نام حقيقي: مهدی مرادی

    عضو عادی
    تاریخ عضویت
    Apr 2009
    محل سکونت
    تهران
    نوشته
    81
    سپاسگزاری شده
    46
    سپاسگزاری کرده
    12
    بله ورژن نرم افزار من 6 هستش


    Microsoft Certified Systems Engineer
    MCSE





  7. #7
    نام حقيقي: Danial

    عضو عادی
    تاریخ عضویت
    Dec 2010
    محل سکونت
    Tehran
    نوشته
    36
    سپاسگزاری شده
    10
    سپاسگزاری کرده
    3
    خروجی دستورات زیر رو بزار لطفا

    show interface trunk برای هر 3 سوئیچ
    show vlan برای هر 3 سوئیچ
    show vtp status برای دو سوئیچ پایین



  8. #8
    نام حقيقي: مصطفی

    عضو عادی شناسه تصویری Mostafa_IT
    تاریخ عضویت
    Jan 2013
    محل سکونت
    مشهد
    نوشته
    71
    سپاسگزاری شده
    42
    سپاسگزاری کرده
    41
    نقل قول نوشته اصلی توسط mehdi-e62 نمایش پست ها
    بله ورژن نرم افزار من 6 هستش
    من دقیقا کارا رو انجام میدم اما آخر show vtp status پیغام زیر هم میاد:
    Local updater ID is 0.0.0.0 (no valid interface found)



  9. #9
    نام حقيقي: مهدی مرادی

    عضو عادی
    تاریخ عضویت
    Apr 2009
    محل سکونت
    تهران
    نوشته
    81
    سپاسگزاری شده
    46
    سپاسگزاری کرده
    12
    SW1:

    Switch#show running-config
    Building configuration...
    Current configuration : 1196 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Switch
    !
    !
    !
    !
    spanning-tree mode pvst
    !
    interface FastEthernet0/1
    switchport mode trunk
    !
    interface FastEthernet0/2
    !
    interface FastEthernet0/3
    !
    interface FastEthernet0/4
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface FastEthernet0/13
    !
    interface FastEthernet0/14
    !
    interface FastEthernet0/15
    !
    interface FastEthernet0/16
    !
    interface FastEthernet0/17
    !
    interface FastEthernet0/18
    !
    interface FastEthernet0/19
    !
    interface FastEthernet0/20
    !
    interface FastEthernet0/21
    !
    interface FastEthernet0/22
    !
    interface FastEthernet0/23
    !
    interface FastEthernet0/24
    !
    interface GigabitEthernet1/1
    !
    interface GigabitEthernet1/2
    !
    interface Vlan1
    no ip address
    shutdown
    !
    interface Vlan10
    no ip address
    !
    interface Vlan20
    no ip address
    !
    interface Vlan30
    no ip address
    !
    interface Vlan40
    no ip address
    !
    !
    line con 0
    !
    line vty 0 4
    login
    line vty 5 15
    login
    !
    !
    end

    - - - Updated - - -

    SW2:

    Switch#show running-config
    Building configuration...
    Current configuration : 1213 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Switch
    !
    !
    !
    !
    spanning-tree mode pvst
    !
    interface FastEthernet0/1
    switchport mode trunk
    !
    interface FastEthernet0/2
    switchport access vlan 10
    switchport mode access
    !
    interface FastEthernet0/3
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/4
    switchport access vlan 30
    switchport mode access
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface FastEthernet0/13
    !
    interface FastEthernet0/14
    !
    interface FastEthernet0/15
    !
    interface FastEthernet0/16
    !
    interface FastEthernet0/17
    !
    interface FastEthernet0/18
    !
    interface FastEthernet0/19
    !
    interface FastEthernet0/20
    !
    interface FastEthernet0/21
    !
    interface FastEthernet0/22
    !
    interface FastEthernet0/23
    !
    interface FastEthernet0/24
    !
    interface GigabitEthernet1/1
    !
    interface GigabitEthernet1/2
    !
    interface Vlan1
    no ip address
    shutdown
    !
    !
    line con 0
    !
    line vty 0 4
    login
    line vty 5 15
    login
    !
    !
    end

    - - - Updated - - -

    Router:

    Router#show running-config
    Building configuration...
    Current configuration : 1079 bytes
    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Router
    !
    !
    !
    !
    !
    ip dhcp pool 10
    network 192.168.10.0 255.255.255.0
    default-router 192.168.10.1
    dns-server 192.168.10.1
    ip dhcp pool 20
    network 192.168.20.0 255.255.255.0
    default-router 192.168.20.1
    dns-server 192.168.20.1
    ip dhcp pool 30
    network 192.168.30.0 255.255.255.0
    default-router 192.168.30.1
    dns-server 192.168.30.1
    !
    !
    !
    !
    !
    !
    !
    !
    !
    spanning-tree mode pvst
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 192.168.10.1 255.255.255.0
    !
    interface FastEthernet0/0.20
    encapsulation dot1Q 20
    ip address 192.168.20.1 255.255.255.0
    !
    interface FastEthernet0/0.30
    encapsulation dot1Q 30
    ip address 192.168.30.1 255.255.255.0
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Vlan1
    no ip address
    shutdown
    !
    ip classless
    !
    !
    !
    !
    !
    !
    !
    line con 0
    !
    line aux 0
    !
    line vty 0 4
    login
    !
    !
    !
    end


    Microsoft Certified Systems Engineer
    MCSE

  10. #10
    نام حقيقي: مصطفی

    عضو عادی شناسه تصویری Mostafa_IT
    تاریخ عضویت
    Jan 2013
    محل سکونت
    مشهد
    نوشته
    71
    سپاسگزاری شده
    42
    سپاسگزاری کرده
    41
    برای سوئیچ پایین سمت چپ تصویر:

    Switch#show interface trunk
    Port Mode Encapsulation Status Native vlan
    Fa0/3 on 802.1q trunking 1

    Port Vlans allowed on trunk
    Fa0/3 1-1005

    Port Vlans allowed and active in management domain
    Fa0/3 1,2,3,5

    Port Vlans in spanning tree forwarding state and not pruned
    Fa0/3 1,2,3,5
    Switch#show vlan

    VLAN Name Status Ports
    ---- -------------------------------- --------- -------------------------------
    1 default active Fa0/2, Fa0/4, Fa0/5, Fa0/6
    Fa0/7, Fa0/8, Fa0/9, Fa0/10
    Fa0/11, Fa0/12, Fa0/13, Fa0/14
    Fa0/15, Fa0/16, Fa0/17, Fa0/18
    Fa0/19, Fa0/20, Fa0/21, Fa0/22
    Fa0/23, Fa0/24, Gig1/1, Gig1/2
    2 VLAN0002 active
    3 VLAN0003 active Fa0/1
    5 VLAN0005 active
    1002 fddi-default act/unsup
    1003 token-ring-default act/unsup
    1004 fddinet-default act/unsup
    1005 trnet-default act/unsup

    VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1 enet 100001 1500 - - - - - 0 0
    2 enet 100002 1500 - - - - - 0 0
    3 enet 100003 1500 - - - - - 0 0
    5 enet 100005 1500 - - - - - 0 0
    1002 fddi 101002 1500 - - - - - 0 0
    1003 tr 101003 1500 - - - - - 0 0
    1004 fdnet 101004 1500 - - - ieee - 0 0
    1005 trnet 101005 1500 - - - ibm - 0 0

    Remote SPAN VLANs
    ------------------------------------------------------------------------------


    Primary Secondary Type Ports
    ------- --------- ----------------- ------------------------------------------
    Switch#show vtp status
    VTP Version : 2
    Configuration Revision : 4
    Maximum VLANs supported locally : 255
    Number of existing VLANs : 8
    VTP Operating Mode : Client
    VTP Domain Name : test.co
    VTP Pruning Mode : Disabled
    VTP V2 Mode : Enabled
    VTP Traps Generation : Disabled
    MD5 digest : 0x97 0x89 0xFE 0x70 0xB8 0xA4 0x32 0x16
    Configuration last modified by 0.0.0.0 at 3-1-93 00:07:14
    برای سوئیچ پایین سمت راست:

    Switch#show interface trunk
    Port Mode Encapsulation Status Native vlan
    Fa0/2 on 802.1q trunking 1

    Port Vlans allowed on trunk
    Fa0/2 1-1005

    Port Vlans allowed and active in management domain
    Fa0/2 1,2,3,5

    Port Vlans in spanning tree forwarding state and not pruned
    Fa0/2 1,2,3,5
    Switch#show vlan

    VLAN Name Status Ports
    ---- -------------------------------- --------- -------------------------------
    1 default active Fa0/3, Fa0/4, Fa0/5, Fa0/6
    Fa0/7, Fa0/8, Fa0/9, Fa0/10
    Fa0/11, Fa0/12, Fa0/13, Fa0/14
    Fa0/15, Fa0/16, Fa0/17, Fa0/18
    Fa0/19, Fa0/20, Fa0/21, Fa0/22
    Fa0/23, Fa0/24, Gig1/1, Gig1/2
    2 VLAN0002 active Fa0/1
    3 VLAN0003 active
    5 VLAN0005 active
    1002 fddi-default act/unsup
    1003 token-ring-default act/unsup
    1004 fddinet-default act/unsup
    1005 trnet-default act/unsup

    VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1 enet 100001 1500 - - - - - 0 0
    2 enet 100002 1500 - - - - - 0 0
    3 enet 100003 1500 - - - - - 0 0
    5 enet 100005 1500 - - - - - 0 0
    1002 fddi 101002 1500 - - - - - 0 0
    1003 tr 101003 1500 - - - - - 0 0
    1004 fdnet 101004 1500 - - - ieee - 0 0
    1005 trnet 101005 1500 - - - ibm - 0 0

    Remote SPAN VLANs
    ------------------------------------------------------------------------------


    Primary Secondary Type Ports
    ------- --------- ----------------- ------------------------------------------
    Switch#show vtp status
    VTP Version : 2
    Configuration Revision : 4
    Maximum VLANs supported locally : 255
    Number of existing VLANs : 8
    VTP Operating Mode : Client
    VTP Domain Name : test.co
    VTP Pruning Mode : Disabled
    VTP V2 Mode : Enabled
    VTP Traps Generation : Disabled
    MD5 digest : 0x97 0x89 0xFE 0x70 0xB8 0xA4 0x32 0x16
    Configuration last modified by 0.0.0.0 at 3-1-93 00:07:14
    برای سویچ بالا:

    Switch#show interface trunk
    Port Mode Encapsulation Status Native vlan
    Fa0/1 on 802.1q trunking 1
    Fa0/2 on 802.1q trunking 1
    Fa0/3 on 802.1q trunking 1

    Port Vlans allowed on trunk
    Fa0/1 1-1005
    Fa0/2 1-1005
    Fa0/3 1-1005

    Port Vlans allowed and active in management domain
    Fa0/1 1,2,3,5
    Fa0/2 1,2,3,5
    Fa0/3 1,2,3,5

    Port Vlans in spanning tree forwarding state and not pruned
    Fa0/1 1,2,3,5
    Fa0/2 1,2,3,5
    Fa0/3 1,2,3,5
    Switch#show vlan

    VLAN Name Status Ports
    ---- -------------------------------- --------- -------------------------------
    1 default active Fa0/4, Fa0/6, Fa0/7, Fa0/8
    Fa0/9, Fa0/10, Fa0/11, Fa0/12
    Fa0/13, Fa0/14, Fa0/15, Fa0/16
    Fa0/17, Fa0/18, Fa0/19, Fa0/20
    Fa0/21, Fa0/22, Fa0/23, Fa0/24
    Gig1/1, Gig1/2
    2 VLAN0002 active
    3 VLAN0003 active
    5 VLAN0005 active Fa0/5
    1002 fddi-default act/unsup
    1003 token-ring-default act/unsup
    1004 fddinet-default act/unsup
    1005 trnet-default act/unsup

    VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1 enet 100001 1500 - - - - - 0 0
    2 enet 100002 1500 - - - - - 0 0
    3 enet 100003 1500 - - - - - 0 0
    5 enet 100005 1500 - - - - - 0 0
    1002 fddi 101002 1500 - - - - - 0 0
    1003 tr 101003 1500 - - - - - 0 0
    1004 fdnet 101004 1500 - - - ieee - 0 0
    1005 trnet 101005 1500 - - - ibm - 0 0

    Remote SPAN VLANs
    ------------------------------------------------------------------------------


    Primary Secondary Type Ports
    ------- --------- ----------------- ------------------------------------------
    Switch#show vtp status
    VTP Version : 2
    Configuration Revision : 4
    Maximum VLANs supported locally : 255
    Number of existing VLANs : 8
    VTP Operating Mode : Server
    VTP Domain Name : test.co
    VTP Pruning Mode : Disabled
    VTP V2 Mode : Enabled
    VTP Traps Generation : Disabled
    MD5 digest : 0x97 0x89 0xFE 0x70 0xB8 0xA4 0x32 0x16
    Configuration last modified by 0.0.0.0 at 3-1-93 00:07:14
    Local updater ID is 0.0.0.0 (no valid interface found)
    من چطور با این وضعیت باید سرور DHCP رو تنظیم کنم که به کامپیوتر هام IP بده و کامپیوتر هام بتونن به راحتی روتر رو پینگ داشته باشند تا بتونن با بقیه شبکه ارتباط برقرار کنن؟؟



  11. #11
    نام حقيقي: مهدی مرادی

    عضو عادی
    تاریخ عضویت
    Apr 2009
    محل سکونت
    تهران
    نوشته
    81
    سپاسگزاری شده
    46
    سپاسگزاری کرده
    12
    SW3:

    Switch#show running-config
    Building configuration...
    Current configuration : 1213 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Switch
    !
    !
    !
    !
    spanning-tree mode pvst
    !
    interface FastEthernet0/1
    switchport mode trunk
    !
    interface FastEthernet0/2
    switchport access vlan 10
    switchport mode access
    !
    interface FastEthernet0/3
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet0/4
    switchport access vlan 30
    switchport mode access
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface FastEthernet0/13
    !
    interface FastEthernet0/14
    !
    interface FastEthernet0/15
    !
    interface FastEthernet0/16
    !
    interface FastEthernet0/17
    !
    interface FastEthernet0/18
    !
    interface FastEthernet0/19
    !
    interface FastEthernet0/20
    !
    interface FastEthernet0/21
    !
    interface FastEthernet0/22
    !
    interface FastEthernet0/23
    !
    interface FastEthernet0/24
    !
    interface GigabitEthernet1/1
    !
    interface GigabitEthernet1/2
    !
    interface Vlan1
    no ip address
    shutdown
    !
    !
    line con 0
    !
    line vty 0 4
    login
    line vty 5 15
    login
    !
    !
    end


    Microsoft Certified Systems Engineer
    MCSE

  12. #12
    نام حقيقي: مصطفی

    عضو عادی شناسه تصویری Mostafa_IT
    تاریخ عضویت
    Jan 2013
    محل سکونت
    مشهد
    نوشته
    71
    سپاسگزاری شده
    42
    سپاسگزاری کرده
    41
    ببینید من نمیخام روتر نقش DHCP رو بازی کنه. من میخام اون DHCP Server یی که گذاشتم بتونه با وجود Vlan بندی به کامپیوتر هام IP بده







  13. #13
    نام حقيقي: مهدی مرادی

    عضو عادی
    تاریخ عضویت
    Apr 2009
    محل سکونت
    تهران
    نوشته
    81
    سپاسگزاری شده
    46
    سپاسگزاری کرده
    12
    شما اول vlanهارو که تعریف کردی البته بعد از vtp. و تعریف پورتهای ترانک دیگه لازم نیست رو سوییچ کاری کنید. میاد رو روتر و ساب اینترفیسهارو تعریف میکنی بعدش توی روتر باید چندتا DHCPPOOL بسازی به ازای هر رنج ip.
    شما اون کانفیگی که گذاشتم ببینی کامل متوجه میشی

    - - - Updated - - -

    خوب فقط میخوای توی یک vldn این کارو انجام بدی. یعنی dhcp فقط برای یک vlan باشه. خوب اون dhcp سرورو بزارید تو اون vlan. ولی اگه برا تمام vlanها میخوای یا باید رو روتر بزاری یا اینکه برا هر vlan یدونه سرور بزاری. به نظر من رو روتر راحت تره


    Microsoft Certified Systems Engineer
    MCSE

  14. #14
    نام حقيقي: مصطفی

    عضو عادی شناسه تصویری Mostafa_IT
    تاریخ عضویت
    Jan 2013
    محل سکونت
    مشهد
    نوشته
    71
    سپاسگزاری شده
    42
    سپاسگزاری کرده
    41
    نقل قول نوشته اصلی توسط mehdi-e62 نمایش پست ها
    شما اول vlanهارو که تعریف کردی البته بعد از vtp. و تعریف پورتهای ترانک دیگه لازم نیست رو سوییچ کاری کنید. میاد رو روتر و ساب اینترفیسهارو تعریف میکنی بعدش توی روتر باید چندتا DHCPPOOL بسازی به ازای هر رنج ip.
    شما اون کانفیگی که گذاشتم ببینی کامل متوجه میشی

    - - - Updated - - -

    خوب فقط میخوای توی یک vldn این کارو انجام بدی. یعنی dhcp فقط برای یک vlan باشه. خوب اون dhcp سرورو بزارید تو اون vlan. ولی اگه برا تمام vlanها میخوای یا باید رو روتر بزاری یا اینکه برا هر vlan یدونه سرور بزاری. به نظر من رو روتر راحت تره
    یعنی با توجه به شکلی که گذاشتم امکانش نیست که سرور روی vlan5 باشه و کامپیوتر هام در Vlan2 و vlan3 باشن و بهشون IP بده؟



  15. #15
    نام حقيقي: Danial

    عضو عادی
    تاریخ عضویت
    Dec 2010
    محل سکونت
    Tehran
    نوشته
    36
    سپاسگزاری شده
    10
    سپاسگزاری کرده
    3
    شما که اصلا توی vtp مشکلی نداری، سوئیچ ها vlan ها رو به هم پاس می دن.

    برای این که بتونی بین vlan هات ارتباط برقرار کنی باید از inter vlan routing استفاده کنی . این کار باعث می شه که اون dhcp server هم که اونجا گذاشتی بتونه به همه سیستم ها توی vlan های مختلف ip بده.

    با این توپولوژی برای این که بخوای اون سرور به همه ip بده، به جای اون سوئیچ مرکزیت یک سوئیچ لایه 3 بزار. به هر کدوم از interface vlan هات ip بده توی رنج اون vlan، بعد ip routing رو از توی مد config فعال کن.

    با این کار بین vlan هات می تونی ارتباط برقرار کنی.

    حالا واسه این که بتونن همه از dhcp server یک ip بگیرن. توی تک تک interface های سوئیچ لایه 3 خودت بزن ip helper address DHCP_SERVER_IP .

    مثلا
    interface vlan 10
    ip helper address 10.41.1.21 .

    حالا بقیش توی تنظیمات DHCP server باید به ازای subnet هایی که داری DHCP pool تعریف کنی



    این سناریو که گفتم مال زمانی هست که یک DHCP Server داری، برای حالتی هم که device میزاری باید مسلما subinterface تعریف کنی و به تعداد vlan هات DHCP Pool



صفحه 1 از 2 1 2 آخرینآخرین

کلمات کلیدی در جستجوها:

مشکل vtp ورژن 3

نقش md5 در vtp

vtp پیاده سازی

پیاده سازی ip helper بر روی سوئیچ

مشکل vlan در vtp

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •