نمایش نتایج: از شماره 1 تا 6 از مجموع 6
سپاس ها 2سپاس
  • 1 توسط EVERAL
  • 1 توسط xp_black

موضوع: توضیحی ساده و کامل در مورد پروتکل های link-state و hybrid

  
  1. #1
    نام حقيقي: ahvazi

    عضو عادی
    تاریخ عضویت
    Oct 2012
    محل سکونت
    ahvaz
    نوشته
    50
    سپاسگزاری شده
    8
    سپاسگزاری کرده
    23

    توضیحی ساده و کامل در مورد پروتکل های link-state و hybrid






  2. #2
    نام حقيقي: mohsen

    عضو عادی شناسه تصویری xp_black
    تاریخ عضویت
    May 2012
    محل سکونت
    تهران
    نوشته
    229
    سپاسگزاری شده
    192
    سپاسگزاری کرده
    22
    سلام
    برو کتاب CCNA بخش Routing protocol را بخوان کامل و روان توضیح داده دوست عزیز



  3. #3
    نام حقيقي: Rmin Rezaeimehr

    عضو عادی شناسه تصویری EVERAL
    تاریخ عضویت
    Jul 2009
    محل سکونت
    Tehran
    نوشته
    389
    سپاسگزاری شده
    397
    سپاسگزاری کرده
    511
    نقل قول نوشته اصلی توسط m_ahvaz_s نمایش پست ها
    دوستان عزیز یک توضیح کامل و آمیانه بگین لطفا
    به صورت کلی سه نوع از پروتکل های Dynamic Routing در عمل Routing شامل :
    1. Link State
    2. Distance Vector
    3. Hybrid

    است ؛ دسته بندی Routing پروتکل های IGP یا Interior Gateway Protocol :
    • Link State
    • Distance Vector

    Link State » تصویری از کل شبکه در Routing Table خودش دارد ، به صورت Classless است و Update هایش
    را به صورت Multicast ارسال می کند ؛ از الگوریتم Shortest Path first برای پیدا کردن بهترین مسیر استفاده می کند .
    RP های آن شامل OSPF و ISIS می باشد .
    Distance Vector » کل شبکه را نمی تواند ببیند به صورت (Flat Topology) است ، در صورت ارسال Update هایش
    از پیغام BroadCast استفاده می کند . به صورت Classful هستند (عدم ارسال Subnet Mask در آپدیت هایش) . از
    الگوریتم Bellman-Ford برای محاسبه بهترین مسیر تا مقصد استفاده می کند .
    RP های آن شامل RIP1 و IGRP است .
    Hybrid » ترکیبی از Distance Vector و Link State است (از مزایای مربوط به هر دونوع بهره می برد) .
    RP های آن شامل RIP2 و EIGRP است .
    اطلاعات تکمیلی


    m_ahvaz_s سپاسگزاری کرده است.

  4. #4
    نام حقيقي: ahvazi

    عضو عادی
    تاریخ عضویت
    Oct 2012
    محل سکونت
    ahvaz
    نوشته
    50
    سپاسگزاری شده
    8
    سپاسگزاری کرده
    23
    نقل قول نوشته اصلی توسط xp_black نمایش پست ها
    سلام
    برو کتاب CCNA بخش Routing protocol را بخوان کامل و روان توضیح داده دوست عزیز
    اگه از اونجا میفهمیدم که نمیومدم اینجا بگم



  5. #5
    نام حقيقي: mohsen

    عضو عادی شناسه تصویری xp_black
    تاریخ عضویت
    May 2012
    محل سکونت
    تهران
    نوشته
    229
    سپاسگزاری شده
    192
    سپاسگزاری کرده
    22
    اگه از اونجا میفهمیدم که نمیومدم اینجا بگم
    دوست عزیز چون دقیق نخوندی , و قبلش search نکردی.
    از حرفم برداشت بد نکن , چون قصدم بی احترامی نیست.
    امیدوارم چیزی که گذاشتم بتونه کمکت کنه هم در مفهوم و هم در کانفیگ.
    موفق باشی.

    در Dynamic Routing از پروتوکلها به منظور یافتن مسیر و update کردن routing table استفاده میشود و برای شبکه های بزرگ مناسب میباشد
    یک پروتکل مجموعه ای از قوانین به منظور ارتباط یک روتر با روترهای همسایه( neighbor Router) را انجام میدهد
    Administrative Distances(AD)
    یک عدد بین 0 تا 255 است که بیان کننده یک سطح از ارزش و اطمینان به اطلاعات روتینگ مبدا میباشد
    عدد صفر نشاندهنده اعتماد بالا و عدد 255 نشاندهنده عدم وجود ترافیک بر روی مسیر میباشد
    اگر روتری دو لیست بهنگام سازی را از یک شبکه راه دور مشابه دریافت کند اولین چیزی که روتر چک میکند AD میباشد
    اگر یکی از مسیرهای پیشنهادی دارای AD کمتر باشد,سپس مسیری در routing table جایگزین میشود که دارای AD پایین تری باشد.اگر هر دو مسیر پیشنهادی در یک شبکه و AD یکسان باشد سپس پروتکل روتینگ استفاده خواهد کرد بهترین مسیر را بوسیله Load Balance یک شبکه راه دور
    اگر یک شبکه مستقیما به روتر متصل شده باشد,روتر همیشه از interface متصل شده به شبکه استفاده خواهد کرد
    اگر یک administrator یک مسیر static را پیکربندی کند,روتر باور خواهد داشت این مسیر را
    administartor شبکه میتواند مقدار AD مسیرهای static را تغییر دهد اما بصورت پیشفرض یک در نظر گرفته میشود

    جدول زیر default Administrative Destances میباشد که روتر سیسکو از آن منظور انتخاب مسیر به یک شبکه راه دور استفاده میکند

    Route Source
    Default AD
    connected interface
    0
    Static Route 1
    EIGRP 90
    IGRP 100
    OSPF 110
    RIP 120
    External EIGRP
    170
    پیکربندی Dynamic Route
    برای پیکربندی باید یکی از پروتوکلهای زیر را استفاده کنیم
    1.RIP(Routing Information Protocol)
    2.IGRP(Interior Gateway Routing Protocol)
    3.EIGRP(Enhanced Interior Gateway Routing Protocol)
    4.OSPF(Open Shortest Path First)
    توجه داشته باشید برای هر روتر آدرسهایی را که مستقیم به روترما وصل شده اند مسیریابی میکنیم

    سه کلاس routing protocol وجود میباشد
    1.Distance Vector
    2.Link State
    3.Hybrid Balanced

    Distance Vector
    این روترها بهترین مسیر را از طریق اطلاعات ارسال شده توسط سایر روترهای مجاور محاسبه میکند
    پروتکل های distance vector بهترین راه پیدا کردن یک مسیر شبکه بوسیله تشخیص فاصله میباشد
    هر بار که یک packet حول یک روتر عبور کند یک hop نامیده میشود
    یک Route با کمترین تعداد hop ها,شبکه ,بهترین Route میباشد
    vectore مسیر را به شبکه مشخص میکند
    RIP و IGRP هر دو پروتوکلهای distance vector هستند
    این دو routing table را بطور مستقیم به روترهای همسایه متصل میفرستد
    مزیت distant vector به روز شدن سریع اطلاعات است
    اشکال distant vector ترافیک زیاد است


    Link State
    این نوع روترها هر یک دارای یک نسخه ای از نقشه شبکه بوده و بهترین مسیر را با استفاده از آن محاسبه میکند
    در پروتکل های link state روترها هر کدام سه جدول جداگانه ایجاد میکند یکی از این جدولها نگهداری میکند مسیری که مستقیما ضمیمه شده به روترهای همسایه و یکی دیگر از آنها معین میکند روش اتصال تمام عناصر شبکه را و دیگری استفاده میشود به عنوان routing table
    روترهای link state آگاهی بیشتری درباره internetwork نسبت به پروتوکلهای distance vectorدارند
    OSPF که یک پروتکل IP Routing است کاملا Link State میباشد
    پروتوکلهای link state, update هایی که شامل عبارت لینکهای مربوط به خودشان به تمامی روترهای دیگر را روی شبکه میفرستند
    اشکال link state گرفتن زمان زیاد برای به روز شدن میباشد
    مزیت link state ترافیک کم آن است

    Hybrid Balanced
    hybrid balanced ادغامی از distant vector و link state میباشد
    ٍEIGRP در hybrid balanced کار میکند


    پیکربندی RIP
    RIP در پروتکل Distant vector میباشد و برای شبکه های کوچک پیکربندی میشود و برای شبکه هایی که بصورت مستقیم به روتر وصل باشد پیکربندی میشودهر مسیرگردان در یک شبکه جدول مسیریابی خود را هر 30 ثانیه یک بار از طریق RIP به نزدیکترین همسایگی خود ارسال میکند.مسیریابی تحت RIP از طریق تعداد گامهای بین مبداو مقصد تعیین میشود.RIP پروتکلی برای پل های ارتباطی داخلی است چون RIP موثرترین پروتکل مسیریابی نیست به تدریج توسط پروتکل OSPF جایگزین میشود دو version در RIP موجود میباشد, RIPV1 , RIPV2
    RIPV1 RIPV2
    classful classless
    no authentication authentication
    no encription encription
    classful به معنی استفاده از default subnet mask میباشد
    classless به معنی استفاده از customize subnet mask میباشد

    RA>en
    RA#config t
    RA(config)#int e0
    RA(config-if)#ip address 192.168.10.1 255.255.255.0
    RA(config-if)#no shut
    RA(config-if)#^z
    RA(config)#wr

    RA#config t
    RA(config)#int s0
    RA(config-if)#ip address 120.120.120.1 255.0.0.0
    RA(config-if)#clock rate 64000
    RA(config-if)#no shut
    RA(config-if)#^z
    RA(config)#wr

    RA(config)#router rip
    RA(config-router)#network 192.168.10.0
    RA(config-router)#network 120.0.0.0


    RB>en
    RB#config t
    RB(config)#int e0
    RB(config-if)#ip address 192.168.20.1 255.255.255.0
    RB(config-if)#no shut
    RB(config-if)#^z
    RB(config)#wr
    RB#config t
    RB(config)#int s1
    RB(config-if)#ip address 120.120.120.2 255.0.0.0
    RB(config-if)#clock rate 64000
    RB(config-if)#no shut
    RB(config-if)#^z
    RB(config)#wr
    RB#config t
    RB(config)#int s0
    RB(config-if)#ip address 150.150.150.1 255.255.0.0
    RB(config-if)#clock rate 64000
    RB(config-if)#no shut
    RB(config-if)#^z
    RB(config)#wr

    RB(config)#router rip
    RB(config-router)#network 192.168.20.0
    RB(config-router)#network 120.0.0.0
    RB(config-router)#network 150.150.0.0.0

    RC>en
    RC#config t
    RC(config)#int e0
    RC(config-if)#ip add 192.168.30.1 255.255.255.0
    RC(config-if)#no shut
    Rc(config-if)#^z
    RC(config)#wr

    RC#config t
    RC(config)#int s0
    RC(config-if)#ip add 150.150.150.2 255.255.0.0
    RC(config-if)#clock rate 64000
    RC(config-if)#no shut
    RC(config-if)#^z
    RC(config)#wr

    RC(config)#router rip
    RC(config-router)#network 192.168.30.0
    RC(config-router)#network 150.150.0.0

    پیکربندی IGRP
    IGRP پروتکلی است که توسط سیسکو سیستم ارائه شده ومسیریابی چندین پل ارتباطی(Gateway) را هماهنگ میکند.اهداف IGRP عبارتند از مسیریابی پایدار در شبکه های بزرگ, پاسخگویی سریع به تغییرات هم بندی شبکه و سربارکم IGRP پروتکل اختصاصی سیسکو میباشد که در distant vector کار میکند
    اگر از IGRP در شبکه استفاده کنیم بقیه روترهای شبکه نیز باید روترهای سیسکو باشند
    IGRP از Classless Routing استفاده میکند
    IGRP را برای روترهایی که بصورت مستقیم به روتر وصل باشد تعیین میکنیم
    Autonomous System(AS)
    ّیک مجموعه از روترها میباشد که بوسیله یک administrator اداره میشود
    برای AS از اعدادی بین 65535-1 باید استفاده کنیم
    syntax IGRP به قرار زیر میباشد
    RA(config)#router igrp <AS number>
    RA(config-router)#network network address

    RA(config)#router igrp 100
    RA(config-router)#network 192.168.10.0
    RA(config-router)#network 120.120.120.0

    RB(config)#router igrp 100
    RB(config-router)#network 192.168.20.0
    RB(config-router)#network 120.120.120.0
    RB(config-router)#network 150.150.150.0

    RC(config)#router igrp 100
    RC(config-router)#network 192.168.30.0
    RC(config-router)#network 150.150.150.0

    پیکربندی EIGRP
    EIGRP پروتکل اختصاصی سیسکو میباشد که در Hybrid Balanced کار میکند
    ٍEIGRP از Classless Routing استفاده میکند و برای روترهایی که مستقیما متصل هستند تعیین میشود
    RA(config)#router eigrp <AS number>
    RA(config-router)#network network address

    RA(config)#router eigrp 100
    RA(config-router)#network 192.168.10.0
    RA(config-router)#network 120.120.120.0

    RB(config)#router eigrp 100
    RB(config-router)#network 192.168.20.0
    RB(config-router)#network 120.120.120.0
    RB(config-router)#network 150.150.150.0

    RC(config)#router eigrp 100
    RC(config-router)#network 192.168.30.0
    RC(config-router)#network 150.150.150.0

    پیکریندی OSPF
    یک پروتکل مسیریابی برای شبکه های IP ی چون اینترنت است که به یک مسیریاب امکان میدهد تا کوتاهترین مسیر منتهی به هر گره را برای پیام های ارسالی محاسبه نماید.مسیریاب برای انجام محاسبات خود اطلاعاتی را درباره گره های متصل به خود به مسیریاب های دیگر شبکه ارسال میکند تا اطلاعاتی درباره وضعیت ارتباط ها گرد آوری کند
    OSPF میتواند با هر نوع روتری ارتباط داشته باشد
    این پروتکل برای شبکه های سازمانی (Enterprise Network) میتواند استفاده شود
    OSPF عمل میکند در SPF Technologes

    Area
    Area یک مجموعه از روترها است کد بوسیله single administrator اداره و نگهداری میشود

    ASBR(Autonomous System Border Router)
    روتر ناحیه مرزی که جایگزین شده بین یک autonomous system ospf و یک شبکه بدون OSPF که عمل میکند هر دو, OSPF و روتر پروتکل اضافه شده مانند RIP
    ASBR ها باید قرار داده شوند در یک ناحیه non-stub OSPF

    Backbone
    بخش مبنایی یک شبکه که فراهم میکند مسیر اولیه برای ترافیک فرستاده شده و راه انداخته شده از بقیه شبکه ها

    Process ID
    یک عدد است که برای اجرای مراحل مختلف OSPF در یک روتر صادر میشود

    WildCard

    یک عدد است که تعیین میکند چه مقدار IP address در OSPFاستفاده میشود
    Range از subnet ها را تعیین میکند
    wildcar برای تطبیق IPاستفاده میشود
    بطور مثال ip و wildcard زیر نشان میدهد range صفر تا 255 را
    192.168.10.0 0.0.0.255

    در wildcard آن octet که صفر است چک نمیشود و آن octet که 255 است بدین معنی است که range یک تا 255 را چک کند

    OSPF Syntax
    RA(config)#router ospf process-id
    RA(config-router)#network wildcard-mask area area-id

    RA(config)#router ospf 100
    RA(config-router)#network 192.168.10.0 0.0.0.255 area0
    RA(config-router)#network 120.120.120.0 0.0.0.3 area0

    RB(config)#router ospf 101
    RB(config-router)#network 192.168.20.0 0.0.0.255 area0
    RB(config-router)#network 120.120.120.0 0.0.0.3 area0
    RB(config-router)#network 150.150.150.0 0.0.0.3 area0

    RC(config)#router ospf 102
    RC(config-router)#network 192.168.30.0 0.0.0.255 area0
    RC(config-router)#network 150.150.150.0 0.0.0.3 area0

    منبع : subnet | مسیریابی Dynamic Routing پروتكل پیکربندی



    m_ahvaz_s سپاسگزاری کرده است.

  6. #6
    نام حقيقي: ahvazi

    عضو عادی
    تاریخ عضویت
    Oct 2012
    محل سکونت
    ahvaz
    نوشته
    50
    سپاسگزاری شده
    8
    سپاسگزاری کرده
    23
    خیلی خیلی ممنون







کلمات کلیدی در جستجوها:

پروتکل link state

الگوریتم link state

الگوریتم مسیریابی link state

http:forum.persiannetworks.comf63t55755-new.html

توضیح link state

link state را توضیح دهید

توضیح درباره ی پروتکل ospf

درباره پروتکل EIGRP

پروتکل های link state

اطلاعاتی در مورد پروتکل ripAdministrative Distance را توضیح دهیدپروتکل hybridدرباره linkstateتوضیح درباره eigrpدرباره link stateدر مورد linkned . comrouterتوضیح در باره link state protocolمفهوم link stateمعنی link state protocolتوضیح ساده routeeigrp دربارهپر وتکل hybridlink state protocol در مورد پروتکلتوضیحاتی کامل پیرامون پروتکل های شبکه

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •