نمایش نتایج: از شماره 1 تا 14 از مجموع 14
سپاس ها 13سپاس
  • 1 توسط iranianmah
  • 3 توسط A.Yazdani
  • 1 توسط iranianmah
  • 1 توسط A.Yazdani
  • 1 توسط iranianmah
  • 2 توسط A.Yazdani
  • 1 توسط iranianmah
  • 1 توسط omidmir88
  • 1 توسط vaahiid
  • 1 توسط iranianmah

موضوع: برقراری VPN Tunnel بین شعب روی اینترنت

  
  1. #1
    نام حقيقي: محمد مهدی غلام زاده

    عضو عادی شناسه تصویری iranianmah
    تاریخ عضویت
    Jun 2009
    محل سکونت
    مشهد
    نوشته
    88
    سپاسگزاری شده
    11
    سپاسگزاری کرده
    7

    برقراری VPN Tunnel بین شعب روی اینترنت








    سلام دوستان .

    من یک کمک میخوام در مورد راه اندازی VPN Tunnel .
    همونطور که تو شکل بالا میبینین 3 تا router که از طریق خط مخابراتی ( MPLS ) به هم وصل هستند و به ip 10.139.3.20 وصل میشوند که در شعبه مشهد هست .

    حالا من یک اینترنت هم گرفتم برای اینترنت دادم به سیستم های هر شعبه و هم اینکه به عنوان یک خط Backup میخوام ازش استفاده کنم که وقتی MPLS قطع میشه یا سرعت اینترنت بالاتره بره روی اینترنت .

    حالا من توی اون قسمت vpn زدن بین router های هر شعبه تا router شعبه مشهد نمیدونم باید چه کار کنم !

    اگه کسی کمکمک کنه ممنون میشم .


    لینک عکس : http://up.vatandownload.com/images/u...t7rrvxto0t.jpg



    موضوعات مشابه:
    ویرایش توسط iranianmah : 2012-06-02 در ساعت 11:13 PM
    shahein2 سپاسگزاری کرده است.





  2. #2
    نام حقيقي: احمد یزدانی (Poker)

    عضو ویژه شناسه تصویری A.Yazdani
    تاریخ عضویت
    Aug 2010
    محل سکونت
    Isfahan
    نوشته
    945
    سپاسگزاری شده
    1310
    سپاسگزاری کرده
    420
    نوشته های وبلاگ
    8
    سلام
    ابتدا از برقراری ارتباط بین شعب با دفتر مر کزی مطمئن بشین. بعد از اینکه ارتباط بین نقاط ok بود IPsec VPN راه اندازی کنید در لینک زیر به صورت ساده این مراحل گفته شده است :
     IPSec VPN 


    iranianmah، virus41 و shahein2 سپاسگزاری کرده‌اند.

  3. #3
    نام حقيقي: محمد مهدی غلام زاده

    عضو عادی شناسه تصویری iranianmah
    تاریخ عضویت
    Jun 2009
    محل سکونت
    مشهد
    نوشته
    88
    سپاسگزاری شده
    11
    سپاسگزاری کرده
    7
    ممنون آقای یزدانی بایت راهنماییت ، من از راه ساده تر اومدم اول انجام بدم اما متاسفانه نشد .
    کانفیگ روتر هامو گذاشتم ممنون میشم که اگه کسی میتونه کمکی بکنه .

    Line Protocol Up شده ام نمیدونم چرا نمیتونم IP های تونل هامو چک کنم !


    کانفیگ روتر مشهد :


    ********************
    Router Mashhad
    ********************


    interface Tunnel4
    ip address 172.10.4.1 255.255.255.252
    tunnel source GigabitEthernet0/2
    tunnel destination 91.98.49.50
    !
    interface GigabitEthernet0/0
    description TO LAN
    ip address 10.20.3.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/2
    description TO Modem ADSL (192.168.2.1)
    ip address 192.168.2.100 255.255.255.0
    duplex auto
    speed auto
    !
    interface Serial0/0/0
    description TO MOKHABERAT
    ip unnumbered GigabitEthernet0/0
    encapsulation ppp
    !
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    !
    ip route 0.0.0.0 0.0.0.0 192.168.2.1
    ip route 10.20.0.0 255.255.0.0 Serial0/0/0
    ip route 10.20.3.0 255.255.255.0 GigabitEthernet0/0

    اینم مودم ADSL مشهد که DMZ تعریف شده IP Ethernet Router

    http://up.vatandownload.com/images/w...f4suevizdn.png



    ----------------------------------------------------------------------
    کانفیگ روتر اصفهان :

    ********************
    * *
    * Router Esfehan *
    * *
    ********************



    interface Tunnel4
    ip address 172.10.4.2 255.255.255.252
    tunnel source FastEthernet0/1
    tunnel destination 2.180.33.13
    !
    interface FastEthernet0/0
    description TO LAN
    ip address 10.20.4.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    description TO Modem ADSL (192.168.1.1)
    ip address 192.168.1.100 255.255.255.0
    duplex auto
    speed auto
    !
    interface Serial0/0/0
    description TO MOKHABERAT
    ip unnumbered FastEthernet0/0
    encapsulation ppp
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    ip route 10.20.0.0 255.255.0.0 Serial0/0/0

    -------------------------------------------------------------

    اینم مودم ADSL اصفهان که DMZ تعریف شده IP Ethernet Router

    http://up.vatandownload.com/images/b...a4oo8gsces.png



    - - - Updated - - -

    اینم اطلاعات تونل 4 در مشهد :

    Core-Mashhad#show interfaces tunnel 4
    Tunnel4 is up, line protocol is up
    Hardware is Tunnel
    Internet address is 172.10.4.1/30
    MTU 17916 bytes, BW 100 Kbit/sec, DLY 50000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation TUNNEL, loopback not set
    Keepalive not set
    Tunnel source 192.168.2.100 (GigabitEthernet0/2), destination 91.98.49.50
    Tunnel Subblocks:
    src-track:
    Tunnel4 source tracking subblock associated with GigabitEthernet0/2
    Set of tunnels with source GigabitEthernet0/2, 1 member (includes iter
    ators), on interface <OK>
    Tunnel protocol/transport GRE/IP
    Key disabled, sequencing disabled
    Checksumming of packets disabled
    Tunnel TTL 255, Fast tunneling enabled
    Tunnel transport MTU 1476 bytes
    Tunnel transmit bandwidth 8000 (kbps)
    Tunnel receive bandwidth 8000 (kbps)
    Last input 05:24:52, output 05:19:59, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/0 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts (0 IP multicasts)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    4687 packets output, 391098 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 unknown protocol drops
    0 output buffer failures, 0 output buffers swapped out


    ------------------------------------------

    و اینم اطلاعات تونل 4 در اصفهان :


    Router-Esfehan#show interfaces tunnel 4
    Tunnel4 is up, line protocol is up
    Hardware is Tunnel
    Internet address is 172.10.4.2/30
    MTU 1514 bytes, BW 9 Kbit/sec, DLY 500000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation TUNNEL, loopback not set
    Keepalive not set
    Tunnel source 192.168.1.100 (FastEthernet0/1), destination 2.180.33.13
    Tunnel protocol/transport GRE/IP
    Key disabled, sequencing disabled
    Checksumming of packets disabled
    Tunnel TTL 255
    Fast tunneling enabled
    Tunnel transmit bandwidth 8000 (kbps)
    Tunnel receive bandwidth 8000 (kbps)
    Last input 05:22:34, output 05:11:25, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/0 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    189 packets output, 10352 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 unknown protocol drops
    0 output buffer failures, 0 output buffers swapped out
    Router-Esfehan#


    ویرایش توسط iranianmah : 2012-06-13 در ساعت 10:19 PM
    shahein2 سپاسگزاری کرده است.

  4. #4
    نام حقيقي: احمد یزدانی (Poker)

    عضو ویژه شناسه تصویری A.Yazdani
    تاریخ عضویت
    Aug 2010
    محل سکونت
    Isfahan
    نوشته
    945
    سپاسگزاری شده
    1310
    سپاسگزاری کرده
    420
    نوشته های وبلاگ
    8
    در تنظیمات شما نه ISAKMP دیده میشه و نه تنظیمات IPsec . لینک داده شده رو دیدید ؟


    shahein2 سپاسگزاری کرده است.

  5. #5
    نام حقيقي: محمد مهدی غلام زاده

    عضو عادی شناسه تصویری iranianmah
    تاریخ عضویت
    Jun 2009
    محل سکونت
    مشهد
    نوشته
    88
    سپاسگزاری شده
    11
    سپاسگزاری کرده
    7
    نقل قول نوشته اصلی توسط A.Yazdani نمایش پست ها
    در تنظیمات شما نه ISAKMP دیده میشه و نه تنظیمات IPsec . لینک داده شده رو دیدید ؟

    راستشو بخوای من از این آموزش استفاده کردم که نتیجه نداد ! یکم راحت تر بود ولی امنیتی نداره .
    حالا نمیدونم برای این نمیشه که تو این آموزش از پورت Serial استفاده کرده و من دارم رو Ethernet پیاده سازی میکنم ، یا مشکل از چیزه دیگس .
    آموزش تصویری راه اندازی GRE tunnel بر روی روتر سیسکو




    RouterA
    Public IP: 217.219.50.100 Tunnel IP: 192.168.0.1 Private network: 192.168.1.0/24 IP on that private network: 192.168.1.1

    RouterB
    Public IP: 217.219.97.1 Tunnel IP: 192.168.0.2 Private network: 192.168.2.0/24 IP on that private network: 192.168.2.1


    ----------------------------------------


    Config on RouterA :

    interface Tunnel0
    description connection to RouterB
    ip address 192.168.0.1 255.255.255.0
    tunnel source Serial 1/0
    tunnel destination 217.219.97.1
    tunnel mode gre ip

    Config on RouterB :
    interface Tunnel0
    description connection to Linux RouterA
    ip address 192.168.0.2 255.255.255.0
    tunnel source Serial 1/0
    tunnel destination 217.219.50.100
    tunnel mode gre ip



    shahein2 سپاسگزاری کرده است.

  6. #6
    نام حقيقي: احمد یزدانی (Poker)

    عضو ویژه شناسه تصویری A.Yazdani
    تاریخ عضویت
    Aug 2010
    محل سکونت
    Isfahan
    نوشته
    945
    سپاسگزاری شده
    1310
    سپاسگزاری کرده
    420
    نوشته های وبلاگ
    8
    دوست عزیز این چیزی که شما راه انداختید GRE هست که GRE رو روی IPsec راه می ندازند و دلیلش هم معمولآ برای انتقال Routing update هست . شما فقط به IPsec نیاز دارید .


    f14f21 و shahein2 سپاسگزاری کرده‌اند.





  7. #7
    نام حقيقي: محمد مهدی غلام زاده

    عضو عادی شناسه تصویری iranianmah
    تاریخ عضویت
    Jun 2009
    محل سکونت
    مشهد
    نوشته
    88
    سپاسگزاری شده
    11
    سپاسگزاری کرده
    7
    نقل قول نوشته اصلی توسط A.Yazdani نمایش پست ها
    دوست عزیز این چیزی که شما راه انداختید GRE هست که GRE رو روی IPsec راه می ندازند و دلیلش هم معمولآ برای انتقال Routing update هست . شما فقط به IPsec نیاز دارید .
    یعنی من نمیتونم با GRE از دو طرف ping بگیرم ؟؟؟؟؟؟؟؟؟؟؟
    و فقط Routing Update رو میبره و میاره ؟؟ من که routing ام Static هست و packet update ای ندارم .

    از این آموزش دیگه که الان دارم میرم تو Router ام Crypto ISAKMP نداره !

    ? Core-Mashhad(config)#crypto
    key Long term key operations
    pki Public Key components


    *-------------------------------------------------*


    License Info:

    License UDI:

    -----------------------
    Device# PID
    -----------------------
    *0 CISCO2911/K9



    shahein2 سپاسگزاری کرده است.

  8. #8
    نام حقيقي: اميد

    عضو عادی
    تاریخ عضویت
    Aug 2009
    محل سکونت
    گرگان
    نوشته
    33
    سپاسگزاری شده
    3
    سپاسگزاری کرده
    39
    شما اگر Ip Tunnel درست نوشته باشی منظورم Ip valid هست. باید بتونی ip اینترفیس Tunnel که رنج 172 دادی تو هر طرف پینگ بگیری. اگه پینگ گرفتی برای اینکه ترافیک بین شبکه ها تو بتونی از روی Tunnel انتقال بدی باید روت بنویسید برای هر روتر مثلا در روتر مشهد ip route 192.168.1.0 255.255.255.0 tunnel 4
    البته اگه من منظور شما رو درست متوجه شده باشم مشکلتون نداشتن روت برای Tunnel برای انتقال ترافیک بین شبکه ها.


    shahein2 سپاسگزاری کرده است.

  9. #9
    نام حقيقي: وحید

    عضو عادی
    تاریخ عضویت
    Jun 2012
    محل سکونت
    تهران
    نوشته
    109
    سپاسگزاری شده
    80
    سپاسگزاری کرده
    13
    اگر شما اینو میخواید ، تو همه جای دنیا واسش پول میگیرن. به این راحتی ها نمیگن من فقط تنها کمکی که میتونیم بکنم اینه که شما باید DMVPN راه بندازین.


    shahein2 سپاسگزاری کرده است.

  10. #10
    نام حقيقي: محمد مهدی غلام زاده

    عضو عادی شناسه تصویری iranianmah
    تاریخ عضویت
    Jun 2009
    محل سکونت
    مشهد
    نوشته
    88
    سپاسگزاری شده
    11
    سپاسگزاری کرده
    7
    با تشکر از کلیه دوستانی که نظر دادن ! من این کار رو بدون پرداخت پولی انجام دادم .

    مودم های ADSL ام رو در هر شعبه بر روی Bridge قرار دادم و بعد بر روی Router یک Dialer تعریف کردم ( مثل Connection ویندوز ) با این کار IP Static بر روی Interface Dialer قرار میگیرد و بعد هم یک Tunnel تعریف کردم که Tunnel Destinationشد IP Static طرف مقایل و Tunnesl Source هم شد Interface Dialer خود Router و اینجوری Tunnel Up شد و Ping هر دو طرف رو هم دارم الان .


    اینم کانفیگ :

    1- ساختن Dialer :

    interface Dialer1
    ip address negotiated
    encapsulation ppp
    dialer pool 10
    ppp authentication pap callin
    789101112 ppp pap sent-username 123456 password
    ppp ipcp route default
    end

    2- بر روی Port متصل با کابل شبکه به Modm ADSL باید دستور زیر رو بزنیم :

    interface GigabitEthernet0/2
    description TO Modem ADSL
    no ip address
    duplex auto
    speed auto
    pppoe enable group global
    pppoe-client dial-pool-number 10

    end


    3- اینم Show ip Interface Brief که زدم بر روی Router طرف مقابل :

    Interface IP-Address OK? Method Status Protocol

    GigabitEthernet0/2 unassigned YES NVRAM up up

    Dialer1 91.98.65.30 YES IPCP up up



    از آخر هم که tunnel رو تعریف کردم اینجوری :

    interface Tunnel4
    description Tunnel Mashhad <=> Isfahan
    ip address 192.168.4.1 255.255.255.0
    tunnel source Dialer1
    tunnel destination 91.98.65.30
    end

    - - - Updated - - -

    این هم فیلم آموزشی

    http://www.youtube.com/watch?v=HBP8_LqBj44


    shahein2 سپاسگزاری کرده است.

  11. #11
    نام حقيقي: aa

    عضو عادی شناسه تصویری shahein2
    تاریخ عضویت
    Aug 2012
    محل سکونت
    bb
    نوشته
    436
    سپاسگزاری شده
    128
    سپاسگزاری کرده
    200
    نقل قول نوشته اصلی توسط iranianmah نمایش پست ها
    سلام ممکنه لینک رو جایی دیگه قرار بدید.ف. ی .ل. ت. ر. ه .



  12. #12
    نام حقيقي: محمد مهدی غلام زاده

    عضو عادی شناسه تصویری iranianmah
    تاریخ عضویت
    Jun 2009
    محل سکونت
    مشهد
    نوشته
    88
    سپاسگزاری شده
    11
    سپاسگزاری کرده
    7
    نقل قول نوشته اصلی توسط shahein2 نمایش پست ها
    سلام ممکنه لینک رو جایی دیگه قرار بدید.ف. ی .ل. ت. ر. ه .
    لینک از خود Youtube هستش !!







  13. #13
    نام حقيقي: aa

    عضو عادی شناسه تصویری shahein2
    تاریخ عضویت
    Aug 2012
    محل سکونت
    bb
    نوشته
    436
    سپاسگزاری شده
    128
    سپاسگزاری کرده
    200
    نقل قول نوشته اصلی توسط iranianmah نمایش پست ها
    لینک از خود Youtube هستش !!
    اگر شد در جایی دیگه شما دانلود و اپلود کنید .البته لطف می کنید و در صورت امکان .

    ضمنا این پروژ] شما واقعی بود یا یه سناریور؟؟؟؟؟



  14. #14
    نام حقيقي: محمد مهدی غلام زاده

    عضو عادی شناسه تصویری iranianmah
    تاریخ عضویت
    Jun 2009
    محل سکونت
    مشهد
    نوشته
    88
    سپاسگزاری شده
    11
    سپاسگزاری کرده
    7
    آره ، اما هنوز در حال انجامش هستم . زیاد مسلط نیستم یکمی کار دیر پیش میره متاسفانه .

    تانل ها رو دارم بین شعبه اصلی و و 15 تا شعبه دارم میزنم ، بعضی از شعبه ها MPLS دارن راحته اما اونایی که فقط اینترنت دارن یکمی سخت تره کار ولی دیگه قسمت Routing مونده فعلا نمیدونم چه جوری بین اینا Dynamic Routing راه بندازم تا بهترین حالت رو داشته باشم !


    http://s1.uplod.ir/files/8/issrb78gm..._-_YouTube.FLV

    Download Config___Setup_PPPoE_on_Cisco_Router_-_YouTube.FLV



کلمات کلیدی در جستجوها:

شکل vpn

برقراری vpn

دستور tuunel در روتر

dmvpnآموزش

vpn تونل

طونل vpn

dmvpn آموزش

آموزش dmvpn

طریقه vpn زدن

آموزش راه اندازی dmvpn

راه اندازی vpn در سیسکو

mpls vpn شبکه

راه اندازی vpn server در روتر سیسکو

راه اندازی vpn بین دو اینترنت adsl

زدن IPSec VPN در روتر

کانفیگ dmvpn

طونلvpn

adsl vpn 172.

آموزش تونل وی پی ان

vpn میخوام

سرعت vpn تونل

آموزش و تعريف dmvpn

تونل روی خط مخابرات

tunneling تنظیم سیسکو

راهنمای میزان مصرف در 192.168.1.1

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •