صفحه 1 از 2 1 2 آخرینآخرین
نمایش نتایج: از شماره 1 تا 15 از مجموع 17

موضوع: بستن چند پروتکل بر روی یک پورت خاص سوئئیچ

  
  1. #1
    نام حقيقي: سحر خاكپور

    عضو عادی
    تاریخ عضویت
    Jun 2010
    محل سکونت
    0098
    نوشته
    324
    سپاسگزاری شده
    62
    سپاسگزاری کرده
    302

    بستن چند پروتکل بر روی یک پورت خاص سوئئیچ

    سلام
    اساتید گرامی بنده قصد دارم یه سوئیچ قابل کانفیگ رو جوری کانفیگ کنم که سیستمی به پورت fast ethernet 0/2 وصل هست نتونه سایتی باز کنه ( پورت 80 روی پورت شماره 2 سوئیچ در دسترس نباشه )

    تحقیقات تقریباً خوبی انجام دادم و به جاهایی هم رسیدم.

    مثلاً اینو میدونم که باید از extended access list استفاده کنم و حتی فهمیدم که دستورش رو چجوری بنویسم.
    میتونم یه access list با اسم دلخواه درست کنم و پورت مورد نظرم رو ببندم. اماا نمیدونم چجوری این access list رو به یک پورت خاص سوئیچ نسیت بدم.

    دو راه رفتم کمی گیج شدم .
    1- پورت مورد نظر رو بزارم توی یک vlan
    2- با دستور no switchport پورت مورد نظر رو تغییر حالت بدم.

    که خوب بقیه مراحل رو قاطی کردم کلاً.

    لطفاً راهنماییم کنید.
    تشکر



    موضوعات مشابه:





  2. #2
    نام حقيقي: Mohammad Moghaddas

    عضو عادی شناسه تصویری Moghaddas
    تاریخ عضویت
    Jan 2010
    محل سکونت
    Tehran
    نوشته
    111
    سپاسگزاری شده
    61
    سپاسگزاری کرده
    20
    بستگی به توپولوژی شبکتون داره که پورت رو ببرین توی VLAN یا از حالت Roted-port استفاده کنین. اما برای apply کردن ACL:
    interface (vlan/fas0/2)
    ip access-group (ACL) out


    sahar_gol و asghari70 سپاسگزاری کرده‌اند.

  3. #3
    نام حقيقي: صادق نجاتی زاده

    مدیر بازنشسته شناسه تصویری SADEGH65
    تاریخ عضویت
    Nov 2003
    محل سکونت
    تهران
    نوشته
    2,264
    سپاسگزاری شده
    3409
    سپاسگزاری کرده
    3620
    نوشته های وبلاگ
    12
    با تشک از جناب مقدس باید این نکته را مد نظر قرار داد که تعریف و اعمال محدودیت بر روی پروتکل های لایه 3 ( در اینجا TCP ) حتما باید از سوییچ لایه 3 استفاده نمود - البته دستور No switchport نیز فقد در سوییچ لایه 3 ممکن است .
    در صورت زدن دستور بالا شما از این پورت به عنوان یک پورت در حالت روتینگ استفاده میکنید و باید به آن IP بدهید و یا اینکه این پورت را در یک vLAN قرار داده و بر روی آن Vlan اکسس لیست بنویسید.


    sahar_gol و asghari70 سپاسگزاری کرده‌اند.

  4. #4
    نام حقيقي: احمد یزدانی (Poker)

    عضو ویژه شناسه تصویری A.Yazdani
    تاریخ عضویت
    Aug 2010
    محل سکونت
    Isfahan
    نوشته
    945
    سپاسگزاری شده
    1310
    سپاسگزاری کرده
    414
    نوشته های وبلاگ
    8
    با سلام
    لازم نیست حتمآ سوییچ لایه 3 باشد !!!!

    سوییچ های لایه 2 درسته که لایه 2 هستند اما به این معنی نیست که نتونه tcp رو بفهمه این دوست ما راحت میتونه یه
    ACL بنویسه و بعد قرارش بده روی in در fa0/2


    SADEGH65، th95، aliafzalan و 2 نفر دیگر سپاسگزاری کرده‌اند.

  5. #5
    نام حقيقي: صادق نجاتی زاده

    مدیر بازنشسته شناسه تصویری SADEGH65
    تاریخ عضویت
    Nov 2003
    محل سکونت
    تهران
    نوشته
    2,264
    سپاسگزاری شده
    3409
    سپاسگزاری کرده
    3620
    نوشته های وبلاگ
    12
    نقل قول نوشته اصلی توسط poker نمایش پست ها
    با سلام
    لازم نیست حتمآ سوییچ لایه 3 باشد !!!!
    فرمایش شما کاملا صحیح است و اشتباه از من بود و من تا به حال این مورد را تست نکرده بودم


    th95، aliafzalan، sahar_gol و 2 نفر دیگر سپاسگزاری کرده‌اند.

  6. #6
    نام حقيقي: Ali Afzalan

    مدیر بخش Cisco شناسه تصویری aliafzalan
    تاریخ عضویت
    Apr 2009
    محل سکونت
    Tehran
    نوشته
    2,086
    سپاسگزاری شده
    2556
    سپاسگزاری کرده
    2059
    سلام
    یک فرق کوچک (و البته شاید هم بزرگ! چون یکبار بدجوری کارم را لنگ کرد) اینه که روی پورت لایه دو، ACL را میشه فقط در جهت in اینترفیس نوشت و نه out.
    البته مشکل دوستمون با قرار دادن ACL روی ورودی پورت حل میشه.


    sahar_gol سپاسگزاری کرده است.





  7. #7
    نام حقيقي: سحر خاكپور

    عضو عادی
    تاریخ عضویت
    Jun 2010
    محل سکونت
    0098
    نوشته
    324
    سپاسگزاری شده
    62
    سپاسگزاری کرده
    302
    سلام
    ببخشید من این مدت مسافرت بودم.
    ممنون از همه کمک ها و راهنمایی هایی که میکنید.

    interface fas0/2
    ip access-group 102 out

    اینو نوشتم جواب نداد.
    زیر حرف اول ip ارور میزاره.

    الان دارم تو packet tracer نسخه 5.2 آزمایش میکنم.
    با سوئیچ 2960 و 3560 هردو تست کردم نشد.



  8. #8
    نام حقيقي: Mohammad Moghaddas

    عضو عادی شناسه تصویری Moghaddas
    تاریخ عضویت
    Jan 2010
    محل سکونت
    Tehran
    نوشته
    111
    سپاسگزاری شده
    61
    سپاسگزاری کرده
    20
    Packet Tracer این دستورات رو ساپورت نمیکنه. باید روی سوئیچ واقع انجام بدین


    sahar_gol سپاسگزاری کرده است.

  9. #9
    نام حقيقي: Ali Afzalan

    مدیر بخش Cisco شناسه تصویری aliafzalan
    تاریخ عضویت
    Apr 2009
    محل سکونت
    Tehran
    نوشته
    2,086
    سپاسگزاری شده
    2556
    سپاسگزاری کرده
    2059
    همونطور که آقای مقدس گفتند روی packet tracer حساب نکنید.
    ولی روی 2960 و 3560 جواب میده.
    در ضمن ACL را هم باید روی in بنویسید و نه out
    deny tcp any any eq 80
    permit ip any any


    sahar_gol سپاسگزاری کرده است.

  10. #10
    نام حقيقي: سحر خاكپور

    عضو عادی
    تاریخ عضویت
    Jun 2010
    محل سکونت
    0098
    نوشته
    324
    سپاسگزاری شده
    62
    سپاسگزاری کرده
    302
    ممنون
    با عرض پوزش میگم احتمالاً اشتباه میکنید.
    الان دستورات زیر رو نوشتم و جواب داد.
    access-list 102 deny tcp any any
    int fas0/2
    no switchport
    ip access-group 102 out

    من روی 3560 اجرا کردم شد و روی 2960 نشد.

    فقط دو نکته برام سوال داره
    اول اینکه چجوری یه acl رو ویرایش کنم
    و دوم اینکه چجوری acl رو بنویسم که یه پورت خاص نرم افزاری بسته بشه. مثلاً ننویسم tcp ، بتونم پورت به فرض مثال 21 یا 95 رو ببندم.

    با تشکر



  11. #11
    نام حقيقي: Mohammad Moghaddas

    عضو عادی شناسه تصویری Moghaddas
    تاریخ عضویت
    Jan 2010
    محل سکونت
    Tehran
    نوشته
    111
    سپاسگزاری شده
    61
    سپاسگزاری کرده
    20
    بله درسته. علت اینکه جناب فضلان و بنده گفتیم نمیشه چون این نرم افزار باگ زیاد داره و از ccna به بعد 80% کامندهای مورد نیاز رو ساپورت نمیکنه. گاهی هم یکاری رو که نباید انجام بده خودش انجام میده
    روی 2960 به علت اینکه پورتها فقط در لایه2 کار میکنن.
    باید در ACL از eq استفاده کنید


    ویرایش توسط Moghaddas : 2011-04-02 در ساعت 08:19 PM
    sahar_gol سپاسگزاری کرده است.

  12. #12
    نام حقيقي: سحر خاكپور

    عضو عادی
    تاریخ عضویت
    Jun 2010
    محل سکونت
    0098
    نوشته
    324
    سپاسگزاری شده
    62
    سپاسگزاری کرده
    302
    پیشنهاد شما برای شبیه ساز چیه ؟
    اگه ممکنه یه منبع آموزشی هم برای شبیه سازی که معرفی میکنید بفرمایید.

    اگه من از eq استفاده کنم میتونم پورت عددی مورد نظرم رو ببندم ؟ حتی اگه سوئیچ لایه 3 باشه بازم میشه ؟







  13. #13
    نام حقيقي: Mohammad Moghaddas

    عضو عادی شناسه تصویری Moghaddas
    تاریخ عضویت
    Jan 2010
    محل سکونت
    Tehran
    نوشته
    111
    سپاسگزاری شده
    61
    سپاسگزاری کرده
    20
    متاسفانه برای سوئیچ هیچ شبیه سازی بهتر از Packet Tracer هنوز ساخته نشده اما برای روتر از GNS3 میتونین استفاده کنین که آمورش هم توی همین فروم زیاده و فقط کافیه یک سرچ بکنین.

    با استفاده از tcp و پس از مشخص کردن آدرس و wildcard با استفاده از eq میتونین دقیقا روی یک پورت رو ببندین. اگه ? بزنین گزینه های دیگه ای هم وجود داره مثل range یا ge یا le که میتونین یک رنج یا پورتهای بزرگنر/کوچکتر مساوی یک پورت رو حتی مشخص کنین



  14. #14
    نام حقيقي: Mohammad

    عضو ویژه شناسه تصویری th95
    تاریخ عضویت
    Sep 2008
    نوشته
    4,263
    سپاسگزاری شده
    5754
    سپاسگزاری کرده
    2674
    نوشته های وبلاگ
    20
    حتی اگه سوئیچ لایه 3 باشه بازم میشه ؟
    ؟؟؟؟؟؟؟؟؟؟

    این چیکار به بحث داشت
    شما با eq، neq gt و .. همه کار میتونی بکنی



  15. #15
    نام حقيقي: Ali Afzalan

    مدیر بخش Cisco شناسه تصویری aliafzalan
    تاریخ عضویت
    Apr 2009
    محل سکونت
    Tehran
    نوشته
    2,086
    سپاسگزاری شده
    2556
    سپاسگزاری کرده
    2059
    نقل قول نوشته اصلی توسط sahar_gol نمایش پست ها
    ممنون
    با عرض پوزش میگم احتمالاً اشتباه میکنید.
    الان دستورات زیر رو نوشتم و جواب داد.
    access-list 102 deny tcp any any
    int fas0/2
    no switchport
    ip access-group 102 out

    من روی 3560 اجرا کردم شد و روی 2960 نشد.
    بله، این دستورات روی 3560 جواب میده ولی روی 2960 کار نمیکنه.
    دلیل اینکه روی 3560 هم جواب داده اینه که شما پورت را لایه 3 کانفیگ کردید (no switchport)، ولی اگر که پورت لایه 2 بود این acl جواب نمیداد، چون توی پورت لایه 2 نمیشه acl رو روی خروجی قرار داد.
    حالا صرفنظر از همه این موارد باز بهتره که شما ACL را روی ورودی بنویسید.
    چرا؟ چون اگه روی خروجی پورت باشه، ترافیک کاربر تا اینترنت میره و بعد موقع برگشتن جلوش گرفته میشه.
    ولی اگر که acl روی in باشه، همون اول جلوش گرفته میشه و اصلا ترافیک از سوییچ خارج هم نمیشه.



صفحه 1 از 2 1 2 آخرینآخرین

کلمات کلیدی در جستجوها:

محدودیت روی vlan

access list extended چند پروتکل

پروتوکول های rotable

بستن پورت TELNET با استفاده از یک ACCESS LIST EXTENDED

بستن چند پورت روی سیسکو

دستور بستن پورت icmp در cissco

بستن telnet با acl

کانفیک سوئیچ 2960 دستور reng

دستور no switch port

آموزش بستن پورت tellnet

دادن ip gig به سوئیچ 2960

بستن پورت سوئیچ 2960

بستن پورت سوئیچ

بستن پورت ها در سیسکو

بستن پورت از طریق access list

روتر 3560 لایه چند؟

بستن پورت روي سوييچ cisco

نحوه نوشتن access list بر روی سوئیچ

دلیل بستن پروتکل ها

طریقه بستن vlan سوئیچ

ﺑﺴﺘﻦ پورت سوئیچ

قرار دادن اکسس لیست بر روی اترنت

آموزش access list extended در gns3

دستور سیسکو نمایش پورت باز در اکسس لیست

محدودیت اینترنت در سوئیچ2960

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •