نمایش نتایج: از شماره 1 تا 2 از مجموع 2
سپاس ها 1سپاس

موضوع: مشکل در DNAT

  
  1. #1
    نام حقيقي: مرتضی جامی

    عضو غیر فعال شناسه تصویری jooya
    تاریخ عضویت
    Jul 2005
    محل سکونت
    اصفهان
    نوشته
    77
    سپاسگزاری شده
    15
    سپاسگزاری کرده
    23

    مشکل در DNAT

    سلام
    اساتید محترم ما یک وب سرور داریم با آدرس 192.168.100.9 که در شبکه داخلی روی پورت 80 به آن دسترسی داریم
    ولی می خواهیم کاربران اینترنت هم بتوانند به آن دسترسی پیدا کنند البته با استفاده از DNAT
    کانفیگ زیر را ملاحظه بفرمایید کجایش ایراد دارد که وب سرور ما از طریق اینترنت قابل دسترس نیست
    البته 188.120.20.3 ، ping می شود

    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname router
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    logging buffered 51200 warnings
    enable secret 5 $1$f1EM$iBA6O5QtVEV6I9E31Vf7d/
    !
    no aaa new-model
    !
    dot11 syslog
    no ip source-route
    !
    !
    ip cef
    !
    !
    ip name-server 4.2.2.4
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    vpdn enable
    !
    vpdn-group test
    ! Default PPTP VPDN group
    accept-dialin
    protocol pptp
    virtual-template 1
    !
    !
    voice-card 0
    !
    !
    username admin privilege 15 password 7 124E04131F0202
    archive
    log config
    hidekeys
    !
    !
    interface FastEthernet0/0
    description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$
    ip address 192.168.100.5 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 188.120.20.3 255.255.255.248
    ip nat outside
    ip virtual-reassembly
    ip access-group 8 in
    duplex auto
    speed auto
    !
    interface Virtual-Template1
    ip unnumbered FastEthernet0/0
    ip nat inside
    ip virtual-reassembly
    peer default ip address pool jami
    ppp encrypt mppe auto required
    ppp authentication ms-chap ms-chap-v2
    !
    ip local pool jami 10.0.100.1 10.0.100.200
    ip default-gateway 188.120.20.1
    no ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 188.120.20.1
    no ip http server
    ip http authentication local
    no ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    !
    ip nat pool test2 188.120.20.2 188.120.20.2 prefix-length 29
    ip nat inside source list 8 pool test2 overload
    ip nat inside source static tcp 192.168.100.9 80 interface FastEthernet0/1 8080
    !
    access-list 8 permit 10.0.100.0 0.0.0.255
    access-list 8 permit 192.168.100.0 0.0.0.255
    access-list 8 permit 188.120.20.0 0.0.0.255
    access-list 8 permit any
    !
    !
    control-plane
    !
    mgcp fax t38 ecm
    !
    !
    line con 0
    password 7 0605
    line aux 0
    line vty 0 4
    access-class 23 in
    privilege level 15
    password 7 1213041A1B
    login
    transport input telnet
    line vty 5 15
    access-class 23 in
    privilege level 15
    login
    transport input telnet
    !
    scheduler allocate 20000 1000
    end




    موضوعات مشابه:
    باندازه آرزویت همت کن، یا باندازه همتت آرزو





  2. #2
    نام حقيقي: كاظم

    خواننده
    تاریخ عضویت
    Jul 2009
    محل سکونت
    Tehran
    نوشته
    259
    سپاسگزاری شده
    210
    سپاسگزاری کرده
    30
    دوست عزیز

    ip nat inside source static tcp 192.168.100.9 80 interface FastEthernet0/1 8080

    شما در خط بالا گفتید اگر روی 8080 ترافیک از اینترنت اومد برات Forward کنه به 192.168.100.9:80

    با 8080 از روی اینترنت تست کردی ؟



    Port Address Redirection یا PAR چیست ؟


    یه فکری هم به حال این Pool کنید

    ip nat pool test2 188.120.20.2 188.120.20.2 prefix-length 29

    اول و آخرش رو یکی در نظر گرفتید.

    اگر IP اضافه دارید می تونید برای Web Server یک IP جدا درنظر بگیرید. (البته با تک IP فعلی هم شدنی هست)


    ویرایش توسط kazem_m : 2010-10-21 در ساعت 05:28 PM
    jooya سپاسگزاری کرده است.
    ...Life is too short to wake up with regrets. Love the people who treat you right Forget about ...

کلمات کلیدی در جستجوها:

dnat چیست

dnat

اینترنت نداشتن کلاینتip virtual reassembly چیستمشكل در dnatمشکل در dnatdnat چيستip virtual-reassembly چیست ؟

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •