نمایش نتایج: از شماره 1 تا 5 از مجموع 5
سپاس ها 5سپاس

موضوع: مشکل با دو لینک WAN در cisco 1841

  
  1. #1
    نام حقيقي: مسعود

    خواننده
    تاریخ عضویت
    Jan 2010
    محل سکونت
    تهران
    نوشته
    65
    سپاسگزاری شده
    29
    سپاسگزاری کرده
    85

    مشکل با دو لینک WAN در cisco 1841

    درود بر اهالی انجمن

    اساتید بزرگوار ،

    سناریو من به این صورت هست که دولینک ارتباطی دارم تا مقصد و بنا به شرایط مجبورم روی هر دو لینک ارتباطی از
    Nat استفاده کنم. هدفم اینه که دو لینک Fail over هم باشند. مشکلات زیادی برام با دو دستور Nat ایجاد شد.

    بعضی هاشو تونستم حل کنم. مثلا فهمیدم که باید از Route map مطابق این Doc استفاده کنم.

    IOS NAT Load-Balancing for Two ISP Connections - Cisco Systems

    اما هنوز یه مشکل بزرگ پا برجاست. اگر یکی از لینک ها رو قطع کنم (از دستور IP Slaهم برای کنترل استفاده کردم) به طور خود کار به لحاظ Route table لینک قطع شده خارج می شه و لینک فعال با متریک بالا تر جایگزین می شه ولی روی Link جایگزین Nat عمل نمی کنه. یعنی وقتی show ip nat translation می گیرم می بینم هنوز داره Packet ها رو روی link قطع شده برای Nat می فرسته. Routing اصلاح شده یعنی لینک فعالو به عنوان دیفالت روت نشون می ده ولی Nat هنوز داره روی لینک غیر فعال کار می کنه. دستی Table مربوط به Nat رو پاک کردم حتی Schedule هم گذاشتم که پاک شه (Clear ip nat trans *) ولی باز هم جواب نداد. فقط وقتی اینتر فیس به صورت فیزیکی Down می شه و بعدش هم دستی clear ip nat انجام می دم بهم جواب می ده یعنی هم route درست کار می کنه و هم NAT


    آیا برای شما پیش نیومده که روی دو لینک IP nat outside داشته باشید و سمت Lan هم Ip nat inside ؟

    نمی دونم چرا با دو تا link روی Nat قاطی می کنه ؟

    من کانفیگم رو میگذارم. همونطور که می بینید یه لینک بر فرض wireless دارم و یه interface Dial به صورت Backup

    هر جا رو بد توضیح دادم بگید. ممنون می شم اگر تجربه مشابهی روی Cisco با دو Nat دارید راهنمایی کنید.

    از اینکه وقت میگذارید ممنونم.





    1841-2AM#show runn
    1841-2AM#show running-config
    Building configuration...
    Current configuration : 3694 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname 1841-2AM
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    resource policy
    !
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    ip sla monitor 1
    type echo protocol ipIcmpEcho 10.1.1.1 source-interface FastEthernet0/1
    timeout 4000
    frequency 10
    ip sla monitor schedule 1 life forever start-time now
    login block-for 120 attempts 6 within 300
    login delay 5
    login on-failure log
    !
    chat-script async "" "AT" ok "atdt\t" TIMEOUT 60 CONNECT \c
    !
    !
    username cisco privilege 15 password 7 030752180500
    username test password 7 051F031C35
    archive
    log config
    hidekeys
    !
    !
    track 1 rtr 1 reachability
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.10.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    description WAN
    ip address 192.168.70.2 255.255.255.0
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    interface Async1
    no ip address
    ip mask-reply
    ip directed-broadcast
    encapsulation ppp
    no ip route-cache cef
    no ip route-cache
    dialer in-band
    dialer pool-member 1
    async mode dedicated
    !
    interface Async0/0/0
    no ip address
    ip mask-reply
    ip directed-broadcast
    encapsulation ppp
    no ip route-cache cef
    shutdown
    dialer in-band
    dialer-group 1
    async mode dedicated
    !
    interface Async0/0/1
    no ip address
    ip mask-reply
    ip directed-broadcast
    ip virtual-reassembly
    encapsulation ppp
    no ip route-cache cef
    dialer in-band
    dialer pool-member 1
    async mode dedicated
    !
    interface Dialer0
    ip address 172.16.31.22 255.255.255.0
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    no ip route-cache cef
    no ip route-cache
    dialer pool 1
    dialer idle-timeout 30
    dialer string xxxxxxxxxx
    dialer-group 1
    ppp authentication pap callin
    ppp pap sent-username test password 7 0835495D1D
    !
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/1 track 1
    ip route 0.0.0.0 0.0.0.0 Dialer0 200
    !
    ip http server
    ip http access-class 10
    no ip http secure-server
    ip nat translation timeout 10
    ip nat translation tcp-timeout 10
    ip nat translation udp-timeout 10
    ip nat translation finrst-timeout 10
    ip nat translation syn-timeout 10
    ip nat translation dns-timeout 10
    ip nat translation routemap-entry-timeout 10
    ip nat translation icmp-timeout 10
    ip nat inside source route-map dialup interface Dialer0 overload
    ip nat inside source route-map mpls1 interface FastEthernet0/1 overload
    !
    ip access-list standard nat1
    permit 192.168.10.0 0.0.0.255
    ip access-list standard nat2
    permit 192.168.10.0 0.0.0.255
    !
    !
    kron occurrence masud in 1 recurring
    policy-list reza
    !
    kron policy-list reza
    cli clear ip nat translation *
    !
    dialer-list 1 protocol ip permit
    route-map dialup permit 10
    match ip address nat1
    match interface Dialer0
    !
    route-map mpls1 permit 10
    match ip address nat2
    match interface FastEthernet0/1
    !
    !
    !
    control-plane
    !
    !
    line con 0
    exec-timeout 30 0
    line aux 0
    modem InOut
    modem autoconfigure discovery
    autoselect ppp
    stopbits 1
    speed 115200
    flowcontrol hardware
    line 0/0/0
    modem InOut
    modem autoconfigure discovery
    transport input all
    autoselect ppp
    stopbits 1
    speed 115200
    flowcontrol hardware
    line 0/0/1
    modem InOut
    modem autoconfigure discovery
    autoselect ppp
    stopbits 1
    speed 115200
    flowcontrol hardware
    line vty 0 4
    exec-timeout 30 0
    login local
    transport input telnet
    line vty 5 10
    access-class 10 in
    exec-timeout 30 0
    password 7 105E080B161E1305
    login
    transport input telnet
    line vty 11 15
    access-class 10 in
    exec-timeout 30 0
    login
    transport input telnet
    !
    scheduler allocate 20000 1000
    end




    موضوعات مشابه:
    ویرایش توسط masud : 2010-05-08 در ساعت 11:08 PM





  2. #2
    نام حقيقي: مسعود

    خواننده
    تاریخ عضویت
    Jan 2010
    محل سکونت
    تهران
    نوشته
    65
    سپاسگزاری شده
    29
    سپاسگزاری کرده
    85
    متاسفانه من توی یه شرایط خاص گیر کردم. به این دلیل که منظور من از WAN اینترنت نیست.

    من از سمت مرکز یه IP دارم (سرور مرکز )و دو لینک از مرکز به سمت دفاتر. مشکل اینجاست که اگر یه IP خاص داشته باشید مسیر Nat شدنش توی روتر Cache می شه ! (یعنی اگر یه GW قطع بشه درک نمی کنه روی اون دیگه Nat نکنه) همه چی رو پاک کردم. (Clear ip nat translation *)
    ولی نشد. جدول Route کلا درست کار می کنه و در لحظه Update می شه ولی Nat رو روی همون مسیری که از اول می انداخته در نظر می گیره و تغییرش نمی ده. اگر یه IP جدید رو Ping کنم (که تا اون زمان ازش استفاده نکرده باشم) روی مسیر درست Nat می کنه و جواب می ده.

    اگه اینترنت باشه شما n تا IP دارین و مشکل زیادی از این بابت احساس نمی کنید ولی من یه IP دارم و Cache شدن Nat اش برام دردسر سازه.

    باز هم از توجه همگی سپاس گذارم. منتظر راهنمایی های شما هستم. حتی در حد چند کلمه کلیدی

    با سپاس



  3. #3
    نام حقيقي: Hootii

    مسدود شده
    تاریخ عضویت
    Feb 2010
    محل سکونت
    تهران
    نوشته
    146
    سپاسگزاری شده
    70
    سپاسگزاری کرده
    29
    نقل قول نوشته اصلی توسط masud نمایش پست ها
    متاسفانه من توی یه شرایط خاص گیر کردم. به این دلیل که منظور من از WAN اینترنت نیست.

    من از سمت مرکز یه IP دارم (سرور مرکز )و دو لینک از مرکز به سمت دفاتر. مشکل اینجاست که اگر یه IP خاص داشته باشید مسیر Nat شدنش توی روتر Cache می شه ! (یعنی اگر یه GW قطع بشه درک نمی کنه روی اون دیگه Nat نکنه) همه چی رو پاک کردم. (Clear ip nat translation *)
    ولی نشد. جدول Route کلا درست کار می کنه و در لحظه Update می شه ولی Nat رو روی همون مسیری که از اول می انداخته در نظر می گیره و تغییرش نمی ده. اگر یه IP جدید رو Ping کنم (که تا اون زمان ازش استفاده نکرده باشم) روی مسیر درست Nat می کنه و جواب می ده.

    اگه اینترنت باشه شما n تا IP دارین و مشکل زیادی از این بابت احساس نمی کنید ولی من یه IP دارم و Cache شدن Nat اش برام دردسر سازه.

    باز هم از توجه همگی سپاس گذارم. منتظر راهنمایی های شما هستم. حتی در حد چند کلمه کلیدی

    با سپاس
    -----------------------------------------------------------------


    منظورتونو خیلی نفهمیدم ..... آیا شما میخواین از یک نقطه همزمان و از طریق دو لینک به یک نقطه دیگه وصل باشید ؟؟ یعنی یه چیزی مثل سایت تو سایت vpn ؟



  4. #4
    نام حقيقي: مسعود

    خواننده
    تاریخ عضویت
    Jan 2010
    محل سکونت
    تهران
    نوشته
    65
    سپاسگزاری شده
    29
    سپاسگزاری کرده
    85
    با تشکر از تمام دوستانی که روی این موضوع وقت گذاشتند. مشکلم حل شد.

    نقل قول نوشته اصلی توسط Hootan نمایش پست ها
    -----------------------------------------------------------------
    منظورتونو خیلی نفهمیدم ..... آیا شما میخواین از یک نقطه همزمان و از طریق دو لینک به یک نقطه دیگه وصل باشید ؟؟
    بله آقا هوتن. شما درست در نظر گرفتید.

    اما راه حل مشکل : این بودکه Cahce روتر رو خالی کردم وبرای Nat هم Time out گذاشتم ومشکل خوشبختانه تا این لحظه حل شده. اینا رو هم تونستم باDebug کردن و دستورات مانیتورینگ پیدا کنم.



  5. #5
    نام حقيقي: مسعود

    خواننده
    تاریخ عضویت
    Jan 2010
    محل سکونت
    تهران
    نوشته
    65
    سپاسگزاری شده
    29
    سپاسگزاری کرده
    85
    دوستان عزیز

    اگر روتر Cisco دارید و دو لینک WAN می توانید از قابلیت موجود روی خود روتر جهت Fail over و Load Balancing استفاده کنید. من مشکلم حل شد. گفتم قدری بیشتر توضیح بدم که اگر برای دوستی مورد مشابهی پیش اومد بتونه از این مطالب استفاده کنه.

    اولش برای خودم این مشکل پیش اومد که مجبور بودم از دو IP nat outside روی دو اینترفیس WAN استفاده کنم و از دستور

    IP nat inside source list nat1 intwan1 overload
    IP nat inside source list nat1 intwan2 overload

    جهت Nat استفاده کردم. ولی جواب نداد. توی سیسکو که گشتم این مطب و چندین مطلب و Forum مشابه تاکید کردند که برای دو NAt باید از Route-map استفاده شود.

    IOS NAT Load-Balancing for Two ISP Connections - Cisco Systems

    در نهایت با Route map مشکل حل شد. IP sla واقعا دستور جالبیه و به محض Fail شدن لینک روتینگ رو تغییر می ده و به این ترتیب هیچ وقت Nat شما از کار نمی یفته.

    امیدوارم براتون مفید بوده باشه.

    موفق و پیروز باشید


    nkm، SADEGH65، ARM و 2 نفر دیگر سپاسگزاری کرده‌اند.

کلمات کلیدی در جستجوها:

route map در سیسکو

http://forum.persiannetworks.com/f63/t34934.html

مشکل route cisco

ايجاد لينك failover در سيسكو

لينك failover در سيسكو

اینترنت بروی 1841

دو لینک سیسکو

ترتیب خوانده شدن ip route

cisco load balance با دو سورس

match ip route-map دستور سیسکو

دستورات 1841

1841

مشکل transit روتر 1841

route map cisco با

load balancing در روترcisco براي

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •