صفحه 1 از 2 1 2 آخرینآخرین
نمایش نتایج: از شماره 1 تا 15 از مجموع 23

موضوع: تنظیم ارتباط pos با روتر

  
  1. #1
    نام حقيقي: emran

    عضو غیر فعال
    تاریخ عضویت
    Aug 2009
    محل سکونت
    tehran
    نوشته
    15
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    0

    تنظیم ارتباط pos با روتر

    سلام خدمت تمام دوستان

    من میخوام تماس به وسیله یک دستگاه کارتخوان با روتر رو تنظیم کنم روترم 3660 هست . config فعلی روترو نوشتم . لطفا بگین درست است یا نه ؟ و چطوری باید تو سیستمم چکش کنم که ok شده یا نه

    راستی خط ورودی به روترم یک خط ایوان که از سانترال شرکت اومده و به ماژولNM16 روتر وصل شده .

    ممنون میشم اگر راهنمایی کنید .

    aaa new-model
    !
    !
    aaa authentication login NO-TAC line
    aaa authentication ppp default local group tacacs+
    aaa authorization network default if-authenticated
    aaa accounting nested
    aaa accounting update newinfo
    aaa accounting exec default start-stop group tacacs+
    aaa accounting network default start-stop group tacacs+
    aaa session-id common
    enable secret 5 $1$Fj2w$0myqK61BxTqN9wSeqQTSq0
    ip subnet-zero
    ip rcmd rsh-enable
    ip rcmd remote-host system 192.168.50.252 system enable
    ip wccp version 1
    ip cef
    !
    !
    no ip domain-lookup
    ip name-server 192.168.50.72
    !
    !
    !
    !
    interface Loopback0
    no ip address
    !
    interface FastEthernet0/0
    ip address 192.168.50.252 255.255.255.0
    speed 100
    full-duplex
    interface Group-Async1
    ip unnumbered FastEthernet0/0
    encapsulation ppp
    ip tcp header-compression passive
    ip policy route-map ptt
    async dynamic address
    async dynamic routing
    async mode interactive
    peer default ip address pool dialup
    ppp authentication chap pap
    group-range 33 48
    !
    interface Group-Async2
    ip unnumbered FastEthernet0/0
    encapsulation ppp
    ip tcp header-compression passive
    ip policy route-map ptt
    async dynamic address
    async dynamic routing
    async mode interactive
    peer default ip address pool dialup
    ppp authentication chap pap
    group-range 65 80
    ip classless
    no ip http server
    ip pim bidir-enable
    !
    !
    tacacs-server host 192.168.50.72
    tacacs-server timeout 20
    snmp-server community public RW 15
    !
    line con 0
    password 7 104D000A0618
    logging synchronous
    line 33
    exec-timeout 0 0
    timeout login response 0
    modem Dialin
    modem autoconfigure discovery
    no exec
    transport input all
    autoselect during-login
    autoselect ppp
    stopbits 1
    flowcontrol hardware
    line 34 48
    exec-timeout 0 0
    timeout login response 0
    modem Dialin
    modem autoconfigure discovery
    transport input all
    autoselect during-login
    autoselect ppp
    stopbits 1
    flowcontrol hardware
    line 65 80
    exec-timeout 0 0
    timeout login response 0
    modem Dialin
    modem autoconfigure discovery
    transport input all
    autoselect during-login
    autoselect ppp
    stopbits 1
    flowcontrol hardware
    line aux 0
    line vty 0 4
    login authentication NO-TAC



    موضوعات مشابه:





  2. #2
    نام حقيقي: emran

    عضو غیر فعال
    تاریخ عضویت
    Aug 2009
    محل سکونت
    tehran
    نوشته
    15
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    0
    اقا هیچکس نیست به داد ما برسه؟؟؟؟؟؟؟؟؟؟؟؟؟



  3. #3
    نام حقيقي: Ali Afzalan

    مدیر بخش Cisco شناسه تصویری aliafzalan
    تاریخ عضویت
    Apr 2009
    محل سکونت
    Tehran
    نوشته
    2,086
    سپاسگزاری شده
    2556
    سپاسگزاری کرده
    2059
    سلام
    مشکل کجاست؟ تست کردید؟ وصل نمیشه؟ پیغام خطاش چیه؟
    اول با یک کامپیوتر (dial-up) بهش وصل بشید، ببینید Authenticate میشه؟؟ IP میگیره؟؟ سوئیچ بانکی ping میشه؟



  4. #4
    نام حقيقي: emran

    عضو غیر فعال
    تاریخ عضویت
    Aug 2009
    محل سکونت
    tehran
    نوشته
    15
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    0
    آقا ممنون از راهنمایی ولی میشه بگین چطوری باید چکش کنم

    زیاد وارد نیستم

    این config رو هم با هزار بدبختی نوشتم

    پیرو صحبت شما توضیح بدم که فعلا سوئیچ نداریم و فقط قرارهست یک دستگاه کارتخوان از طریق خط dialup به وسیله روتر وصل بشه به یک سرور که به وسیله نرم افزار( موجود است ) مربوطه بشه اطلاعات به کارتخوان فرستاد یا دریافت کرد
    نرم افزارم طوری هست که میتونه به وسیله سوکت اماده دریافت باشه
    مشکل من این که چطوری باید این ارتباط رو برقرارکنم و روتر اطلاعات منو بعد از شناسایی چطوری به اون ip و port میفرسته .

    این عملیات در حال حاضر انجام میشه و فقط به جای روتر چنتا مودم قرارداره که خطوط تلفن بهشون وصل شده و من میخوام مودمها رو حذف کنم و اطلاعات ورودیمو از طریق روتر در شبکه روی ip سرورم دریافت کنم .

    آقا سرتو درد آوردم .ممنون میشم اگر راهنماییم کنی .



  5. #5
    نام حقيقي: Ali Afzalan

    مدیر بخش Cisco شناسه تصویری aliafzalan
    تاریخ عضویت
    Apr 2009
    محل سکونت
    Tehran
    نوشته
    2,086
    سپاسگزاری شده
    2556
    سپاسگزاری کرده
    2059
    سلام
    خب فعلا برای تست یک POS بیا چند تا کار انجام بده:
    1. یک یوزر پسورد local روی روتر تعریف کن.
    2. یه مودم به پورت aux وصل کن و اون رو کانفیکش کن (کانفیگش مثل همون line 33 که زدی، دستور login local رو هم بهش اضافه کن)
    در مورد اینکه گفتی روتر چطوری اطلاعات رو به اون ip و پورت میفرسته هم اینکه شما IP و پورت رو روی POS تنظیم میکنی، وقتی که
    دیتا به روتر می فرسته ، روتر هم با توجه به اینکه چطوری کانفیگش کردی ( Route بشه یا NAT ) اطلاعات رو به سرور می فرسته.
    راستی اون تست بالا رو هم که گفتم حتما انجام بده.
    اگه کانفیگ PPP درست باشه باید سیستمت IP بگیره و سرور رو ping کنی.



  6. #6
    نام حقيقي: emran

    عضو غیر فعال
    تاریخ عضویت
    Aug 2009
    محل سکونت
    tehran
    نوشته
    15
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    0
    سلام
    ممنون از ali afzalan
    من کابل اتصال مودم به روتر رو ندارم
    خط تلفن مستقیم به روتر وصل شده
    با تلفن معمولی با روتر که تماس میگیرم صدای مودم میاد
    و وقتی روتر رو ping میکنم ok میده و توسط نرم افزار wireshark وقتی sniff میکنم
    موقع login کردن یا ping کردن روتر یک سری packet که رفته و آومده نشونم میده

    ولی وقتی با pos به روتر زنگ میزنم خط رو اشغال میکنه و خط اشغال میمونه

    آیا راه دیگه ای داره من انجام بدم ؟؟؟

    راستی من خیلی گیرم و باید تو این یکی دو روز این روتر و تنظیم کنم







  7. #7
    نام حقيقي: Ali Afzalan

    مدیر بخش Cisco شناسه تصویری aliafzalan
    تاریخ عضویت
    Apr 2009
    محل سکونت
    Tehran
    نوشته
    2,086
    سپاسگزاری شده
    2556
    سپاسگزاری کرده
    2059
    سلام
    خب روتر ping میشه، سرور چطور ؟؟ سرور هم میتونی ping کنی ؟؟
    اگه ping به سرور داری، با همون سیستم روی سرور telnet روی پورت مورد نظر کن.
    مثلا اگه pos باید به سرور 10.1.1.1 روی پورت 2000 وصل بشه بزن : telnet 10.1.1.1 2000
    اگه ok بود یعنی تنظیمات شبکه ok هست و مشکل از سمت سرور هست.



  8. #8
    نام حقيقي: emran

    عضو غیر فعال
    تاریخ عضویت
    Aug 2009
    محل سکونت
    tehran
    نوشته
    15
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    0
    سلام
    من از روتر با سرورم telnet کردم با ip سرور و شماره پورت پیغام زیر رو میده
    [Connection to *.*.*.* closed by foreign host]

    اینو بگم که من تنظیمی روی روتر برای ارسال به پروت خاص نکردم آیا لازمه ؟؟؟
    روتر بسته رو چطوری به پورت خاص من می فرسته ؟
    موقع telnet کردن از روتر شماره پورتی رو نوشتم که نرم افزارم روی سرور از طریق اون پورت آماده در یافت بسته هست آیا درسته ؟؟



  9. #9
    نام حقيقي: Ali Afzalan

    مدیر بخش Cisco شناسه تصویری aliafzalan
    تاریخ عضویت
    Apr 2009
    محل سکونت
    Tehran
    نوشته
    2,086
    سپاسگزاری شده
    2556
    سپاسگزاری کرده
    2059
    سلام
    خب پس اون پورت روی سرور باز نشده، روی سرور بزنید netstat -a ببینید اون پورتی رو که شما تعریف کردید در حالت listen هست یا نه؟
    دوست عزیز به شما پیشنهاد میکنم در مورد روتر و روتینگ یکمی مطالعه کنید، چون هم دنیاتون رو میخرید و هم آخرتتون رو !
    راستی شما نگفتید که آیا از روتر میتونید سرور رو ping کنید یا نه ؟؟
    با یه سیستم با dial-up به روتر وصل بشید ببینید سرور ping میشه ؟


    ویرایش توسط aliafzalan : 2009-11-18 در ساعت 11:20 AM

  10. #10
    نام حقيقي: Ali Afzalan

    مدیر بخش Cisco شناسه تصویری aliafzalan
    تاریخ عضویت
    Apr 2009
    محل سکونت
    Tehran
    نوشته
    2,086
    سپاسگزاری شده
    2556
    سپاسگزاری کرده
    2059
    نقل قول نوشته اصلی توسط emran نمایش پست ها

    روتر بسته رو چطوری به پورت خاص من می فرسته ؟
    روتر بسته رو به پورت شما نمی فرسته، بلکه بسته رو به سیستم مقصد می فرسته، این سیستم مقصد هست که اگه اون پورتش باز باشه، بسته رو تحویل پورت میده.



  11. #11
    نام حقيقي: emran

    عضو غیر فعال
    تاریخ عضویت
    Aug 2009
    محل سکونت
    tehran
    نوشته
    15
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    0
    netstat رو زدم پورت در حالت listen بود
    از روتر میتونم سیستم و ping کنم ولی با یک سیستم دیگه به صورت dialup نتونستم به روتر telnet کنم .



  12. #12
    نام حقيقي: emran

    عضو غیر فعال
    تاریخ عضویت
    Aug 2009
    محل سکونت
    tehran
    نوشته
    15
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    0
    با تلفن معمولی هم شماره وصل شده به روتر رو میگیرم صدای مودم نمیاد
    فکر کنم تنظیمات line م مشکل داره میشه چکش کنید .
    interface FastEthernet0/0
    ip address 192.168.*.* 255.255.255.0
    speed 100
    full-duplex
    !
    interface Group-Async1
    ip unnumbered FastEthernet0/0
    encapsulation ppp
    ip tcp header-compression passive
    no ip mroute-cache
    ip policy route-map ptt
    async dynamic address
    async dynamic routing
    async mode interactive
    peer default ip address pool dialup
    ppp authentication chap pap
    group-range 33 48

    ip local pool dialin_pool 192.168.50.1 192.168.50.250
    ip classless
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
    no ip http server
    ip pim bidir-enable

    line con 0
    logging synchronous
    login local
    line 33 48
    timeout login response 0
    modem Dialin
    modem autoconfigure discovery
    autocommand ppp
    transport input all
    autoselect during-login
    autoselect ppp
    stopbits 1
    flowcontrol hardware
    flowcontrol hardware
    line aux 0
    line vty 0 4
    login







  13. #13
    نام حقيقي: emran

    عضو غیر فعال
    تاریخ عضویت
    Aug 2009
    محل سکونت
    tehran
    نوشته
    15
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    0
    وقتی دستور telnet رو روی روتر میزنم با پورت مربوط به برنامم هیچ اتفاقی در روتر نمی افته و بعد از مدتی پیغام زیر رو میده

    [Connection to 192.168.50.72 closed by foreign host]

    ؟؟؟؟؟؟



  14. #14
    نام حقيقي: Ali Afzalan

    مدیر بخش Cisco شناسه تصویری aliafzalan
    تاریخ عضویت
    Apr 2009
    محل سکونت
    Tehran
    نوشته
    2,086
    سپاسگزاری شده
    2556
    سپاسگزاری کرده
    2059
    لطفا به سوالهای زیر پاسخ دهید:
    1. وقتی با یک کامپوتر از طریق dial-up به روتر وصل می شوید، آیا سیستم IP میگیرد؟؟ ( IP ذکر شود)
    2. روتر ping می شود؟؟
    3. سرور ping می شود؟؟



  15. #15
    نام حقيقي: Ali Afzalan

    مدیر بخش Cisco شناسه تصویری aliafzalan
    تاریخ عضویت
    Apr 2009
    محل سکونت
    Tehran
    نوشته
    2,086
    سپاسگزاری شده
    2556
    سپاسگزاری کرده
    2059
    نقل قول نوشته اصلی توسط emran نمایش پست ها
    !
    interface Group-Async1
    peer default ip address pool dialup

    ip local pool dialin_pool 192.168.50.1 192.168.50.250
    اسم این دو تا ip pool باید مشابه هم باشد (کوچک و یا بزرگ بودن حروف هم رعایت شود)
    local ip pool هم به شکل زیر تغییر بده:
    ip local pool dialup 192.168.200.10 192.168.200.50
    و اینها رو اضافه کن.
    interface Group-Async1
    ip nat inside


    interface fast 0/0
    ip nat outside

    access-list 1 permit ip 192.168.200.0 0.0.0.255

    ip nat inside source list 1 interface fast 0/0 overload

    اون تستهایی که بالا نوشم رو هم انجام بده و نتیجه رو بنویس.





صفحه 1 از 2 1 2 آخرینآخرین

کلمات کلیدی در جستجوها:

تنظیم pos

تنظیمات pos

اتصال pos به کامپیوتر

ping کامپیوتر به 878

تنظیم کردن مودم به پوز

http://forum.persiannetworks.com/f63/t29298.html

اتصال پوز به کامپیوتر

تنظیمات پوز

اتصال pos به سانترال

چگونه کارت خوان رو به سانترال وصل کنیم

نحوه ارتباط pos با سرور

تنظیمات ip دستگاههای کارت خوان

ارتباط پوز با کامپیوتر

روش وصل کردن کارت خوان به سويچ

تنظیمات هایپر ترمینال روتر در packet tracer

نحوه وارد کردن ip در دستگاه پوز

ارتباط pos با کامپیوتر

تنظیم ip دستگاه پوزنحوه اتصال پوز به کامپیوتر خطوط سانترال و اتصال دستگاه پوزارتباط دستگاه pos به کامپیوترروش وصل کردن کارتخوان به سانترالنحوه ای اتصال مودم l به دستگاه کارتخوانای پی برای دستگاه پوزتنظیم ارتباط دو روتر از طریق wds

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •