نمایش نتایج: از شماره 1 تا 12 از مجموع 12

موضوع: تنظيمات NAT

  
  1. #1
    نام حقيقي: ali

    عضو عادی
    تاریخ عضویت
    Apr 2008
    محل سکونت
    a
    نوشته
    27
    سپاسگزاری شده
    1
    سپاسگزاری کرده
    3

    تنظيمات NAT

    سلام
    من يه روتر دارم كه يه پورت شبكه اون به اينترنت وصله و يه پورت ديگش هم به شبكه من .
    من روتر رو براي NAT كردن IP هاي داخلي(192.168.100.0) به IP Valid روتر ( 95.195.48.38) تنظيم كردم .
    من دو تا سرور دارم كه بعد از روتر (داخل شبكه) قرار مي*گيرند و نياز به IP Valid دارند و اينكه از بيرون با IP Valid ديده بشن

    تنظيماتي كه من انجام دادم به شرح زير :

    interface FastEthernet0/0
    ip address 95.195.48.38 255.255.255.248
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 192.168.100.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
    !
    !
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat pool ovrld 95.195.48.38 95.195.48.38 netmask 255.255.255.248
    ip nat inside source list 3 pool ovrld overload
    !
    access-list 3 permit 192.168.100.0 0.0.0.255
    !

    لطفاً راهنمايي كنيد كه چه تنظيمي به روتر اضافه كنم.
    مرسي








  2. #2
    نام حقيقي: mehdi,soleimani

    عضو غیر فعال شناسه تصویری mehdi_1980
    تاریخ عضویت
    Jun 2007
    محل سکونت
    tehran
    نوشته
    23
    سپاسگزاری شده
    0
    سپاسگزاری کرده
    4
    من هم همین مشکل رو دارم از اساتید خواهش میکنم در این مورد توضیح دهند



  3. #3
    نام حقيقي: ali

    عضو عادی
    تاریخ عضویت
    Apr 2008
    محل سکونت
    a
    نوشته
    27
    سپاسگزاری شده
    1
    سپاسگزاری کرده
    3
    ؟



  4. #4
    نام حقيقي: Hamidreza

    عضو غیر فعال
    تاریخ عضویت
    Sep 2008
    محل سکونت
    tehran
    نوشته
    33
    سپاسگزاری شده
    4
    سپاسگزاری کرده
    3
    با سلام
    ببين عزيز شما الان فكر نكنم تو NAT كردن IP هاي شبكه داخلي مشكل داشته باشي تنها مشكلي كه داري اينه كه مي خواي سرور هات از توي اينترنت با IP Valid ديده بشن. خوب براي اين كار اين دو تا دستور رو اضافه كن
    ip nat inside source static 192.168.0.10 1.1.1.1 extendable
    ip nat inside source static 192.168.0.11 1.1.1.2 extendable
    اين دستورا با فرض اينه كه IP Invalid سرورهايي كه مي خواي از بيرون ديده بشن 10 و 11 است و IP Valideاونها رو هم خودت جايگزين كن



  5. #5
    نام حقيقي: Hamidreza

    عضو غیر فعال
    تاریخ عضویت
    Sep 2008
    محل سکونت
    tehran
    نوشته
    33
    سپاسگزاری شده
    4
    سپاسگزاری کرده
    3
    راستي يك موضوع يادم رفت شما داري كل رنج داخلي رو به بيرون NAT ميكني اگه سرورهات توي همين رنج هستن كه به مشكل ميخوري براي حل مشكلت بايد توي اون Access List كه كل رنج رو اجازه دادي به بيرون دسترسي داشته باشه اول IP Server هات رو ِ Deny كني. يادت باشه كه Deny rule بايد حتما قبل از Permit rule باشه.
    يك نكته هم بگم خارج بحث از دستور IP Access-List به جاي Access-List استفاده كن اين طوري ميتوني به هر خط ACL يك عدد نسبت بدي و بدون از نو نوشتن كل ACL اون رو ويرايش كني يا يك خط جديد به اون اضافه كني.



  6. #6
    نام حقيقي: pooya

    عضو غیر فعال
    تاریخ عضویت
    Oct 2009
    محل سکونت
    tehran
    نوشته
    12
    سپاسگزاری شده
    5
    سپاسگزاری کرده
    0
    دوست عزیز این روشی که شما گفتی، اون چیزی نیست که این بنده خدا می خواهد.
    اولا اینکه ایشان به گفته خودشان ضاهرا تنها یک ip valid دارند، بنابراین امکان server publishing به وسیله static destination nat را ندارند و همچنین اگر چندین valid ip موجود می بود ، config ای که گفته اید server publishing را انجام نمی دهد و سرور ها از سمت اینترنت قابل دسترس نخواهند بود.
    در واقع config شما تنها source destination nat را انجام میدهد.در واقع برای server publishing باید config مربوط به
    static destination nat نیز اضافه شود.که برای مثال اینگونه است :

    ip nat outside source static 1.1.1.1 192.168.0.10
    ip nat outside source static 1.1.1.2 192.168.0.11

    و ام اگر همان یک valid ip موجود باشد باید ار port forwarding استفاده کردیعنی باید شماره پورت های ایی که می خواهید بر روی سرور از بیرون قابل دسترس باشند را از روی روتر به سمت سرورهایتان forward کنید، کافی است به کانفیگ nat overload که خودتان انجام دادید این دستور اضافه شود:

    ip nat inside source static tcp 192.168.0.10 80 95.195.48.38 80 extendable

    ip nat inside source static tcp 192.168.0.11 3389 95.195.48.38 3389 extendable

    با این کار مثلا پورت 80 و 3389 بر روی دو سرور از طریق یک ip valid از بیرون قابل دسترسس خواهد بود.







  7. #7
    نام حقيقي: pooya

    عضو غیر فعال
    تاریخ عضویت
    Oct 2009
    محل سکونت
    tehran
    نوشته
    12
    سپاسگزاری شده
    5
    سپاسگزاری کرده
    0
    راستی confige مربوط به access list سر جایش است و انجام میگیرد.



  8. #8
    نام حقيقي: pooya

    عضو غیر فعال
    تاریخ عضویت
    Oct 2009
    محل سکونت
    tehran
    نوشته
    12
    سپاسگزاری شده
    5
    سپاسگزاری کرده
    0
    دوست عزیز این روشی که شما گفتی، اون چیزی نیست که این بنده خدا می خواهد.
    اولا اینکه ایشان به گفته خودشان ضاهرا تنها یک ip valid دارند، بنابراین امکان server publishing به وسیله static destination nat را ندارند و همچنین اگر چندین valid ip موجود می بود ، config ای که گفته اید server publishing را انجام نمی دهد و سرور ها از سمت اینترنت قابل دسترس نخواهند بود.
    در واقع config شما تنها Static Source nat را انجام میدهد.در واقع برای server publishing باید config مربوط به
    static destination nat نیز اضافه شود.که برای مثال اینگونه است :

    ip nat outside source static 1.1.1.1 192.168.0.10
    ip nat outside source static 1.1.1.2 192.168.0.11

    و ام اگر همان یک valid ip موجود باشد باید ار port forwarding استفاده کردیعنی باید شماره پورت های ایی که می خواهید بر روی سرور از بیرون قابل دسترس باشند را از روی روتر به سمت سرورهایتان forward کنید، کافی است به کانفیگ nat overload که خودتان انجام دادید این دستور اضافه شود:

    ip nat inside source static tcp 192.168.0.10 80 95.195.48.38 80 extendable

    ip nat inside source static tcp 192.168.0.11 3389 95.195.48.38 3389 extendable

    با این کار مثلا پورت 80 و 3389 بر روی دو سرور از طریق یک ip valid از بیرون قابل دسترسس خواهد بود.



  9. #9
    نام حقيقي: Hamidreza

    عضو غیر فعال
    تاریخ عضویت
    Sep 2008
    محل سکونت
    tehran
    نوشته
    33
    سپاسگزاری شده
    4
    سپاسگزاری کرده
    3
    با سلام
    پويا خان من شرمندم ولي اون كانفيگي كه من گفتم كار ميكنه. اگه باور نمي كني امتحان كن.



  10. #10
    نام حقيقي: ali

    عضو عادی
    تاریخ عضویت
    Apr 2008
    محل سکونت
    a
    نوشته
    27
    سپاسگزاری شده
    1
    سپاسگزاری کرده
    3
    ممنون از همگي

    من به تعداد مورد نياز IP valid دارم يعني اوون 2 تا سرور من IP valid دارند. ضمناً كاربران براي اتصال به اينترنت بايد يك VPN Connection بزنن و از رنج IP هاي Nat شده بگيرن يعني IP هاي شبكه داخلي من روي روتر مستقيماً NAT نميشن.



  11. #11
    نام حقيقي: pooya

    عضو غیر فعال
    تاریخ عضویت
    Oct 2009
    محل سکونت
    tehran
    نوشته
    12
    سپاسگزاری شده
    5
    سپاسگزاری کرده
    0
    حمید رضا جان، شما صحیح می فرمایید، کانفیگ شما کاملا درست است. البته من کانفیگی که گفتم را جایی انجام دادم کار می کرد،اما بررسی کردم داستان آنجا با شرایط این دوست ما متفاوت بود. و در مورد server publishing با یک ip valid هم فکر کنم درست گفتم.



  12. #12
    نام حقيقي: ali

    عضو عادی
    تاریخ عضویت
    Apr 2008
    محل سکونت
    a
    نوشته
    27
    سپاسگزاری شده
    1
    سپاسگزاری کرده
    3
    كسي چيزي به نظرش نميرسه؟؟؟؟







کلمات کلیدی در جستجوها:

تنظیمات nat

تنظيمات nat

تنظیم nat در روتر

NAT تنظیمات

کانفیگ nat روتر سیسکوتنظیماتnatتنظیم natتنظیم destination nat روی سیسکوتنظیمات dnatدستور nat در روترتنظیم nat در سرور ip virtual-reassembly ودستور ip virtual-reassembl در روترنوشتن nat در روترport forwardingتنظیماتip در روتر چیستتنظیمات nat در مودم2640تنظیم server publishing روی cisconat تنظیم ciscoتنظیمات NAT در ویرچوالتنظیمات برای natتنظیم valid ip natip virtual-reassembly دستور روتر ip nat تنظیمات nat روی روتر

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •