نمایش نتایج: از شماره 1 تا 8 از مجموع 8

موضوع: مشکل با gre tunnel

  
  1. #1


    خواننده شناسه تصویری miskoolak
    تاریخ عضویت
    Jan 2006
    نوشته
    237
    سپاسگزاری شده
    49
    سپاسگزاری کرده
    21

    مشکل با gre tunnel

    سلام

    آقا من 2تا روتر دارم که بینشون gre زدم و نتورک ها رو روت کردم . همه چیز مثل بنز کار میکنه کاربرای هر دو سایت طرف مقبل رو میبینن . امااااا روترها فقط روتر مقابل رو میبینن (هم public ip هم private ip) ولی کلاینت های پشت سر روتر مقابل رو نمیتونن ببینن ! trace هم که میکم میندازه تو تونل بعدش هیچی به هیچی! از یه طرف هم مشکلی تو روتینگ نیست چون کار بر پشت روتر 1 کاربر پشت روتر2 رو ping میکنه ولی از روتر1 کاربر پشت روتر 2 ping نمیشه.

    ممنون میشم اساتید راهنمایی بفرمایند.



    موضوعات مشابه:
    No Body Leaves For Ever !!!





  2. #2
    نام حقيقي: Ehsan Vahdati

    عضو غیر فعال شناسه تصویری arminvox
    تاریخ عضویت
    Feb 2005
    محل سکونت
    Tehran
    نوشته
    171
    سپاسگزاری شده
    98
    سپاسگزاری کرده
    53
    در صورت امكان كانفيگ روترهاتون رو بگذارين تا بهتر بتونيم راهنمايتون كنيم .



  3. #3
    نام حقيقي: naderpour

    خواننده
    تاریخ عضویت
    Aug 2008
    محل سکونت
    جاده ابریشم
    نوشته
    742
    سپاسگزاری شده
    381
    سپاسگزاری کرده
    245
    Access-list ها رو چک کنید



  4. #4


    خواننده شناسه تصویری miskoolak
    تاریخ عضویت
    Jan 2006
    نوشته
    237
    سپاسگزاری شده
    49
    سپاسگزاری کرده
    21
    Current configuration : 4718 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname r1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    aaa new-model
    !
    !
    aaa authentication login default local
    aaa authentication enable default enable
    aaa authentication ppp default group radius
    aaa authorization exec default local
    aaa authorization network default group radius
    aaa accounting exec default start-stop group radius
    aaa accounting network default start-stop broadcast group radius
    !
    !
    aaa session-id common
    !
    !
    ip cef
    !
    !
    no ip domain lookup

    ip name-server 206.225.91.113
    ip name-server 208.67.222.222
    ip name-server 217.218.127.104
    !
    multilink bundle-name authenticated
    !
    vpdn enable
    !
    vpdn-group 1
    ! Default PPTP VPDN group
    accept-dialin
    protocol pptp
    virtual-template 1
    l2tp tunnel password 7
    !
    !
    voice-card 0
    no dspfarm
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    username xxxxxxxxxx
    !
    !
    class-map match-any 111
    match access-group 111
    class-map match-any p2p
    match protocol bittorrent
    match protocol edonkey
    match protocol kazaa2
    match protocol skype
    match protocol icmp
    match protocol gnutella
    !
    !
    policy-map 111
    class 111
    police 512000 512000 conform-action transmit exceed-action drop
    policy-map p2p
    class p2p
    police 8000 conform-action transmit exceed-action drop
    policy-map 256k
    class class-default
    police 256000 conform-action transmit exceed-action drop
    policy-map 512k
    class class-default
    police 512000 conform-action transmit exceed-action drop
    !
    !
    !
    !
    !
    !
    !
    interface Tunnel0
    ip address 1.1.1.1 255.255.255.252
    no ip redirects
    no ip unreachables
    keepalive 5 4
    tunnel source FastEthernet0/1
    tunnel destination xxxxxxx
    tunnel key xxxx
    !
    interface Tunnel1

    ip address 1.1.1.5 255.255.255.252
    shutdown
    keepalive 10 3
    cdp enable
    tunnel source FastEthernet0/1
    tunnel destination xxxxxxxxx
    tunnel key xxxxxxxxx
    !
    interface Tunnel2
    description Tunneled To r2
    ip address 1.1.1.9 255.255.255.252
    no ip redirects
    no ip split-horizon
    no ip mroute-cache
    cdp enable
    tunnel source FastEthernet0/1
    tunnel destination xxxx
    tunnel key xxx
    !
    interface FastEthernet0/0
    description Connection to LAN
    ip address xxxx 255.255.255.0
    no ip unreachables
    ip nat inside
    ip virtual-reassembly
    duplex auto
    speed auto
    h323-gateway voip interface
    !
    interface FastEthernet0/1
    ip address xxxx 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nbar protocol-discovery
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    service-policy input p2p
    service-policy output p2p
    !
    interface Virtual-Template1
    ip unnumbered FastEthernet0/0
    no ip unreachables
    ip nat inside
    ip virtual-reassembly
    peer default ip address pool pool1
    ppp encrypt mppe auto passive
    ppp authentication ms-chap ms-chap-v2
    !
    ip local pool pool1 192.168.254.10 192.168.254.40
    ip route 0.0.0.0 0.0.0.0 xxxx

    ip route xxxx 255.255.255.0 Tunnel0
    ip route xxxx 255.255.255.0 Tunnel2
    !
    !
    no ip http server
    no ip http secure-server
    ip nat inside source list 101 interface FastEthernet0/1 overload
    !
    access-list 101 permit ip 192.168.254.0 0.0.0.255 any
    access-list 111 permit ip any any
    snmp-server community xxx RO
    !
    !
    !
    !
    !
    radius-server host xxxx auth-port 1645 acct-port 1646
    radius-server key 7 xxxxx
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    gatekeeper
    shutdown
    !
    !
    line con 0
    privilege level 15
    logging synchronous
    line aux 0
    no exec
    line 1/0 1/7
    line vty 0 4
    privilege level 15
    logging synchronous
    transport input ssh
    line vty 5 15
    privilege level 15
    logging synchronous
    transport input ssh
    !
    scheduler allocate 20000 1000
    !
    end



    r2#sh run
    Building configuration...

    Current configuration : 2370 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname r2
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    !
    no ip cef
    !
    !
    !
    multilink bundle-name authenticated
    !
    vpdn enable
    !
    vpdn-group r2
    ! Default PPTP VPDN group
    accept-dialin
    protocol pptp
    virtual-template 1
    l2tp tunnel password 7
    !
    !
    voice-card 0
    no dspfarm
    !
    !
    !
    voice service voip
    h323
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    username xxxxxxxxxxxxxxxxxxxx
    !
    !
    !
    no crypto ipsec nat-transparency udp-encaps
    !
    !
    !
    !
    interface Tunnel1
    ip address 1.1.1.6 255.255.255.252
    shutdown
    cdp enable
    tunnel source FastEthernet0/1
    tunnel destination xxxxxxxxxxx
    tunnel key xxxxxxx
    !
    interface Tunnel2
    description Tunneled to r1
    ip address 1.1.1.10 255.255.255.252
    no ip redirects
    no ip unreachables
    no ip split-horizon
    cdp enable
    tunnel source FastEthernet0/1
    tunnel destination xxxxxxxxxxxx
    tunnel key xxxxxx
    !
    interface FastEthernet0/0
    description r1_LAN
    ip address 192.168.240.100 255.255.255.0
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    description INTERNET
    ip address xxxxxxxxxxxxxxxx
    ip virtual-reassembly
    no ip route-cache
    duplex auto
    speed auto
    !
    interface Virtual-Template1
    ip unnumbered FastEthernet0/1
    peer default ip address pool pool1
    ppp encrypt mppe auto required
    ppp authentication ms-chap ms-chap-v2
    !
    ip local pool pool1 1xxxxxxx
    ip route 0.0.0.0 0.0.0.0 xxxxxxx
    ip route xxxxx 255.255.0.0 Tunnel2
    ip route xxxxx 255.255.255.0 Tunnel2
    ip route xxxxx 255.255.255.0 Tunnel2
    !
    !
    no ip http server
    no ip http secure-server
    ip nat inside source list 100 interface FastEthernet0/1 overload
    !
    access-list 100 permit ip 192.168.240.0 0.0.0.255 any
    snmp-server community xxxxxx RW
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    voice-port 0/0/0
    !
    voice-port 0/0/1
    !
    voice-port 0/1/0
    no battery-reversal
    !
    voice-port 0/1/1
    !
    voice-port 0/1/2
    !
    voice-port 0/1/3
    !
    !
    !
    !
    !
    dial-peer voice 1 pots
    destination-pattern 999
    port 0/0/0
    !
    dial-peer voice 2 voip
    destination-pattern .T
    session target ipv4:xxxxxx
    !
    !
    !
    !
    gatekeeper
    shutdown
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login local
    !
    scheduler allocate 20000 1000
    !
    end



    No Body Leaves For Ever !!!

  5. #5
    نام حقيقي: naderpour

    خواننده
    تاریخ عضویت
    Aug 2008
    محل سکونت
    جاده ابریشم
    نوشته
    742
    سپاسگزاری شده
    381
    سپاسگزاری کرده
    245
    چرا 2 تا Tunnel روی هر روتر تعریف کردید ؟
    شما که همه ی IP هارو x گذاشتید !
    با abcd یا یک رنج دیگه مشخص می کردید که قابل درک تر باشه



  6. #6


    خواننده شناسه تصویری miskoolak
    تاریخ عضویت
    Jan 2006
    نوشته
    237
    سپاسگزاری شده
    49
    سپاسگزاری کرده
    21
    ممنون از پیگیریتون . در مورد تعداد تانل ها روی روتر اول 3 تانل هست که اولی به یه نقطه دیگس دومی شات هست و سومی به همین روتری هست که کانفیگش پایین تر اومده توی روتر دومی هم 2 تا تانل هست که اولی شاته دومی هم به روتر اول هست ! در مورد ip ها حق با شماس !


    No Body Leaves For Ever !!!





  7. #7


    خواننده شناسه تصویری miskoolak
    تاریخ عضویت
    Jan 2006
    نوشته
    237
    سپاسگزاری شده
    49
    سپاسگزاری کرده
    21
    مشکل حل شد !

    وقتی از خود روتر ping میکنم source add رو ip تونل میزاره حالا دستگاهی که پشت روتر مقابل قرار داره بیچاره روت برای ip رنج تونل رو نداره.


    No Body Leaves For Ever !!!

  8. #8
    نام حقيقي: Reza ARYAGOHAR

    مدیر بازنشسته شناسه تصویری aryagohar
    تاریخ عضویت
    Jul 2003
    محل سکونت
    Sydney ,Australia
    نوشته
    3,056
    سپاسگزاری شده
    942
    سپاسگزاری کرده
    215
    کلا روتینگ هات هم اصولی درست نیست. از Dynamic Routing استفاده کنی بهتره. ترجیحا EIGRP



کلمات کلیدی در جستجوها:

http://forum.persiannetworks.com/f63/t25791.html

تونل gre

ip split-horizon

راهنمایی پیکربندی تونل روی روتر

pptp مشکل gre

تونبل gre

tunnel

مشکل gre tunnel

Auto Tunnel cod

tunnel icmp مشکل

برچسب برای این موضوع

مجوز های ارسال و ویرایش

  • شما نمی توانید موضوع جدید ارسال کنید
  • شما نمی توانید به پست ها پاسخ دهید
  • شما نمی توانید فایل پیوست ضمیمه کنید
  • شما نمی توانید پست های خود را ویرایش کنید
  •